Hot answers tagged

5

First make sure that hibernation is disabled - so boot into Windows, open command prompt as administrator and execute : powercfg /h off. Shutdown the PC completely - do NOT reboot. Then install GRUB boot loader to your Ubuntu installation in EFI mode. Boot from the Ubuntu installation media, open a terminal and execute: sudo mount /dev/sda8 /mnt sudo ...


3

Ok I seem to have got it with the following (everything is simple in retrospect): $ umount /boot I tried this as I noticed that there were two 'mounts' for /boot: $ mount -l |grep boot /dev/md1 on /boot type ext3 (rw,relatime,data=ordered) none on /boot type aufs (rw,relatime,si=6ea5aad590be877d) And that the latter was overriding the former: $ df -h ...


2

The two issues are just one: your sda has an MBR partitioning scheme (that's why no EFI partition on it) and your sdc has a GPT partitioning scheme. That's an incompatibility. The install source device (sdc) and the target (to install to) device MUST have the same partitioning scheme in order for GRUB to install correctly. It can be MBR --> MBR, or GPT --> ...


2

If anyone still cares its actually videoinfo for grub-efi


1

Usually nothing. The bkpbootx64.efi is a backup regularly created by Boot-Repair. With Windows the bootx64.efi is just really a copy of Windows bootmgfw.efi. And bootx64.efi is a fallback or hard drive boot entry in UEFI. But Boot-Repair with its 'Use the standard EFI file` in advanced options creates the bkpbootx64.efi and makes bootx64.efi a copy of ...


1

Boot into Windows and download and install EasyBCD. Run it, and click "BCD Deployment, click "Write MBR" and then install BCD on your Windows partition (This case NTFS Partition 4). Now go to "Add New Entry" and select your Windows partition, then click "Add Entry". Next, go to the Linux tab and select GRUB2 and select "Automatically Locate and Load" then ...


1

Here you go. https://www.youtube.com/watch?v=IQIaDO9nR6Y I've seen plenty of positive comments, so I think that video should work!


1

To force it to come up every time, you need to edit the file /etc/default/grub for example with sudo nano /etc/default/grub comment out the line GRUB_HIDDEN_TIMEOUT=0 so it looks like #GRUB_HIDDEN_TIMEOUT=0 and make sure GRUB_TIMEOUT is set to something above 0 and enough seconds for you to do something when you get to the screen, for example ...


1

Some key things I've noticed about your output: You have two EFI System Partitions (ESPs), /dev/sda1 and /dev/sdb1. This is legal, but makes it harder to troubleshoot the computer. Your /dev/sda1 ESP seems to be empty -- or at least, Boot Info Script has not identified any boot files on it. This could be a bug in Boot Info Script (it misses things ...


1

Try this from an Ubuntu Terminal Window: sudo efibootmgr -o 0 That should fix the problem. Alternatively, you could use EasyUEFI in Windows to move the ubuntu entry to the top of the boot order list. EDIT: If it's resetting to boot straight to Windows when you reboot the computer without booting into Windows, then your EFI is badly broken. Check the ...



Only top voted, non community-wiki answers of a minimum length are eligible