Tag Info

Hot answers tagged

17

What about this command: convert -background black -size 800x480 -fill "#ff0080" -pointsize 72 -gravity center label:'Ask Ubuntu' output.png By using above command you create an empty .png image which its background color is black. -background color    set the background color.    the default background color (if none is ...


10

After searching I found the answer in launchpad. This is an issue with xorg.conf file actually. One can generate the xorg.conf file by using the command sudo aticonfig --initial if one is having the AMD driver. Else one may try sudo nvidia-xconfig if one has nvidia graphic driver. Then one needs to open the xorg.conf file by running the below ...


9

As you get the following error: Error: alternatives are not set up properly You may try to set the alternatives yourself. When I switch to Intel I see: update-alternatives: using /usr/lib/nvidia-331-prime/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in manual mode update-alternatives: using ...


9

That software checks /etc/lsb-release and that is a text file we can edit ourself so it might be fairly easy to circumvent. Make a backup first though if you do not know what this means. From a command line: sudo cp /etc/lsb-release /etc/lsb-release.backup And then edit the file ... sudo gedit /etc/lsb-release And change the lines that look like ...


8

I have ubuntu 13.04 64 bit and same problem: Nvidia GTX 750ti and no boot. I solve by following these steps: go on nvidea driver download I have get NVIDIA-Linux-x86_64-334.21.run put it in a folder you remember (your home) and make it executable (chmod u+x ./NVIDIA-Linux-x86_64-334.21.run) sudo apt-get purge nvidia* sudo apt-get purge ...


8

This is a bug (LP #1214508). You can switch using: sudo prime-select intel sudo prime-select nvidia Also, Bumblebee is still supported so you can install it if you prefer. You'll have to remove nvidia-prime then as you can't use both.


7

The backend is different: Compiz uses a 3D compositor to display the windows. Whereas Metacity displays the windows in 2D. So if you have a low end graphics card and/or want to save energy on a mobile device I would suggest that you use metacity. There also used to be problems with 3D applications in combination with compiz.


7

I didn't see any errors in the Xorg.0.log file the radeon driver seems to work well so try to create a Modeline for the unsupported resolution. Open a terminal with Ctrl+Alt+t and type: cvt 1366 768 It should return: # 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz Modeline "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync ...


7

On some computers the new versions that are installed with the intel-linux-graphics-installer have those exact same issues, I had it happen with two netbooks so it dosn't seem to be a conflict between nouveau/intel but a problem with the newer graphics installed from Intel. First you need to remove the source that Intel installed automatically when you ran ...


7

I found a solution: installed Imagestick: sudo apt-get install imagemagick And then I used something like: convert -pointsize 36 -fill red -draw 'text 10,10 "Loh pidr text" ' b.png test1.jpg And then use man convert to see documentation and play aroud.


7

If we were talking about outside video, I would make a simple SVG in inkscape with a placeholder string like OLISTRING, get it how I want it to look then manipulate that on the command line to substitute my dynamic text in. And use Inkscape to rasterise it. inkscape -z -e intro.png -w 1920 -h 1080 <(sed 's/OLISTRING/My Video!/' drawing.svg) The real ...


7

I think I found the fix. Source: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1314367/comments/22 so far so good. I'll update this if it starts flickering again. For those that are wondering, you need to install compizconfig-settings-manager first from terminal. sudo apt-get install compizconfig-settings-manager Open it and go to workarounds and ...


6

The root of the problem described above is probably a lightdm bug: https://bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/1292467. I had this problem on an Atom Mini-ITX motherboard with Intel NM10 graphics which includes an internal LVDS display port. The Boot with "video=LVDS-1:d" workaround solved it for me. Instructions for making the boot option ...


6

This may be the cause of your problems: Nvidia-Prime Freeze Theese two things have worked for me so far; either: Disable touchpad in: System settings -> Mouse & Touchpad -> "off" and use a regular USB mouse. Install nvidia-prime sudo apt-get install nvidia-prime, find "Nvidia Settings" in dash, and under "Prime Profiles" choose "Intel(Power saving ...


5

If you can access a terminal use sudo poweroff. You can access a TTY by pressing Ctrl+Alt+F1; TTY is just a terminal. You can return to the graphical desktop by pressing Ctrl+Alt+F7. Otherwise you can use kernel interupts to safely shutdown the computer: Ctrl+Alt+Print Screen+R,E,I,S,U,B (Hold down Ctrl, Alt, and Prnt Scrn then press REISUB in that order ...


4

sudo gedit /etc/default/grub find this line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and change it to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor" and then: sudo update-grub That works for my HP ProBook. Here is where i found the solution: http://www.techjail.net/solved-brightness-problem-in-ubuntu-12-04-precise-pangolin.html


4

There are a few GUI tools available to control and monitor AMD open-source graphics under Linux but none of them are as easy to use or install as AMD's CCC: DriConf - GUI for controlling the direct rendering settings (OpenGL) of all open-source drivers. Pretty hard to use and hasn't been updated since 2006. Phoronix has an overview and comparison to AMD's ...


3

Available graphics drivers won't be appear on the additional drivers tab if you fail to add the below to your System. sudo add-apt-repository ppa:xorg-edgers/ppa sudo apt-get update Now go to Software and Updates and select additional drivers tab. You will see the available options.


3

you can use glxinfo to test if your X server is using the GPU driver. glxinfo queries X server about its OpenGL version, renderer string, Visuals supported and other infomation. glxinfo | less


3

To solve my problem I had to enter the following commands: sudo apt-get remove --purge xserver-xorg sudo apt-get install xserver-xorg sudo dpkg-reconfigure xserver-xorg And then: sudo reboot But I think that if you on pure text mode, you don't need to reboot your computer, but you would have to do sudo /etc/init.d/gdm stop before you type the commands ...


3

No, a GPU is not necessary for Ubuntu to run on the system. However, if you don't have a serial console or some other management interface with which to visually see what you are doing on the system, you may find it difficult to work through the installation process.


3

Before you proceed with the following please consider removing other nvidia drivers that might conflict. For the latest proprietary Nvidia driver the following commands may be issued : sudo apt-add-repository ppa:xorg-edgers/ppa sudo apt-get update sudo apt-get install nvidia-current nvidia-settings For Nvidia Optimus technology (Nvidia+Intel) and the ...


3

Go see for yourself. Download an Ubuntu Desktop ISO, create a bootable USB stick or burn a DVD, boot it up and select "Try Ubuntu". This will not alter your hard drive or install anything, Ubuntu will be run from the installation medium. If you like it, just click on the "install" icon on your desktop.


3

Install the driver package using the command: sudo apt-get install xserver-xorg-video-radeon If it is already installed, then purge and reinstall: sudo apt-get --purge autoremove xserver-xorg-video-radeon \ && sudo apt-get install xserver-xorg-video-radeon You might need to reboot your system for the changes to take effect. (You can reboot ...


3

Your xorg.conf has two device sections: Section "Device" Identifier "aticonfig-Device[0]-0" Driver "fglrx" BusID "PCI:1:0:0" EndSection Section "Device" Identifier "intel" Driver "intel" Option "AccelMethod" "uxa" EndSection This is causing your machine to attempt to load both the fglrx and the intel ...


3

I think your computer has Optimus technology. There are two solutions: Nvidia prime The binary Nvidia driver added partial Optimus support in the 319.17 update. You can install this by typing sudo apt-get install nvidia-319 nvidia-settings-319 nvidia-prime in the terminal to install the binary Nvidia driver. Prime will disable the Intel card, so you ...


3

I installed a Lenovo Z50-70 laptop two days ago with an Intel HD 4400 integrated and with this Nvidia Geforce 840M GPU. I installed an Ubuntu 14.04 trusty thar on it (from an usb stick with UEFI boot). The system worked with the intel vga by default, yes, a current nouveau driver can't recognise the Geforce 840M. The easiest sollution to work with it: In ...


3

New Intel driver is the problem. Nvidia doesn't support new drm environment. To remove the new driver run the following commands: sudo apt-get purge i915-3.15-3.13-dkms sudo apt-get install --reinstall xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core sudo dpkg-reconfigure xserver-xorg Then restart the system. optirun should work ...


3

A while back, Spotify enabled hardware acceleration by default in the desktop client. On certain systems (not only Linux), incompatibility with the graphics drivers causes some content to fail to render. The suggested solution is to disable hardware acceleration in the clients' Preferences (Edit > Preferences): Applying this change requires a restart of ...


3

Most of the open source drivers you'll find may produce better graphical output than the proprietary do. Sometimes you won't even notice a difference. And sometimes an open source driver works much worse than the proprietary one. I will not make a general recommendation on which to use, but here are some cases, in which certain drivers are better than ...



Only top voted, non community-wiki answers of a minimum length are eligible