Tag Info

New answers tagged

1

Gnome and other DEs startup things use the .desktop files in ~/.config/autostart and /etc/xdg/autostart to know what to start. A basic solution would be to examine these files and see what commands are executed, then manually add it to the config: grep -r Exec /etc/xdg/autostart/ Note this includes ones that are disabled (by OnlyShowIn, ...


0

I faced the same problem. As I found out, it was caused by setting the DISPLAY variable in my user's .bashrc (and .profile) to 'localhost:0.0'. After commenting this definition out, I was able to log in to GUI. Otherwise, only terminal login (ctrl-alt-F1 or ssh) was possible.


0

I used gksu-properties to change the "Grab mode" to disable. simply type: gksu-properties in a terminal or run dialogue box. This changes weather the screen is "grabbed" or not while entering the password. Disabling this allows other applications to eavesdrop, a security vulnerability. But insistently it allows other applications to input to the ...


2

The answer is simple: Ubuntu's Notify OSD and GNOME Shell both ignore this parameter. Open the man page man notify-send and you can read this: -t, --expire-time=TIME The duration, in milliseconds, for the notification to appear on screen. (Ubuntu's Notify OSD and GNOME Shell both ignore this parameter.)


0

The short answer is, you can't. Evince 3.4.0 (on 12.04) had the option to hide the toolbar from the menu View > Toolbar then viewing Fullscreen or via F11 key will hide the toolbar in fullscreen mode. Apparently, this feature has been removed from newer version of Evince and it has been reported as bug on launchpad and in mailing list as well. Perhaps ...


1

The directories here contain source files of various packages. Source files are meant to be compiled by you, hence there is no question of these being installed automatically after downloading. So you can remove the files easily by traditional way i.e. rm. For example if you have downloaded the files in ~/foobar, you can remove these by (assuming there are ...


1

My opinion based answer is, I have fewer problems with GNOME 3.16 as with GNOME 3.14 in my GNOME Ubuntu 15.04 with proprietary nvidia drivers. A warning for not supported software is always good to avoid discussions. GNOME 3.16 is released since weeks and the PPAs have some patches included. That's a good sign for me. Ok, maybe there are some apps which ...


0

To solve your 'unmet dependencies' issue, I suggest using sudo apt-get -f install .


1

I'm going to assume that by "integrated calendar" you mean the one from the action bar at the top of the screen. You can refresh this by opening the Online Accounts application and toggling the Evolution Data Server entry for Access Your Google Calendar off and on again.


3

Here's a few command line tools you might not have been aware of. The good-old apt-get! Search with apt-cache search language-pack-gnome-xx, there xx is the code for language. In your case, if you want russian – apt-cache search language-pack-gnome-ru. There's two packages, actually, language-pack-gnome-ru and language-pack-gnome-ru-base. Running sudo ...


0

If you're using GNOME 3, you should be able to see programs' app indicators by "pushing" the mouse cursor against the bottom edge of the screen. The panel will then appear from the bottom edge.


0

I assume, it's not an answer but you could test my desktop files. Both files start Eclipse Mars in an Ubuntu 15.04 with a GNOME 3.16 environment. With tis desktop files, I have two running instances which are not grouped. cat ~/.local/share/applications/opt_eclipse_cpp.desktop [Desktop Entry] Encoding=UTF-8 Version=1.0 Type=Application Name=Eclipse C++ ...


2

Using the Activities Configuration. You can disable the hot corner and there are plenty of other settings. Open the URL via Firefox browser to install the extension directly. After that, open the Tweak Tool for the configuration


0

I realize that this is an old post but for the benefit of others who may be looking for an outliner as well, for what it's worth, I've just released a Gtk 2.0 based outliner for Ubuntu and derivatives (such as Mint) called Hiero. It's certainly no OmniOutliner but that said, it's targeted for use by those wanting to draft blog articles, dissertations, etc. ...


2

If you want modify aspects of Gnome Shell, you can use extensions from https://extensions.gnome.org/ In this case (with shell versions 3.8 to 3.18 currently), you can use No Topleft Corner extension (you can install by going the page and clicking 'Install', you will need the Gnome Shell Integration plugin installed and enabled in the browser). This ...


0

I did : cd $HOME cd .config rm -R * sudo reboot And I've found my desktop like the first day I create my user account, but all my software params are the same (firefox, thunderbird, filezilla...)


1

Install the dconf-editor sudo apt-get install dconf-editor Start the application and navigate to org.gnome.terminal.legacy Open the category profiles: and select the wrong profile, or check all profiles. In the right hand pane you will see a key custom-command. Remove the value or use the Button Set to Default in the lower pane.


-2

Try running this in MATE: sudo apt-get purge gnome-terminal; sudo apt-get update; sudo apt-get install gnome-terminal This will uninstall and purge the configs, then reinstall the latest version.


1

My solution to use pm-utils with PolicyKit With this way, you have to enter a password before suspend First install pm-utils, we need pm-suspend sudo apt-get install pm-utils After that, create a new script file and add the code below #!/bin/sh pkexec "pm-suspend" "$@" Open Keyboard via Activities menu and navigate to Custom Shortcuts and add a ...


0

You can just add this gksudo pm-suspend in Settings>>Keyboard>>Shortcut and map it to any key combination you want.


3

I tested the command mentioned here on Gnome 15.04, and it did the job well. The next thing to do is then to make it available under a shortcut key. The easiest way would be to create a small script of it: #!/bin/bash dbus-send --system --print-reply \ --dest="org.freedesktop.login1" \ /org/freedesktop/login1 \ org.freedesktop.login1.Manager.Suspend ...


0

try gconftool-2 --set /apps/gnome-terminal/profiles/Default/font --type string "Ubuntu Mono derivative Powerline 11"


0

This is safe to run for unity. Although, you should always carefully review the list of packages to uninstall before you agree to make the changes as you may have some other application that uses one of these as a dependency and it may get uninstalled automatically as a result. For example, this will most likely uninstall gnome-shell. Run the following ...


0

This is not something you should configure globally. I.e. you don't really want no new windows to take focus: you want no test windows to take focus. To accomplish this, use the Compiz Window Rules plugin to prevent all "test" Firefox windows from taking focus. You would need to write a rule to identify only "test" Firefox instances. If they all have a ...


1

You need a .desktop file, eg: [Desktop Entry] Encoding=UTF-8 Name=NetBeans IDE 8.0.2 Comment=The Smarter Way to Code Exec=/opt/netbeans-8.0.2/bin/netbeans Icon=netbeans Categories=Application;Development;Java;IDE Version=1.0 Type=Application Terminal=false StartupWMClass=NetBeans In /usr/share/applications/ or in ~/.local/share/applications/. After that, ...


3

If you have GDM instead of LightDM installed, then there is no guest session. The configuration of the guest session is part of the lightdm package. Therefore you could install lightdm to get the guest session back >:) sudo apt install lightdm apt – yes, in Ubuntu 15.04 you can use this command


0

I ended up restoring all my configuration files (~/.___) from a backup and that fixed it. But I never figured out what caused it.


2

The terminal way The terminal way is excellent described in answer of @GunnarHjalmarsson and in the answer of @Serg. The GUI way Start the Language Support via GNOME Shell or language-selector-gnome (GNOME 3.14) or gnome-language-selector (GNOME 3.16) in a terminal. Click Install / Remove Languages… and select one or more languages to install


0

In my case this did not work. The problem is a bug in ubuntu-drivers-common I had the same problem with my W530 and could solve it by downgrading > to ubuntu-drivers-common=1:0.2.91.4 sudo aptitude install ubuntu-drivers-common=1:0.2.91.4 sudo aptitude hold ubuntu-drivers-common This defect is still valid even with the latest update of ...


4

I wouldn't call it malware, it's just apport. If you just want to get rid of the message and you feel comfortable leaving apport enabled, you can run the following command (remember, apport can sometimes send sensitive info so leaving it enabled is an issue of privacy but it does help the developers take care of bugs and performance issues): sudo rm ...


2

That is a normal message. I recommend clicking "OK". While the message is open, you could xlsclients -al to list the clients of your X server (man xlsclients, of course). See also man xwininfo,man xprop and (shudder) man 7 X to track down which process has that popup open. Seriously, relax. Just the apport crash reporting system. man -k apport and dpkg ...


2

I'm aware of two ways. Either you install Language Support: sudo apt-get install language-selector-gnome and do it from there. Optionally you can just run these commands in a terminal window: sudo mkdir /usr/share/locale-langpack/ru sudo apt-get install $(check-language-support)


2

The command line way On AC Sleep timeout computer when on AC sleep-inactive-ac-timeout <time_in_seconds> 0 = off eg after 300 second: gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 300 Whether to hibernate, suspend or do nothing when inactive sleep-inactive-ac-type <hibernate|suspend|nothing> eg ...


3

You can use the AppIndicator support extension for gnome. Open a browser and go to the Gnome Extensions page. Click the “Off” button to “On” to install the extension in Gnome Shell. Once activated, you should see the appindicator icons in your system tray. Configuring the Appindicator support If you have not installed Gnome Tweak Tool, install it ...


6

The command line way add the values at the left side of : for buttons on the left side close,minimize,maximize: gsettings set org.gnome.desktop.wm.preferences button-layout "close,minimize,maximize:" add the values at the right side of : for buttons on the right side :minimize,maximize,close gsettings set org.gnome.desktop.wm.preferences ...


1

I've been going nuts over this just like you, but with Ubuntu 14.04 (LTS), Xubuntu, xfce 4.12 and xkbd (from xfce goodies). Ctrl+Space to change the keyboard layout worked, but Alt+Shift didn't (modifier-only keys). Finally managed to make things work- 1. Run ibus-setup (Keyboard Input Methods application). 2. Goto Advanced tab. 3. Check 'Use system ...


0

Execute sudo dpkg-reconfigure locales in an alternative terminal emulator and select en_US.UTF-8 UTF-8 , choose it as the default locale. gnome-terminal should work.


0

to disable functionality without having to add an extension is: sudo gedit /usr/share/gnome-shell-js/ui/messageTray.js find the line that says:this._traySummoned = false; and change the value to true (the line was 2198 on my version)


2

With the gnome-session-flashback, there are parts of it that use parts of Unity. So, not every part of Unity should be removed. LightDM is the Display Manger for Unity, where GDM is the Display Manager for the GNOME Desktop Environment. To install GDM it is: sudo apt-get install gdm During the install, it should come to screens like below: Press ...


2

As you don't actually specify that you wish to install Gnome 2.X (which is what gnome-session-flashback installs). If you wish to use the latest version of Gnome in the 3.X series, you can install ubuntu-gnome-desktop.


2

gnome-session-fallback is not available anymore for Ubuntu >14.04 , so in order to get that old gnome you should refer to the other package which is called flashback. sudo apt-get install gnome-session-flashback indeed gnome-flashback is exactly the same as gnome-fallback. Quoted from Gnome wiki: Gnome Flashback is a session for Gnome 3 which was ...


0

According to http://hplipopensource.com/hplip-web/supported_devices/index.html your HP Deskjet Ink Advantage 2645 All-in-one Printer printer should be supported in Ubuntu 14.04 with the deskjet_2640_series driver. $ lsb_release -dr Description: Ubuntu 14.04.2 LTS Release: 14.04 $ LANG=C apt-cache policy hplip hplip: Installed: 3.14.3-0ubuntu3.2 ...


1

With HP and newer printers best to install newest HPLIP directly from HP. There is a version of HPLIP in Ubuntu repository but it usually is older and does not support newest printers or features. You can get a Linux installer script directly from HP. Supports most Linux including Ubuntu and all its printers. Details in link on what exactly is supported. ...


1

Install GNOME 3.16 again, and yes, I'am sure sudo add-apt-repository ppa:gnome3-team/gnome3 sudo add-apt-repository ppa:gnome3-team/gnome3-staging Upgrade your system again, and yes, I'm sure ;) sudo apt-get update sudo apt-get dist-upgrade Now remove GNOME 3.16 in a clean way sudo apt-get install ppa-purge sudo ppa-purge ...


1

For 14.04: Go to System settings --> System --> Universal Access (or F2, type Universal Access) Choose Tab Pointing and Clicking Hover Click --> Off


3

xset - user preference utility for X r is to control autorepeat. xset -r 10 will disable autorepeat for the "1" key. xset r 10 will enable autorepeat for the "1" key. xset r [keycode] in my case keycode for space bar is 65 check for yours with code: xev | grep -A2 --line-buffered '^KeyRelease' | sed -n '/keycode /s/^.*keycode \([0-9]*\).* ...


0

It seems to be a strange issue between changes in python-xlib and DBus, but I am unable to find the exact issue. As a temporary workaround, you can disable X server access control with a simple xhost + before running AutoKey. Not a secure or ideal solution, but it works. You can add this to your ./profile to make sure it runs before AutoKey starts. Here ...


3

I've found a solution for you, but it doesn't involve Bounce Keys. What I do here is to deactivate the space key/keyboard for a small time each time space is pressed. So here it goes: We use xbindkeys to capture space bar press (in this case release) and xdotool to insert spaces. Install them if you don't have it on your system: sudo apt-get install ...


0

If the IP address of your VNC server is 1.2.3.4 (and running on the standard port), you might execute: ssh -L 5959:127.0.0.1:5900 user@1.2.3.4 This sets up an encrypted tunnel from your local machine's port 5959 that magically comes out on port 5900 at 1.2.3.4 Then you can VNC to localhost::5959 The above assumes that you're also running VNC on your ...


0

Here is another way, in case @Tim's answer doesn't work for some reason. Right click in the terminal, then click "Leave full screen".



Top 50 recent answers are included