Tag Info

Hot answers tagged

9

I'm running Firefox 23 in Ubuntu 13.04 with the Button instead the menubar. You can try the following.. 1) Disable the global menu in firefox: Open Firefox and in address bar type about:config then click to confirm in "I'll be careful, I promise" Search the key "ui.use_unity_menubar" and select it , then double click to change the value from true ...


8

To answer you directly - no its not "easy" for gnome-shell to have unity's global menu. However, there is an alpha quality gnome-shell global unity patch available (patch below). As to redisplaying the minimize-maximize and close decoration back-into gnome-shell - just use gconf-editor and change the key shown - note the position of the close - minimize - ...


5

Delete, Remove or Uninstall the package firefox-globalmenu Unity appmenu integration for Firefox This package provides an extension which adds support for the Unity appmenu to Firefox


5

Global menu is old and I don't think it is being actively developed anymore. Application Menu is under very active development by the Ubuntu community and Canonical employees. Application Menu supports way more apps than the old global menu.


5

For an application to use the global menu the environment variable $UBUNTU_MENUPROXY needs to be set to to the name of the menuproxy library to be used. For security reasons this variable is cleared when using sudo etc. to run a program as root. As a side effect this indicates which programs are run as root, otherwise it may be not always clear that the ...


4

The proper name is "application menu" to distinguish it from the older (and seperate project). The modules are indicator-appmenu and appmenu-gtk. Unless it's indicator specific most bugs should be reported against appmenu-gtk. https://bugs.launchpad.net/indicator-appmenu/ https://bugs.launchpad.net/appmenu-gtk Wiki page


4

appmenu-indicator is designed to be a desktop agnostic way to provide for a "global menu" from GNOME, GTK, and QT applications. gnome-global-menu is GNOME/GTK specific. That is just the surface. Programatically, there are several underlying fundamental differences. The loose description of each might seem the same but I would focus on appmenu-indicator in ...


4

To install Global Menu support for LibreOffice. Install lo-menubar from Ubuntu Software Centre or Use in Terminal use the command: sudo apt-get install lo-menubar


4

Simply install the "jayatana" package and restart the system. sudo add-apt-repository ppa:danjaredg/jayatana sudo apt-get update sudo apt-get install jayatana You will also need to enable the "GTK+" theme in PHPStorm (File -> Settings -> Appearance), otherwise I don't think it will work. Source


3

I used this solution to disable automatically starting unity-service-panel from starting. But you should be clear, unity-panel-service is not the panel on top bar, but it provides a service so that indicators can run on the panel. Solution: Move the unity-panel-service file to somewhere else cd ~ sudo mv /usr/lib/unity/unity-panel-service . This will ...


3

I agree, it is so much easier working with many windows if they have the menu in their window. I found this command to work. gsettings set org.gnome.settings-daemon.plugins.xsettings overrides '@a{sv} {"Gtk/ShellShowsAppMenu": <int32 0>}' That I found here, enter link description here


3

This instructionswork in 11.10 and earlier No and yes. There is not one currently supported just for xfce that works (an old one exists, but is broke-see below). However, you can use the "xfce-xfapplet-plugin" xfce plugin (listed in synaptic) to put the "gnome-applet-globalmenu" or the "indicator-applet-appmenu" onto the xfce panel. See my answer at the ...


3

You can also look at this post: http://www.webupd8.org/2011/09/get-global-menu-in-gnome-shell.html. It's about the same extension, but it provides instructions for different distros and Shell versions.


3

The Komodo team have just added support for the Unity Global menu here: http://community.activestate.com/node/9281 You can install it through Komodo's Tools > Add-ons dialog. Update for Komodo 8.0 The above mentioned add-on will not work for Komodo 8 so try this: http://community.activestate.com/node/9547


2

Ok. Solved the problem. The problem came from libgtk-3-0. A newer version (3.6.2) than the one in quantal archive ( 3.6.0-0ubuntu3.2 ) was still kept in the system. Actually, the GNOME3 PPA purging when I first did it, was not performed correctly due to a bug in the ppa-purge package in quantal official archives (multi arch bug). So I : installed a new ...


2

That is not possible. That's what the launcher (The "panel" on the left hand side) is for. Currently you don't have a lot of options to customize Unity, however if you do want to know what you can do, check out the "Unity Tweak Tool" which from 13.04 is available as a free download in the Ubuntu software center. If you want to do it from terminal then ...


2

This workaround does work partially, but has a very significant bug: Download lo-menubar_0.1.1-0ubuntu0.1_amd64.deb for amd64 or lo-menubar_0.1.1-0ubuntu0.1_i386.deb for i386 extract home/downloads/lo-menubar_0.1.1-0ubuntu0.1_i386.deb with file roller and sudo copy this folder: home/downloads/usr/lib/libreoffice/share/extensions/menubar to file ...


2

I had the same problem I was able to fix by installing unity-gtk-module-common unity-gtk3-module sudo apt-get install unity-gtk-module-common unity-gtk3-module Just to quote what I've already said on launchpad On side note why this has happened to me is cause of this bug during the upgrade: ...


2

Yes, it's a bug: See: https://code.google.com/p/chromium/issues/detail?id=306667 Star the issue to keep up to date.


2

How did you install Firefox? I'm using Firefox 13 on Ubuntu 12.04 and the menu bar appears on Unity (this is called "global menu bar"). This is done with an addon called firefox-globalmenu. If you somehow installed Firefox from a non-ubuntu package, that may be the problem. You can try opening a terminal and typing sudo apt-get install firefox-globalmenu ...


2

See this post on how to build and install gnome-globalmenu extension: http://www.webupd8.org/2011/09/get-global-menu-in-gnome-shell.html.


2

Another person has some private code for getting the indicator-appmenu working on Oneiric Ocelot Xubuntu 11.10. I am not sure I yet trust the code for either the ~koshi code or from aaronlewis1989. In any case, here is a link I found: OMG ! XFCE Global Menu [Oneiric Only]


2

I don't know why do you need to do that but in the image you provide the handle is right there as you can see when paying attention to the same image with a little amplification: In that image the handle seems not to be there but it is because of a visual effect by the theme that you are using. If you wish to remove the handle simply right clic over the ...


2

The easy way, If you want, you can install a plugin of Lxde panel like that http://home.student.utwente.nl/j.vanderhoff/downloads/LXglobalmenu.png (lxpanel is in bottom of screen) The package is here: http://home.student.utwente.nl/j.vanderhoff/downloads/


2

following the instructions under Ubuntu Desktop Installation on this wiki page https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationMenu will get you global menu on maverick


2

The "Global Menu Panel Applet" has not been ported to Maverick. The applet used with unity is called "Indicator Applet Appmenu" available in Synaptic as indicator-applet-appmenu. It is quite like the global menu applet. That being said, I prefer the "Global Menu Panel Applet" as it is more customizable than the "Indicator Applet Appmenu." To use the ...


2

This is a known (wishlist) bug. You may want to subscribe to it to get updated on its status.


2

I'm having the same problem, but I did not go through the installing/uninstalling GNOME 3.10. I think it just came with the regular ubuntu update. This unity-panel/global menu is such a headache, I don't know why the can't get it right. Anyway, this works for me for GIMP: * open a terminal and run: $ killall -HUP unity-panel-service This will reset the ...


2

I just actually upgraded to ubuntu 13.10 and got exactly the same problem. The appmenu is actually having a bug. So to fix the problem (workaround) I actually disabled the app menu. Run your application evolution using : UBUNTU_MENUPROXY=0 evolution The menu will be inside the application and not in the appmenu. Items will not be greyed out anymore. ...



Only top voted, non community-wiki answers of a minimum length are eligible