New answers tagged

0

it seems you are not in the right directory. to be sure, open a terminal and browse to that directory again with cd prog/c/learn. list the content of that directory with ls -l and see if GOODBYE.C is listed in the output


2

You can put your gcc command right after ssh command, such as ssh target@ip "gcc -o mybin main.c && ./mybin" will compile main.c in your target's home folder and if compiling is successful, run "mybin" to see output, if there is any output of this program.


2

gcc 4.8 had a bug related to this. You could try the workaround mentioned in the bug report: Add the flags -Wl,--no-as-needed to the compilation.


1

I had this issue - it was because Anaconda2 didn't have the GLIBCXX_3.4.20 version of whatever that thing is. Only up to .19, the same as yours. However, Ubuntu's library did have it. So I just created a softlink/shortcut in the Anaconda library to the actual Linux library containing that GLIBCXX_3.4.20, replacing the previous one, and it worked fine after ...


0

After struggling for a while, I found the solution to this problem. First sudo apt-get install aptitude, which works fine. Then try sudo aptitude install build-essential, which first says that there is something wrong and proposes a solution. The first solution it proposes keeps nothing change, which is not what we want, so choose no. And it proposes the ...


1

You can also customize the output file by using gcc <sourcefilename> -o <destinationfilename> Note: you can even dump the output file in a different folder by including the path in the file name. Ex gcc mysource.c -o ./myfolder/mybinary.out This will create a file named mybinary.out in the folder, myfolder, within your current working ...


1

When write programs in C, you must compile the program with a compiler (here gcc). So you get an executable file (here a.out). you should give that file execution permissions with the following command: chmod +x a.out and then run your compiled program with ./a.out


0

I rebuild with following packages and repositories. You need those packages: - - "build-essential" - "fakeroot" - "dpkg-dev" - "python-software-properties" - "software-properties-common" - "rsync" - "ubuntu-keyring" - "ubuntu-extras-keyring" - "debian-keyring" - "debian-ports-archive-keyring" - ...


1

You can upgrade your compiler, or just modify the setup.py file. Find the following line: extra_compile_args=['-std=c++11'])], And change the flag into -std=c++0x, which makes it: extra_compile_args=['-std=c++0x'])], And run it again, it should work with this. (Tested with the mimclib source code on github)


1

You need at least gcc 4.8 to compile this. See How to install gcc-4.8 for how you can install it on Ubuntu 12.04.


0

Okay so I've searched around a bit more and found that the "make" command doesn't work because the previous ./configure command doesn't work. I read the full error in the terminal and it said to install gmp, mpc and mpfr (Newest versions). In the gcc directory there is a file that downloads them for you and installs them nicely. Here's the link, It'll guide ...


2

Your gcc might be corrupted, try to re-install gcc-4.8: apt-get install --reinstall gcc-4.8


0

I got this error in branch 51. I found the problem is md5sum must link to libatomic when use gcc 5.x version. So, i modify the file <dir of webrtc>/src/chromium/src/tools/android/md5sum/md5sum.gyp as follows: diff --git a/tools/android/md5sum/md5sum.gyp b/tools/android/md5sum/md5sum.gyp index 9099ba9..177883d 100644 --- ...


3

For some reason, you have build-essential:i386 (the 32 bits version) installed, and your system, like you said, it's 64 bits (i.e., amd64). First, remove build-essential:i386: sudo apt-get remove build-essential:i386 Then install the 64 version: sudo apt-get install build-essential


-1

It Works fine for me, compiling Mame 0.172 on Linux Mint 17.3! (with qt5-default package installed previously sudo apt-get install qt5-default and executing on terminal this: export QT_SELECT=qt5 (for Qt5 version as default on system))


2

The 4: prefix to the version number is called the epoc. It is a way for Debian ( and hence Ubuntu, as a derived distribution ) to create a version of a package that is considered higher than previous versions, even if the regular version number is not. Sometimes various circumstances conspire to cause the need to release a new package that otherwise ...


1

You need to install linux-headers sudo apt-get install linux-headers-3.13.0-24 I am not sure this will be enough, because I don't know which other packages you do not have installed.



Top 50 recent answers are included