Tag Info

New answers tagged

1

This is python code extending with C. No need to use make. Python itself will take care of the cpp code compilation with proper flags. First you need to have header files and a static library. Install those as, sudo apt-get install python-dev Now follow these commands to execute example.py in your code. python setup.py build cp ...


2

After looking at https://github.com/hrldcpr/hungarian/blob/master/hungarian.cpp, it seems that you need both: #include "Python.h" #include "numpy/arrayobject.h" So install the following packages: sudo apt-get install libpython2.7-dev python-numpy To identify the missing packages (the ones providing the headers), look at packages.ubuntu.com.


0

Type "gcc" in terminal and then press Tab in your keyboard,the versions of gcc that are installed,will be shown. good luck


1

Open the Ubuntu Software Center, search for g++ (GNU C++ compiler) and install it if it has not already been installed. g++ is an optional package for Code::Blocks. Code::Blocks depends on either g++ or gcc in Ubuntu 14.04, and you can also install both g++ and gcc. Code::Blocks will automatically detect the path to the g++ executable without any ...


0

Unless you show us any error message, only suggestion is to use gdebi or open the deb in Ubuntu Software Center instead of using dpkg.


1

The g++ and gcc 4.8 compilers shoudl already be in 14.04 Try running this command: sudo apt-get install g++-4.8 gcc-4.8 and see if it works. It should then resolve the dependencies. You may then have to update the alternatives. Run this command afterwards to point everything to the 4.8.x compiler: sudo update-alternatives --install /usr/bin/g++ g++ ...


1

All you need is in the build-essential package sudo apt-get install build-essential


-1

You can open the file in any text editor. Try: nano file_name.cpp


0

The <iostream.h> header is old and deprecated. Instead you should use <iostream> which is the new header. If you still get an error about your header file then check your include directories. Go to "Option" > "Directories..." and check your "Include Directories" for example: /home/user/cpp/custom-includes/


0

I think that g++ is installed by default when you install gcc. Try to type in g++ in the terminal and see what happens. If you can't find it with what the previous person said, best chance of getting it is going to the GCC website and download the source and compile.



Top 50 recent answers are included