Tag Info

New answers tagged

0

I had a similar situation in the past, in my case the problem was that /bin/false is not a shell. (Sorry, can't explain better, forgot the background. I think it had something to do with PAM.) Many older tutorials recommend settings /bin/false as shell for no-login users, but the better choice is /usr/sbin/nologin. Try setting /usr/sbin/nologin as login ...


0

Files inside /bin/ need to be 755 except for symlinks those needs to be 777 and all are owned by root:root. Files inside /etc/ need to be 644 and owned by root:root except for (if you have any of these that is): -rw-r----- 1 root daemon 144 2007-02-20 13:41 at.deny drwxr-xr-x 2 root root 4096 2007-11-14 11:01 libpaper.d -rw-r----- 1 ...


0

I had the same problem & none of the suggestions about Write_enable or folder permissions worked. I changed my connection type in my FTP client from FTP to SSH/SFTP, and everything worked fine. Apparently, VSFTPD requires a secure connection to write.


0

TL;DR Download the latest version here and compile your own version. Currently there is no PPA for Ubuntu 12.04 with the version 1.3.4e/1.3.5. Compile your own version It is possible that you need some development libraries. If so, drop me a comment. cd wget ftp://ftp.proftpd.org/distrib/source/proftpd-1.3.4e.tar.gz tar xf proftpd-1.3.4e.tar.gz cd ...


0

I would consider using NitroShare. NitroShare is a simple file sharing GUI program. It can be installed using sudo add-apt-repository ppa:george-edison55/nitroshare sudo apt-get update sudo apt-get install nitroshare You can launch it from your Desktop's menu (Dash, in the case of Unity), and the program will open in the system tray. It will need to be ...


1

Hi you could maybe insted of print use echo, and insted of alias use ftp=host name, and dom as domain, and then use vpn hotspot, and put up an vpn and type this in: vpn=<ip adr> >> vpn_login=hostname nmcli -v -c -d <ip adr> -force--yes >> and it might work fine this way.


0

Not perhaps a direct answer; but I use a .netrc file: Script: cp ~/.netrc netrc.bak ; cp sqm-netrc ~/.netrc ; ftp ftp.anoth.er.uk ; cp netrc.bak ~/.netrc .netrc: machine ftp.somewebsite.com login username1.com password fgerghjvnfg machine ftp.anoth.er.uk login gdruug password vfohfgbsluv machine webhost.anoth.er.uk login vrfkbv password fbgvnfebuhb macdef ...


1

Shawn, As discussed on the HAProxy mailing list, I'm pretty sure you need to enable conntrack as well as ip_vs_ftp, then it should work fine.


2

The suggested resolution did not work for me. I gave up on the ftp user, and switched my attention to the ubuntu user. I made sure there was a password associated with the ubuntu user. I made sure to enable passive mode, and set local_enable=YES in the vsftpd.conf file. I was able to authenticate just fine using the ubuntu account. And I successfully ...


2

For vsftpd, the configuration is exceedingly simple: sudo apt-get install vsftpd then: sudo nano /etc/vsftpd.conf ensure you have the following parameters set right: # Depending on the version you're running, you might want to set the following # parameter to YES # (if affected by https://bugs.launchpad.net/ubuntu/+source/vsftpd/+bug/1313450) ...


1

Is there a reason you need to use that specific FTP server software? What you're looking for is mostly called "chroot" (change the root directory per user) or something similar. According to this bug report the netkit ftp server, that's contained in the linux-ftpd package, doesn't offer that feature. Event the launchpad page says This is the netkit ftp ...


1

To enable root login for SSH first enable root account by giving password to root sudo passwd Now, you need to edit /etc/ssh/sshd_config gksudo gedit /etc/ssh/sshd_config Remove the (#) comment from this line: PermitRootLogin without-password directly under it add this: PermitRootLogin yes Now restart SSH: sudo service ssh restart Enable Root ...


0

Simply add a file to /etc/pm/sleep.d In this file do you checks if suspend should be allowed. If not just exit with exit 1. For example: tmp_start=... tmp_stop=... if [ $((tmp_stop)) -gt $((current_date)) -a $((tmp_start)) -lt $((current_date)) ]; then logger $0: Currently RECORDING. No Suspend! exit 1; fi


0

Here is your answer. How Rinzwind said, you need a maximum of 664. Therefore 777-664=113 local_umask=0113 I quote: In case you are wondering where to set your umask, it can be set in the vsftpd config file (/etc/vsftpd.conf) as anon_umask for anonymous access and local_umask for users. For the mask to work properly (even without anonymous ...


0

This services starts as upstart to disable/manually start $echo 'manual' | sudo tee -a /etc/init/vsftpd.conf


0

Disable the service with this commands: sudo service vsftpd stop sudo mv /etc/vsftpd.conf /etc/vsftpd.conf.disabled sudo mv /etc/init/vsftpd.conf /etc/init/vsftpd.conf.disabled After then, make a test: sudo service vsftpd start ps xa | grep vsftp Now no process should run. You can do the whole thing undone: sudo mv /etc/vsftpd.conf.disabled ...


0

I'm sorry for sharing link, but this question was asked in StackExchange in past: link to question Please let us know if it's hepled you. Following by your description you are on 14.04 and it still using initd, that's true for this answer in serverfault.



Top 50 recent answers are included