New answers tagged

0

Not sure if its what your looking for, but i always install privacy badger on my Firefox to help get rid of potential trackers. Hope i could help. PS. privacy badger is multi browser: https://www.eff.org/privacybadger


1

Your question is pretty broad, but inferring from your first sentence about "different security measurements" for home, etc, I would recommend you try gufw gufw is a GUI front-end to the ufw firewall and it allows you to create profiles for home, etc. sudo apt-get install gufw As a simple solution, you can just set the default Incoming rule to Deny and ...


2

Looking at your tshark capture and your routing table. I supposed that your vpn network is using the same subnet as the docker0 interface. This will shutdown the docker0 interface: sudo ifdown docker0 But the problem will come back after a reboot. To properly fix it you should remove docker, or change subnet settings of docker, or change your vpn ...


1

You have not provided a return path. You need: iptables -t nat -A POSTROUTING -o ens33 -j SNAT --to 192.168.1.5 I assume it is just a typo in your PREROUTING line, but regardless I would do it this way anyhow: iptables -t nat -A PREROUTING -p tcp -i ens33 --dport 80 -j DNAT --to-destination 192.168.2.2:80 If your default policy for the FORWARD chain is ...


0

Surprised no one even suggested things to check but in the end I have solved it anyway. As I said in my problem description the server was a VM so when I was trying to access the 8080 port it was actually on the host not my VM. 8080 on the host was actually mapped to another VM and was not setup to receive anything. This issue was resolved by mapping port ...


0

So I ended up figuring out my problem, just posting an answer for anyone else potentially having the issue. The command: iptables -t nat -A PREROUTING -d outerip -p tcp --dport 80 -j DNAT --to webip Was what eventually allowed it to work. This rule appends the prerouting table to allow connections from the outer ip of the firewall, as long as they are ...


5

The bans are stored in a SQLite3 database in /var/lib/fail2ban. To open it you need the package sqlite3 installed and if you want a GUI, use a tool like sqliteman. The name of that database file is called: /var/lib/fail2ban/fail2ban.sqlite3


0

Since Ubuntu 14.10, the xrdp package provided by Ubuntu (Ubuntu repositories) allow you to reconnect to the same session. firewall wise, you should only need the port 3389 as the xrdp software is acting as a proxy. When you connect to port 3389, in your xrdp.ini file, you can see that additional connection is done through the ip 127.0.0.1 (itself) We ...


0

This post on reddit says that it's because of a broken dependency and the fix for that is: sudo apt-get install python-gobject After typing that in a terminal, I'm now able to start GUFW.


0

Your example log entry is for a TCP packet with the reset flag asserted. For TCP connections, Linux tends to use a "half-duplex" close sequence where either side of the session can initiate connection termination via a single 2 way FIN-ACK handshake (which puts the connection into the CLOSE_WAIT state), instead of a full 4 way FIN-ACK handshake. It is ...


0

One of the reasons, I found out in the meantime, is that the bridge will be working at ISO/OSI layer 2 and therefore firewalling is much more difficult (it requires specific marking of traffic - with the source port/NIC). Having separated bridges (and separated networks) makes firewalling more straightforward.


1

I have the same problem as Mookey but I can confirm that the solution by 2707974 is working for me! Let's see this step by step. If have Gufw set to incomming:deny and outgoing:allow with logging on. Then if I switch VPN on, the first contact to my VPN provider is allowed normally without any rules. When the VPN provider is calling back his call is ...


1

Let's start. I preferOpenVPN solutions OpenVPN Access Server supports a wide range of configurations, including secure remote access to internal network and/or private cloud network resources and applications with fine-grained access control. It has a mobile app for Android and iOS, so that you can access the VPN server from your smartphones too. Install ...


2

Command for deny whole 91.0.0.0/8 network is sudo ufw deny from 91.0.0.0/8 when you list rules sudo ufw status you will see To Action From -- ------ ---- ... Anywhere DENY 91.0.0.0/8 This will deny any traffic from ip's witch start with 91.x.x.x But I recommend ...


1

From the UFW MAN Page By default, ufw will apply rules to all available interfaces. To limit this, specify DIRECTION on INTERFACE, where DIRECTION is one of in or out (interface aliases are not supported). For example, to allow all new incoming http connections on eth0, use: Example : ufw allow in on eth0:0 to any port 80 proto tcp ...


0

you could also add. nameserver 8.8.8.8 to /etc/resolv.conf


2

You don't have DNS working. Add the directive to interfaces to enable it. dns-nameservers 8.8.8.8 Full Example for your configuration. auto lo iface lo inet loopback auto eth1 iface eth1 inet static address 192.168.5.1 netmask 255.255.255.0 gateway 192.168.5.254 dns-nameservers 8.8.8.8


2

You need much more to launch this type of app. When there is something missing in your profile it has no access to it. Sublimetext must have access to things like : X server system fonts Xauthority file dconf glib etc ... The best and easiest way to create your own profile is to install apparmor-utils sudo apt-get install ...


0

Check your Iptables, maybe there are some rules that aswell block your VPN connection. iptables -L ACCEPT VPN connections for INPUT aswell to OUTPUT at Iptables. iptables -A INPUT -p tcp --dport 47 -j ACCEPT iptables -A OUTPUT -p tcp --dport 47 -j ACCEPT If VPN connection works, then save rules iptables-save


1

PPTP vpn user port 47 aka GRE. To allow this traffic edit /etc/ufw/before.rules and add at the end of file sudo nano /etc/ufw/before.rules this # gre -A ufw-before-input -p 47 -j ACCEPT -A ufw-before-output -p 47 -j ACCEPT Then disable, enable ufw sudo ufw disable sudo ufw enable EDIT 1 Rules must placed in /etc/ufw/before.rules before segment # ...


0

This might not answer your question directly, however... Why not use PFsense or IPfire rather? They can do all you need and more. PFSense Ipfire



Top 50 recent answers are included