New answers tagged

-1

Sorry, Andre, I have no answer for you. I'm adding to this because I have a similar problem with an i5 6th generation Intel NUC booting Ubuntu 16.04. If I have a LAN cable plugged in, the system boots quickly and the LAN networking works as expected. I can get the wireless to connect to our wifi network, but if I unplug the LAN cable, the wireless network ...


1

You have blacklisted the r8169 module by installing r8168-dkms. This can be fixed by sudo apt-get purge r8168-dkms sudo rm /etc/modprobe.d/r8168-dkms.conf The second command may give no file found error, but it is OK.


0

Screenshot So this was the output while wired connection 1 was connected. @Ted .


0

After a while system repaired itself. What goes around comes around.


0

I had the same problem with my win8. Then I figure out that some settings in Windows may prohibit internet connecting in Ubuntu. I disable WOL (wake-on-lan) of power management in Wiondws 8 and then it works in Ubuntu.


1

Check (vi/nano) /etc/network/interfaces I willing to bet you only have lo interface. If so run dmesg | grep "eth0" it may tell you that eth0 has been changed to new name, then you will have to add the new interface name to /etc/network/interfaces. If above does not work try ifconfig to see if there is a new name. hope this helps!!


1

It seems that your particular card requires some additional proprietary software components to be installed which come with a licence that has restrictive distribution terms, this is why Ubuntu was unable to take care of this issue for you during the install. Seems that other users with same same installed hardware have already faced and resolved this ...


0

Are you sure your iMac is serving IP's via dhcp? Have you tried setting the IP manually when installing via ethernet?


0

Get an internet connection(i got through wifi). Use the command: sudo apt-get install r8168-dkms Enter your password. This will install the latest version of the driver. Ethernet connection should be established after installing (you may reboot & check again).


0

It seems to me to be a problem with the r8169 driver I had. I downloaded the r8168 driver from the Realtek website and now my ethernet connection works perfectly.


1

As you can see on this line: May 17 15:44:18 pi kernel: [ 0.971359] e1000e 0000:00:19.0 eno1: renamed from eth0 your network card gets renamed to eno1, so using ethtool eth0 will yield no results. You need to use ethtool eno1 Use lspci -v . This will show you what kernel module is handling your network card. If there is no module listed, you need ...


0

Nevermind, an update to Ubuntu 15.10 seems to have solved the problem. Additionally, learnt to cross-verify every operation against /run/network/ifstate as well.


0

it sounds similar to the problem that I have at the moment. Unfortunately I have not been able to find a solution yet but I will let you know if I figure it out. edit In the meantime please could you post the output of the following commands lspci | grep Ethernet ifconfig eth0 sudo lshw -class bridge sudo lshw -class network edit 2 For reference ...


0

you have 2 options Option 1 - usnig wifi dongle sudo apt-get update sudo apt-get install firmware-b43-installer Option 2 - but if you don't have internet connection 1 - Download firmware-b43-installer 2 - copy it to an usb flash 3 - mount it on your ubuntu (and extract it to your Desktop) 4 - open up terminal 5 : sudo mkdir ...


-1

My network was down after my last update as well. I ran update/upgrade from recovery mode and that solved it. I had to use the root terminal in recovery mode because my recovery mode is buggy. So I had to mount the drive RW manually and bring the network up, ifonfig eth1 up , which I don't think you have to do otherwise.


0

[Note: if you don't have your WiFi adapter plugged in, omit the commands containing wlan0] After boot, try running these commands: sudo su service network-manager stop ifconfig wlan0 down ifconfig eth0 down ifconfig wlan0 up ifconfig eth0 up service network-manager start


0

Amen, lemonsqueeze. I created a similar executable Bourne shell script in /etc/pm/sleep.d for 14.04 only. That worked fine under Upstart. Subsequently, I upgraded that particular machine to 16.04 (Systemd). New ball game: Create an executable Bourne shell script, /usr/local/bin/resume_r8169.sh: MYNAME=`basename` echo $MYNAME Begin modprobe -v -r ...


1

The issue arose due to a regression introduced with a fix for libnl3 bug #1511735. I resolved this issue by downloading a newer version of network-manager from another computer with a functional network connection. Here are the respective download links for the amd64 and i386 architectures. Copy the .deb file to a USB stick and install it on the affected ...


0

I can't add a comment for possible duplicate since I don't have enough reputation. What you say seems like what happened to me: a fix in libnl3 caused regression in network-manager. I answered it in more detail here: 14.04 - Network manager stopped working


0

You need to install build-essential and linux-headers . Offine install is answerd here or here Download the intel driver e1000e from here copy the file to src directory: cp e1000e-3.3.3.tar /usr/local/src/ unzip the archive tar zxf e1000e-3.3.3.tar Install make install unload and load driver: rmmod e1000e modprobe e1000e update initramfs ...


1

This answer summarizes the chat: You can either: let NetworkManager take care of network connections; make sure that managed=true in /etc/NetworkManager/NetworkManager.conf. Restart the Network Manager after changes: sudo systemctl restart NetworkManager. Obsolete entries in /etc/NetworkManager/system-connections can be deleted; if necessary, they will be ...


0

Check the driver required for your computer using lspci In my case: sumit@Lenovo-Z50-70:~/Documents/programs$ lspci 00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b) 00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b) 00:14.0 USB controller: Intel Corporation 8 Series ...


0

one of the main reasons for this PCI card not loading is the driver . I just had this issue a few moments ago , and the way i solve it was by installing this driver : https://gist.github.com/ttp/2390823 I also removed the card from PCI slot and put it there again just in case any bad contact was happening .


0

It was simply just faulty wiring. Sorry guys!


0

I'm not entirely sure if this will fix your problem, but I had the same issue with an Intel Centrino Advanced-N 6230 and this helped me: Unreliable wireless connection with an Intel Centrino Advanced-N 6230


0

Also adding few points that has helped me solve similar problems alongside what @sMurf has replied to; You can verify if the MAC address found on the device is same as that present in the /etc/udev/rules.d/*-persistent-net.rules This is more relevant if you are making use of a VDI image in Virtual Box or the equivalent environment. If in Virtual Box ...


0

I tried to mix some suggestions and I had found the solution! Step 1: Disable the default Firmware inherited names. Edit your /etc/default/grub changing the line from GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0" and, finally run as root: $ sudo update-grub and reboot your system. $ sudo reboot Step 2: Create the ...


0

Both are in the same subnet 10.0.0.0/24, AFAIK, this is will not work. Change the second one to another subnet/network, example: source /etc/network/interfaces.d/* auto lo iface lo inet loopback auto enp5s0f0 iface enp5s0f0 inet static address 10.0.0.241 netmask 255.255.255.0 gateway 10.0.0.205 dns-nameservers 10.0.0.205 auto enp5s0f1 ...


1

Another tool that you might want to employ is iperf. You can use this to determine if the local networking is killing your throughput. A reference is located at: https://iperf.fr/. You can simply generate high bandwidth loads and then check what that actual reported throughput is. If you have two nodes you can do the following check. First run sudo lshw -c ...


-1

I have a similar problem.I use wired 802.1x auth wich works fine with ubuntu 14.04 and 12.04 .In 16.04 works only if i write in clear text the password (password='mypassword') in /etc/NetworkManager/system-connections/myconn.


0

There is a typo in Jiang Junyu's answer, but it works anyway. auth="MSCHAPV2" network={ key_mgmt=IEEE8021X eap=PEAP phase2="auth=MSCHAPV2" identity="youridentity" password="yourpassword" }


0

Pinging 8.8.8.8 it's ICMP, DNS is not involved (but you still need it set properly ;-) "Destination host unreachable", it's ICMP control message type 3 code 1, most likely there is not route to to the target host. So the first thing is to check your routing table route -n ip route show Get the output. Try to ping your gateway first and see if that ...


1

I finally solved my issue. I went with the sudo nautilus in etc/modprobe.d/blacklist-bcm43.conf And then I deleted some lines of drivers that were blacklisted. In my case I removed the b43, b43firmware and b44. One reboot later, I got my wired connection back. But still don't know why bcmwl blacklisted these drivers ...


1

I think I finally found an answer to this problem. In the version 15.10 the TLP utilities has been introduced as default. So on dist upgrade you get a default configuration in TLP saying WOL_DISABLE=Y Even https://wiki.archlinux.org/index.php/Wake-on-LAN says if the computer does not wake after suspend/hibernate when using TLP, set the WOL_DISABLE value to ...


1

I use conky for this purpose. It shows live information about all the interfaces on your computer. This is a screeshot from my computer and as you can see on the right side(the red and green graphs) are all the interfaces my PC has. You can install conky with sudo apt-get install conky


2

If you use the command route there will be and entry in the table with the value 'Default' or '0.0.0.0' as destination field, then the 'Iface' field will be the interface (Ethernet or wifi) your computer is using to reach the internet. Example: $ route -n Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface ...


1

Change the "Network Adapter" to bridged mode in Oracle's Ubuntu VM system settings. If you need to set the static IP of the VM: Change the "Network Adapter" to bridged mode in Oracle's Ubuntu VM system settings. Start Ububtu VM Type ifconfig ifconfig returns enp0s3 and lo, therefore, Type sudo ifconfig enp0s3 192.168.0.111 netmask 255.255.255.0 and you ...


1

For this problem there could be many solutions So first of all lets find your wireless network adapter, you can do it by running following command lshw -C network If your adaptor manufacturer is Atheros, this solution should work for you. Solution 1: for slow WiFi in Atheros wireless network adaptors echo "options ath9k nohwcrypt=1" | sudo tee -a ...


0

so disabling ipv6 was only part of the problem. this got everything working for me: sudo sh -c "echo 'net.ipv6.conf.all.disable_ipv6 = 1' >> /etc/sysctl.conf" sudo sh -c "echo 'net.ipv6.conf.default.disable_ipv6 = 1' >> /etc/sysctl.conf" sudo sh -c "echo 'net.ipv6.conf.lo.disable_ipv6 = 1' >> /etc/sysctl.conf" sudo sysctl -p sudo sed -i ...



Top 50 recent answers are included