New answers tagged

0

I received an answer from Wolfram Premier service. They provided the prerelease of Wolfram Workbench 3, and recommends to use it in Ubuntu 16.04 instead of Workbench 2. Open .nb file again and you get a similar error /usr/local/Wolfram/Mathematica/9.0/Executables/Mathematica as in the screenshot of the body. I think Wolfram Workbench does not support ...


1

The cause If you install an application via apt-get, you can be pretty sure a correct .desktop file is installed in /usr/share/applications. That leaves us the only option that there must be an outdated .desktop file, representing Eclipse, in ~/.local/share/applications, most likely of a previous locally installed version, or some application must have ...


0

Try using a MENU editor to alter the launch command: MENU editor: sudo add-apt-repository ppa:caldas-lopes/ppa sudo apt-get update sudo apt-get install ezame


2

You can't get it directly from the standard Ubuntu repository, but you can add this PPA that has Eclipse 4.5 through apt: sudo apt-add-repository ppa:mmk2410/eclipse-ide-java Ref: https://launchpad.net/~mmk2410/+archive/ubuntu/eclipse-ide-java


0

By starting the application from the command line (the terminal) it is sometimes possible to get more information about why the program fails to start. For example (assuming that eclipse is in your path, otherwise start it from the folder where it is installed/unpacked): user@machine:~$ eclipse Unrecognized VM option 'MaxPermSize=256m' Error: Could not ...


0

'Java EE - Eclipse' list means you have the version of Eclipse for Java developers creating Java EE and Web applications. There are several 'flavours' of Eclipse available of which this is one. Open the 'Help > About' dialog to see more details about what you have installed.


2

Thanks for the tip. I had to change required version of java from : -Dosgi.requiredJavaVersion=1.7 into -Dosgi.requiredJavaVersion=1.8 and remove this line as well : -XX:MaxPermSize=256m Happy coding !


0

Edit eclipse.desktop as following: Exec=env SWT_GTK3=0 eclipse


0

Duplicated here (but not recognized as duplicate by askubuntu.com): http://stackoverflow.com/questions/3878445/ubuntu-error-failed-to-create-the-sd-card


1

Try to start Eclipse after editing your eclipse.ini file and tweaking the launcher entry like this: --launcher.GTK_version 2 Example file: -startup plugins/org.eclipse.equinox.launcher_1.3.100.v20150511-1540.jar --launcher.GTK_version 2 -product org.eclipse.epp.package.cpp.product --launcher.defaultAction openFile -showsplash org.eclipse.platform ...


0

I had this same problem of duplicated icon. but in my case it was caused because I double clicked in the eclipse executable and ask unit to lock it in the launcher. this action makes unity to create an eclipse.desktop file into ~/.local/share/applications where its "exec=" was set to java instead of eclipse executable. After I removed the one created by ...


0

I'm not sure it is the best solution, but it worked for me: remove old installation open installer as sudo open the menu in the upper-right corner of the installer and turn OFF Bundle Pools install the version you need after the installation is completed go to /opt and change the owner of the eclipse folder. It should be something like sudo chown -R ...


0

The answer listed here finally worked for me after trying several other solutions, none of which worked (Eclipse Mars 4.5.2, Ubuntu 14.04.3). I did have to edit one additional file though (gtk-main.css). If you run the "Ambiance" theme (default theme, dark), open these files and change all "bg" tooltip colors to #ffffff (white) and all "fg" tooltip colors ...


0

You may have to wait when a theme update will come out from Numix. I am having a similar problem with the Ambiance Aqua theme: can't enable overlay scrollbars. However the theme in eclipse mars 2.0 works just fine.


27

I had something the same with 16.04 and Eclipse Mars. I thought it had frozen but in fact it was running very, very slowly. The problem is the version of GTK+ 3, shipped with 16.04. Fortunately the solution is very easy. Open a terminal and then type export SWT_GTK3=0, then start Eclipse from the terminal. If that works, then a more persistent fix is to put ...


0

I fixed compilation from the command line with sudo apt-get --reinstall install openjdk-8-jdk-headless sudo apt-get --reinstall install openjdk-8-jre-headless I fixed Eclipse by deleting "~/.eclipse".


2

I found the solution when I was on my main machine, I'm now typing this on my tablet, so please excuse the brevity. If you type export SWT_GTK3=0 before invoking eclipse from a terminal, you will load quickly. Googling for 'eclipse' and 'SWT_GTK3' will find the bug report that led me to the solution.


1

I had the exact same problem as you experienced. Turns out a RAM memory module in my machine was broken. After removing the broken memory module everything went back to normal.


0

Look for your core-site.xml. Mine looks like this: <?xml version="1.0"?> <?xml-stylesheet type="text/xsl" href="configuration.xsl"?> <configuration> <property> <name>fs.default.name</name> <value>hdfs://localhost/</value> </property> </configuration> when i am running the code from my ...


0

First enable ADB over network on your android device by running Developer Options->ADB over network. On Ubuntu terminal, goto the folder where sdk platform tools are installed, for example (change <user> for your username): cd /home/<user>/Android/Sdk/platform-tools then run: ./adb connect <host>:<port> you will verify HOST ...


2

I've also posted this question on the Eclipse Forums: https://www.eclipse.org/forums/index.php/m/1728570/#msg_1728570 It seems to be an issue with Eclipse and GTK3. There is no real fix and it's not clear if they will back-port the fix from the next Eclipse release. Anyway, there are 2 ways to deal with this: 1) Define the environment variable SWT_GTK3=0, ...


1

This is probably Eclipse bug 489958 which is marked as being fixed in Eclipse Neon milestone 7 (4.6M7) which is not yet available. Eclipse Mars is really intended to be used with the current Java 8 release rather than Java 9 early access releases.



Top 50 recent answers are included