Hot answers tagged

22

You cannot uninstall GRUB. As your installation stands, GRUB is necessary to boot Ubuntu (that's why it's called the bootloader). Every OS has a bootloader, and every OS needs that bootloader to boot (lots of booting :P). EDIT: As people in the comments have pointed out, there are alternatives to using GRUB. However, there is no reason to switch to one, ...


8

All the other answers start good, advising you that GRUB is usually there whether you see it or not, you probably shouldn't start taking random potshots at it, and how to restore your system to the 'hidden GRUB' you (presumably) previously enjoyed. However, they end up going wrong - in making blanket statements that GRUB is always required, when this is ...


7

What you have tried to do will not work. Windows 10 is installed in UEFI (GPT) mode. You have to install Ubuntu in EFI mode as well. It is not possible to do this with Ubuntu in 32 bit. Install the recommended 64 bit edition of Ubuntu.


2

Okay. I fixed it. I'll explain for anyone that might ever come across this. On the GParted screenshot you see /dev/sdb/ extended has a key/lock infront of it. When I clicked info it said the following: Status: Busy (At least one logical partition is mounted) Alright. It was because I was booted into my Ubuntu. I burned GParted on a Live CD and booted that. ...


2

The problem in your case is that, in the image shown above your 289.09GB HDD is of MBR (Master Boot record)partition style which only supports up to 4 primary partitions (i.e blue partitions) . If you want more than 4 partitions then you have to create an extended partition such that the total HDD has 3 primary and 1 extended partition. Then from that ...


2

I had the same trouble with an NVMe disk. That technology is quite recent and the old version of GParted in Ubuntu repo couldn't see my SSD. I resolved creating a GParted live USB with the latest version of the software.


2

The partition you are trying to re-size is mounted and in use (since it's your system partition), and you cannot unmount it when it is active (also since it's your system partition). To fix it: Boot from a USB or CD with a Linux live distribution (Ubuntu for example) Now use Gparted to re-size your partition. GParted is part of the default toolset in ...


1

Do not try to remove grub, it is used as the bootloader for Ubuntu, just like the Windows mbr, which you just do not see. You could try to install the program grub-customizer, which lets you define different settings for grub in a simple GUI. You could set the timeout to 0 and tell it to always boot the first entry, so you will directly boot Ubuntu without ...


1

I found out eventually. Edit /boot/grub/grub.cfg Find ### BEGIN /etc/grub.d/30_os-prober ### menuentry 'Windows 10 (loader) (on /dev/sdXX)' After chainloader +1 Write ntldr /bootmgr It did the trick and fixes the shit. Thanks all for your hints.


1

In your pastebin, it's mentioned that: Please disable SecureBoot in the BIOS. Then try again.Do you want to continue? So you should disable secure boot in your BIOS completely. Also make sure that Windows 10 and Ubuntu are both installed in EFI mode.


1

Change the boot order in your BIOS so that you can boot using your Windows Recovery Driver and then when installing Windows 10(from the recovery media) - just install it on the entire hard drive. If needed, clean the mbr using BootRec.exe /fixmbr in command prompt.


1

WUBI is deprecated even on BIOS-based computers and is 100% useless on a dual-boot with an EFI-mode Windows installation, so don't waste any more time on it. When doing a dual-boot installation in EFI mode, you should NOT enable the Compatibility Support Module (CSM; aka "legacy boot support" or a similar phrase). Doing so is much more likely to create ...


1

Launch the Disks program from the launcher. The "Volumes" section will show you all the disks in your system. Select your 3Tb HDD. In the bar at the bottom of the Volumes diagram, click the gear wheels icon to bring up the settings for that disk. Click on Edit Mount Options Turn on the Auto Mount option, and make sure the 'show in user interface' ...


1

Not sure what computer brand you are using, but instead of hitting F12 for boot options try using F2 (or what ever option gets you into CMOS) and right arrow over to the "boot" tab. Here you can choose which drive to boot from (the Linux drive or the Windows Drive). Select the drive you want to boot from, hit F10 to save changes and reboot. Also try ...


1

This is defiantly possible! You have to have a spare partition or drive for Windows to install on in the first place. The tricky part is that Windows as you stated does not "like" to be installed alongside Ubuntu. The problem is that when installing Windows aside a Ubuntu system it will override Grub with the Windows boot loader, which makes Ubuntu ...


1

Macs normally come with EFI System Partitions (ESPs) of about 100 MiB, which is plenty big enough for most purposes. (I recommend making them bigger for reasons related to EFI driver bugs, but that's not an issue here.) If you're seeing just ~6 MiB of free space on your ESP (with a mount point of /boot/efi), then something is wrong. I recommend you discover ...


1

GRUB does not normally give boot options for external media; for that, you normally use your firmware's built-in boot manager, which you access by hitting Esc, Enter, or a function key (usually F8 or above) just after powering on the computer. Alternatively, you could install my rEFInd, which does show external media. (You may have to hit Esc in rEFInd to ...



Only top voted, non community-wiki answers of a minimum length are eligible