Tag Info

New answers tagged

0

1st since you are on server, not desktop you need to install all the major pakages needed by typing on terminal sudo apt-get install build-essential that should install needed packages upto libc6-dev, if it doesnt work try sudo apt-get update sudo apt-get install libc6-dev 2nd goto packages.ubuntu.com/it/wily/libfuse-dev (or any other you find) it has ...


0

you are getting this problem because you reinstalled gcc but there older dependency still exist that conflicting with new dependency . so run command : apt-get -f install it will resolve dependency then install gcc . if you still face problem then purge gcc and then run command : sudo apt-get autoremove it will remove older dependency then reinstall ...


0

I just figured out how to solve the problem in my case. I don't know if this is best practice or not, but I basically kept trying to run sudo apt-get remove codeblocks to get an error code and see which components of codeblocks were installed and had dependency errors. I then used sudo dpkg -r --force-depends <package name> where I replaced with ...


1

This problem can happen in the case of Hyper-V virtualization (Happened to me today). In this case the answer is to disable OS-probbing in grub by opening the configuration file : sudo nano /etc/default/grub And adding the line : GRUB_DISABLE_OS_PROBER=true


0

I have run into a similar problem before. There are two possible solutions: Use pip pip is a package manager for python. With pip${version} you can install packages for a specific python version. General info about pip Installing pip (basically sudo apt-get install pip) There are also ways to install the packages for all users (as root), or only locally. ...


0

This is a bug. See below link for the solution: https://bugs.launchpad.net/ubuntu/+source/mysql-5.6/+bug/1455818 Workaround: edit /var/lib/dpkg/info/mysql-server-5.6.postrm. Comment out lines that mention configure-symlinks. Retry.


0

I've encountered the same error. Reading the error message, it appears that the runit install script expects upstart at one point, but my system (and I suspect yours) is running systemd. Notably, I've another machine that did not have this error during installation; the only substantive difference is that the erroring machine was an upgrade from 14.10, ...


0

That's not a problem with the installation of acroread. Check your *.list files with the command below grep -Pr '^deb(\-src)*.+debian\.koha-community\.org\/koha' /etc/apt/ | awk -F: '{print $1}' Example output /etc/apt/sources.list.d/koha.list Remove the shown file via, eg sudo rm /etc/apt/sources.list.d/koha.list Some housekeeping sudo apt-get ...


0

I had the same problem. I have a System76 laptop where I had installed the Kubuntu desktop. The problem with apt-get is it tries to be a little too magical here. You need something more low-level to remove the Ubuntu packages that rely on the package that provides the conflict. I don't use Unity, so this works for me: sudo dpkg -r \ ...


-1

There is some bugs in default config and init.d service of freeradius3 You must change the field name=radiusd in the /etc/freeradius/radius.conf to name=freeradius Then restart the service If service couldn't be start , you must see the log , maybe the problem is from allow_vulnerable_openssl = no and change it to yes , run service freeradius restart If ...


0

install synaptic by going to a terminal by pressing ctrl+alt+T then copy past this to it. sudo apt-get install synaptic after that open synaptic and enter your password. from the left side choose 'custom filters" and in the upper left side choose "broken" and see install the packages that it will suggest for you. Note broken means, missing packages. ...


0

It looks like my Broadcomm Wireless drivers do not play well with latest Ubuntu 14.04 updates. I just removed debian packages bcmwl-kernel-source and dkms. The packages might very well run fine, but apt-get upgrade hangs, and I don't want to to deal with contantly freezing updates. Now I can run 'sudo apt-get dist-upgrade' and smooth sailing.


0

First try the commands below sudo apt-get update sudo apt-get install --reinstall plymouth-theme-ubuntu-text If the error persists, follow the next steps Open the file plymouth-theme-ubuntu-text.postinst in an editor sudo nano /var/lib/dpkg/info/plymouth-theme-ubuntu-text.postinst Search this code, should be start at line 21 sed -re \ ...


0

Brosix is providing versions for amd64 and i386 processors. This means 64bit and 32bit desktops. Phones are using ARM processors. So, at least they should recompile for armhf (and also make sure that the application doesn't depend on X11 display server).


0

You can re-install plymouth-theme-ubuntu-text by running the following in a terminal: sudo apt-get remove plymouth-theme-ubuntu-text sudo apt-get install plymouth-theme-ubuntu-text sudo apt-get update sudo apt-get upgrade Hopefully, that should fix the issue.


0

Fixed it with 2 commands: sudo dpkg -P linux-image-generic sudo dpkg -P linux-generic


2

So after some searching in addition to what I've posted in the comments, I found a command that produces the exact repository - apt-cache policy packagename. Example: $ apt-cache policy chef chef: Installed: (none) Candidate: 11.8.2-2 Version table: 11.8.2-2 0 500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages


0

This (the syntax error) is caused by a Python version mismatch, as the syntax has changed between Python 2 and Python 3. Another user with the same problem had manually installed a newer version of python (version 3.2; the version installed through packages is 2.7) and he redirected /usr/bin/python to python3.2 -- a bad idea. Restoring the original link of ...


0

I solved this issue. After several trial & error, what I did was: I rolled back an earlier backup (2 months old) I re-tried installing lamp sever using: sudo tasksel install lamp-server This helped me identify the missing directories. I manually created the missing folders in the mysql directory Next, I ran these commands sudo dpkg-reconfigure ...


2

You could look for it: locate --regexp 'chef.*deb' Or, you could get a new copy, if /var/cache/apt/archives has been cleaned out. See man apt-get, which says, in part: NAME apt-get - APT package handling utility -- command-line interface SYNOPSIS apt-get [-asqdyfmubV] [-o=config_string] [-c=config_file] [-t=target_release] ...


0

You're using the wrong command. dpkg --listfiles is for installed packages, not random .deb files. From man dpkg: -L, --listfiles package-name... List files installed to your system from package-name. So when you do dpkg --listfiles linux-image-3.19.0-25-generic_3.19.0-25.26~14.04.1_amd64.deb, linux-image-3.19.0-25-generic_3.19.0-25.26~14.04.1_amd64.deb ...


1

The are you root? part shows that you do not have the privileges of installing new software. Try using sudo with your command to execute them as root user. First run the command sudo apt-get update and then you can try to install the application with sudo apt-get install app_name where app_name is the application you want to install.


0

I was facing similar problem when trying to install hadoop usergroup hduser and I solved it by removing the two files. Here is the error I was getting: useradd: existing lock file /etc/subuid.lock without a PID useradd: cannot lock /etc/subuid; try again later. solution: sudo rm /etc/subgid.lock sudo rm /etc/subgid


2

The terminal used by default is Gnome Terminal. There are 2 ways to uninstall it. Command line method: Open tty1 by pressing Ctrl+Alt+F1, and run this command: sudo apt-get remove gnome-terminal It will be removed. Graphical method: Open the Software Centre and search for Gnome Terminal: Click the first result called "Terminal (gnome-terminal)" and ...


2

Nothing. The VCS-* fields are for source packages, not binary packages. Compare: $ apt-cache showsrc php5 | grep -i git Vcs-Browser: http://anonscm.debian.org/gitweb/?p=pkg-php/php.git Vcs-Git: git://anonscm.debian.org/pkg-php/php.git $ apt-cache show php5 | grep -i git $


1

Before you start, try to delete unneeded packaged using : sudo apt-get autoremove Now, you have to install all dependencies packages using : sudo apt-get update sudo apt-get install -f After that, try to install updates using : sudo apt-get upgrade


1

Use the main server instead of http://in.archive.ubuntu.com/ubuntu/ sudo sed -i 's://in\.://:g' /etc/apt/sources.list sudo apt-get update or change the server via Software & Updates. Select Main server for Download from: Install the correct version of libuuid1:i386 sudo apt-get update sudo apt-get install libuuid1:i386=2.20.1-5.1ubuntu20.6 But ...


0

Never mind, I actually just fixed it. What I had to do was outlined in this post: Broken dependencies due to libjackd So I went to /usr/share/doc and then took zlib1g and zlib1g-dev and renamed both with a .old on the back. This allowed me to do my apt-get -f install and things seem to be happy now.


0

In the past, I have had some stubborn packages, that wouldnt uninstall properly. (Im not sure why that happens, package quality perhaps?) anyhow, try: sudo apt-get purge <package> Then you might also use find, or locate to locate any residual files that you might want to remove. places for concern might include anything that is in one of the ...


2

I suggest installing the same deb file again. Then you will be able to remove it.


3

Create a script, in my example foo #!/bin/bash # Create a temporary folder in /tmp dir=$(mktemp -d) # Extract the deb file dpkg -x "$1" "$dir" printf "\n%s\n\n" "$1" # Show the package architecture information dpkg --info $1 | \ awk '/Architecture/ {printf "defined dpkg architecture is:\t%s\n", $2}' # Show the executable format via find and awk for ...


1

A DEB package is just an archive with very specific contents. You can open it in any archive manager you like (such as File Roller or whatever) and the contents are laid out as if you empty it into /. All you need to do is locate a binary and query its file type. This isn't usually necessary - if the filename has i386 in it, it should be i386. Your case is ...


-1

Each deb package declares an architecture, eg. "i386" or "all". However this is only a declaration, and it can be declared wrong (intentionally for some reason, or eg. by error in some package building script). What can you about to verify the real package architecture: # verify, if package supports multiple architectures (and possibly has some bug): dpkg ...


1

Package: ResolutionX Version: 1.0-0 Section: base Priority: optional Architecture: all Build-Depends: debhelper (>= 9) Maintainer: Bilal Bernardot Description: ResolutionX A simple tool to enable you to have your desired resolution without requiring graphics drivers. This paragraph is a mish-mash of fields for source and binary packages. The first ...


0

Enter these two commands: sudo apt-get clean sudo apt-get autoclean Try to fix the broken dependencies: sudo apt-get -f install sudo dpkg --configure -a And enter again sudo apt-get -f install. This should solve your dependency problems and you can now install libgimp2.0-dev again. Next solution is to run: sudo apt-get -u dist-upgrade If it shows ...


0

Steam is in multiverse repository, so you have to enable it before installing steam. Open Software center, navigate to the "Ubuntu software" tab at the top, select (check off) multiverse. Use the "Reload" button to update your package list. Now, install with sudo apt-get install steam.


0

Nothing worked except: sudo apt-get -f install This removed all the dependent files. And I am using ampps by Softaculus for mysql


1

Try this command in terminal to find what is running ps -e | grep -e apt -e adept | grep -v grep If that doesn’t print anything, type the following in terminal to remove the lock sudo rm -rf /var/lib/dpkg/lock sudo rm -rf /var/cache/apt/archives/lock Also If you try ps aux | grep apt that will catch processes containing the word apt, at least. ...


1

You can install same driver a supported way. First remove what you tried to install by sudo apt-get purge fglrx Then install this driver from Ubuntu repositories sudo apt-get install fglrx-updates This will install 15.200 fglrx.


1

You can force dpkg to over-write files by: sudo dpkg -i --force-overwrite Downloads/texmaker_ubuntu_14.04_4.4.1_i386.deb Also run sudo apt-get -f install to make sure everything is OK.


0

update-initramfs: Generating /boot/initrd.img-3.16.0-43-generic gzip: stdout: No space left on device E: mkinitramfs failure cpio 141 gzip 1 solution: apt-get autoremove


2

From the manpage: Unless you pass the -F option, the output of aptitude search will look something like this: i apt - Advanced front-end for dpkg pi apt-build - frontend to apt to build, optimize and in cp apt-file - APT package searching utility -- command- ihA ...


0

man aptitude says in part: Unless you pass the -F option, the output of aptitude search will look something like this: i apt - Advanced front-end for dpkg pi apt-build - frontend to apt to build, optimize and in cp apt-file - APT package searching utility -- command- ihA ...


0

That's a job for yes, if you always want the answer N: yes N | dpkg --configure -a Or Y (works without an argument): yes | dpkg --configure -a Or over the dpkg options, see dpkg --force-help: [...] [!] confnew Always use the new config files, don't prompt [!] confold Always use the old config files, don't prompt [!] confdef ...


2

This is a dpkg change, not an apt change: # dpkg --get-selections | grep hold google-chrome-stable hold # dpkg -i google-chrome-stable_44.0.2403.125-1_amd64.deb (Reading database ... 318187 files and directories currently installed.) ... # dpkg --get-selections | grep hold # After doing some git bisect, this change was ...


1

Add this software source to /etc/apt/sources.list deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse Run this command for installing dependencies: sudo apt-get -y install libgnomeprint2.2-0:i386 libgnomeprintui2.2-0:i386 libbonobo2-0:i386 libbonoboui2-0:i386 libgconf2-4:i386 libgnome-desktop-2-17:i386 ...


2

You need the development packages, they should be available in 14.04 from the trusty main repository. Try running: sudo apt-get install libgtk2.0-dev


2

system by default reserve 5% memory for superuser . so you can use that memory by reducing 5% to 2% . let up suppose you have 100GB hard disk then system will keep 5GB memory for superuser reserved. it will not use all 5% memory so you can reduce it by 2%. tune2fs -m 2 /dev/sda1 if you are going to create partition and you want to assign less memory to ...


1

Boot on the computer with a live USB key/cdrom linux, and from this, use parted or gparted to extend your root partition. You'll not be able to do it from your system as the root partition is mounted and in use.



Top 50 recent answers are included