Hot answers tagged

10

You are receiving these errors because Google has ended the support for Ubuntu 12.04. Google: We will end support for Google Chrome on 32-bit Linux, Ubuntu Precise (12.04). You alternatively can install the chromium-browser on which Google Chrome is built on. You also can install Ubuntu 14.04 LTS or Ubuntu 15.10 - both are supported - to use Chrome. ...


5

You misspelled dpkg , that's it , the terminal was smart enough to answer to your question :)


5

The package apache2 in your enabled third-party repository needs the package dpkg in version 1.17.14 or higher. This version is not available for Trusty. For this reason, install the official apache2 package for Trusty, currently version 2.4.7-1ubuntu4.9. And as you can see in the output of apt-cache policy 2.4.12-2 0 500 ...


3

I don't think you can. They've just upgraded and the dependencies cannot be met in 12.03. I've had the same problem on a travis build and have downgraded. Loads of old versions here. Obviously not a great answer, I looked for a good while and couldn't find a way without downgrading.


2

I guess you are using PPA for PHP 5.6 for Ubuntu 12.04 (precise). Your issue is because that apache2-mpm-prefork is already obsoleted in 2.4.x. You just need to remove apache2-mpm-prefork, then install apache2, and default is prefork mode.


2

You can safely purge all linux-headers packages with the old versions. In your case versions 3.19.0-26 - 3.19.0-43. And NEVER delete files installed by dpkg or apt manually using rm.


2

This is a very common question, and the UI is a bit tricky. I took some screenshots. First: Computers -> Select Computers -> Packages -> Find Package to Hold You should end up on a screen like this: Expand the row of the package you want to hold: Click the little package icon: Then apply changes to generate the activity that will be sent to ...


1

You need to click the package icon in a search results page to set/unset a hold on that package. There are also some interesting details about holding kernel updates, with the kernel metapackage playing a key role. See Mastering Package Holds for coverage of this functionality from both Landscape and the shell.


1

I don't know why you're expecting it to install anything into those directories. But what you're seeing is correct, there is nothing wrong with the package. The package provides the following files: /usr/bin/glewinfo /usr/bin/visualinfo /usr/share/doc/glew-utils/README.txt /usr/share/doc/glew-utils/TODO.txt ...


1

If another apt-get instance is running in another terminal, you should close it or let it complete the task before running apt-get in another terminal. If that's not the case, remove the lock file in /var/lib/dpkg/ directory with sudo rm /var/lib/dpkg/lock


1

You could certainly do the following: sudo apt-get -f install which might address the dpkg error: dependency problems - leaving unconfigured But it looks as if you are installing an Acrobat Reader deb package from Raring Ringtail on to your Wily Werewolf installation. Try the following, which I have tested on Trusty not Wily. First some required files ...


1

Some packages can't be uninstalled if some dependencies are gone, or some configuration files have been deleted for some reason. You will end up with a package that is not completely installed nor completely uninstalled. The solution, in this case, is to sudo apt-get install the package. If necessary, do sudo apt-get install --reinstall [package]. Missing ...


1

Ubuntu GNOME no longer includes the dpkg-dev package by default as it is a developer/maintainer tool and is not likely to be needed by an end-user. So those who do wish to be able to use such commands as you gave, will need to install it with: sudo apt-get install dpkg-dev


1

You have two repositories which provide MySQL: the official Ubuntu 14.04 ones provide MySQL 5.5, and the official MySQL ones provide 5.7. This is why you cannot manually install 5.6 packages without some forcing, it would be better to go with either 5.5 or 5.7. In that case you should: Uninstall all residual 5.6 packages, you can find them with dpkg -l | ...


1

Not exactly a straight answer, but, as you have mentioned, how about you create a list of packages available on both versions of Ubuntu (10.04 and 14.04) and then compare it using diff? You can create this list executing the commands below on each server: $ sudo apt-get update $ dpkg -l > packages_version.txt Where version could be an identification of OS ...



Only top voted, non community-wiki answers of a minimum length are eligible