Tag Info

Hot answers tagged

4

Depending on the way you've set up your system it might be as easy as copying the monitors.xml file from the correctly set-up user to all users: Test for one user: cp --preserver=timestamps /home/CorrectUser/.config/monitors.xml /home/TestUser/.config/ then log off TestUser, log back on and see whether everything is correct. Now do for all users: cp ...


3

I am not sure how you are going to apply it in your application ("enable a user to have their desired resolution without requiring graphics drivers" ?), but: A terminal command to list connected screens xrandr | grep " connected " | awk '{ print$1 }' This wil give you the connected screens for further processing, like: VGA-0 DVI-I-1 Since you mention ...


3

You can use python and just python to get the connected monitor names: $ python3 -c 'from gi.repository import Gdk; screen=Gdk.Screen.get_default(); \ [print(screen.get_monitor_plug_name(i)) for i in range(screen.get_n_monitors())]' DP1 LVDS1


3

To set your screen configuration for every user on log in (this will not change the configuration on the log in screen), you can create a .desktop file in /etc/xdg/autostart How to do that find out the name of the screen you'd like to be rotated by running xrandr. It will output a number of lines, among thos a few lines looking like: VGA-0 connected ...


2

Take a "snapshot" of the window arrangement and restore it The script below can be used to get the current window positions of all "normal" windows (run with the argument -get), or restore the last window arrangement (run with the argument -restore). As explained here, using wmctrl i.c.w. Unity has some issues. If it is satisfying in your situation is to ...


1

If you are using the i915 driver, try the following command: echo 0 > /sys/class/drm/card0/power/i915_dpst


1

My best guess is that he somehow changed the resolution of the display and maybe the scale of the items displayed as well. If you can see the settings button in the top right corner, navigate to System Settings > Displays and change the resolution. You'll probably want the highest resolution listed there. After that, change the scale to 1. If that is ...


1

The solution exists of two parts: 1. create a small script to arrange the screens You should think of your combined screens as one combined virtual screen, as explained here. To arrange two screens into the combined virtual screen, you need to arrange them from left to right. In your case: to place the left screen on 0,0: xrandr --output DP-0 --pos 0x0 ...


1

That's one of the major problems of using a TV as a monitor: they are lousy at telling the computer what exact resolution they have and at following orders if the computer tells them what to do... As we don't have the exact specs of your TV, you should look up "overscan" or "overzoom" or "zoom" in your TV manual and then turn that feature off on your TV.


1

Adding complicated commands to Startup Applications In General, you can add commands to run on start up (log in) by choosing: Dash > Startup Applications > Add. In this case, you have a complicated command to run. There are two options to do that: write a separate script: #!/bin/bash cvt 1368 768 xrandr --newmode "1368x768_60.00" 85.25 1368 1440 ...


1

Do you use the nvidia proprietary drivers or the nouveau open drivers? (If you don't know run lsmod | grep nouveau if it gives you any results, it's nouveau; if lsmod | grep nvidia gives you any results, it's the proprietary nvidia drivers). If you have the nvidia drivers you should be able to configure the monitors from the nvidia-settings utility that ...


1

Make sure the displays can be recognized by your computer, you can do this by typing Ctrl+Alt+T to open a terminal and type: xrandr This should output some information about your displays. You can then setup your displays based on this. man xrandr in a terminal will help with this. In my monitor setup: xrandr --output DVI-I-1 --auto --orientation left ...


1

Try first setting scaling mode on the display to "Full aspect" xrandr --output LVDS --set "scaling mode" "Full aspect" or xrandr --output LVDS --set PANEL_FITTING full_aspect After this change your resolution xrandr -s 1024x768 This works with lenovo E330 laptop with intel gpu. Options for scaling mode are: "Full", "Center" or "Full aspect".


1

I had this problem too on a carbon X1 laptop. My setup was a bit different and I'm on 15.04 and I was rotating the other screen with xrandr, rather than using the system menu. Nonetheless, it also has a recent intel gpu (broadwell, but I don't think they're that different), so it's probably the same problem. Here's how I fixed it: Install new (>= 2.99.917) ...



Only top voted, non community-wiki answers of a minimum length are eligible