Hot answers tagged

196

You basically need the Guest additions, log into the Virtual Machine to install the following packages: sudo apt-get install virtualbox-guest-dkms Finally restart the VM to complete the installation.


188

Independently of your installed version of VirtualBox you should install the latest version of the VirtualBox Guest Additions into your Ubuntu-Guest. You can get it from the Ubuntu-Software-Repository. Startup your guest and hit Ctrl+Alt+T to open a terminal session. Type sudo apt-get install virtualbox-guest-dkms to install the latest package. Restart ...


49

There are some steps to take: 1. System wide Menu and titlebar scaling Starting with 14.04 we have an option that helps a bit: Scaling Support open the System Settings (here in english:) LANG=c unity-control-center Go to "Displays" and set the "Scale for menu and title bars": see also: How to find and change the screen DPI? 2. Universal Access Go ...


47

I had the same problem as you. I did these steps, maybe helps you too: Go to System settings → Software and Updates → Additional drivers Use x86 virtualization solutions... After that reboot your VirtualBox My VirtualBox is working perfectly.


46

On virtualbox you have to install "Guest Additions". There is no need to set a resolution via Ubuntu settings. With your guest window in the foreground select from the top menu: VirtualBox -> Devices -> Insert Guest Additions CD image In Ubuntu open a terminal, navigate to cd folder (usually /media/VBOXADDITIONS*) and run sh ...


28

Install my Firefox-addon Zoom Menu Elements (or install this file from source on github). Alternative: you can manually open a new tab about:config in Firefox and search for layout.css.devPixelsPerPx set this value to 2 or 1.5 as you wish to adjust the size of the Firefox icons (source, bug report) Install the Firefox-addon Fix for zoomed default-font to ...


26

After having first tried installing the Guest additions, which didn't work, I found another solution elsewhere: linuxbsdos.com. Use Xdiagnose from the Dashboard. Search for and launch Xdiagnose, then enable all the options under the Debug section. Click the Apply button, then close the window and restart the system. That's what finally did the trick! Now ...


16

Developing from this answer, and in fact pretty well explained also in this other post. (I really tried everything else posted here but it does not seem to work on my Windows 7 system) Preliminary steps: Make sure you have installed the latest version of Virtual Box(*). Be careful that if you ask Virtual Box to update to the latest version it might very ...


13

Just had exaclty the same problem with Ubuntu 14.04 on Windows 7 VirtualBox. I've updated to latest version of Virtualbox (4.3.10 r93012) and it now works correctly. Make sure to install the latest version of Guest Additions (v4.3.10 at the moment).


12

It is probable that your graphic driver is not detecting that resolution. Follow the instructions below; it might help. It helped me in my Ubuntu(using unity) which installed in my desktop that has a dedicated AMD Radeon 5570HD(which uses Gallium REDWOOD drivers i.e the default open source drivers). First type this in your terminal(You can open terminal with ...


11

Sometimes the packaged version of the Guest additions gives better results. So I'd suggest to update the Guest additions with the VM package manager. So login first into your VM and open a Terminal to type: sudo apt-get install virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11 Finally restart the Ubuntu VM to complete the installation. ...


10

Found a way to do it without requiring a dummy plug: http://blog.mediafederation.com/andy-hawkins/ubuntu-headless-vnc-vesa-800x600-fix/ Basically install a dummy driver: sudo apt-get install xserver-xorg-video-dummy Then write it in the /usr/share/X11/xorg.conf.d/xorg.conf file (create one, if it does not exist): Section "Device" Identifier ...


10

I tried a similar thing and after some debugging I think I figured out what's going on. Your script probably is run and probably does set the resolution correctly. However, since it is run by the login manager, it runs before Unity has finished setting up your desktop environment and Unity reads its own settings and resets the resolution to what you had. So, ...


8

I solved the problem by running: xrandr --addmode VGA1 1366x768 I also added new modes to the change resolution drop down by using, xrandr --newmode "mode line" Where mode line replaces the supported resolutions. You can find the supported resolutions by running: xrandr Currently, it's working all right.


8

The answer I found was a combination of How do I increase console-mode resolution? and How to use ubuntu server full screen in virtualbox?. The former provided information for changing grub's display resolution, and the latter assisted me in diagnosing why the former wasn't resulting in any resolution change. Combining the two answers: Identify the ...


8

HTML5 is usually better (particularly security wise), just Youtube's implementation uses Media Source Extensions, which is available in Firefox but disabled by default currently: Why you can’t play 1080p or 480p YouTube HTML5 videos in Firefox anymore - Nov 5 2013 no option for 1080p youtube - Jan 25 2015 How to get 1080p in Youtube’s HTML5 player in ...


7

I didn't see any errors in the Xorg.0.log file the radeon driver seems to work well so try to create a Modeline for the unsupported resolution. Open a terminal with Ctrl+Alt+t and type: cvt 1366 768 It should return: # 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz Modeline "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync ...


6

Go to System Settings and then to displays. Look for "Scale for menu and title bars." then drag the slider to whatever size you want.


6

Install the latest version of virtualbox say 4.3.10 or above from here and also it's corresponding guest additions, extensions Or you can also install the latest virtualbox version from the multiverse repository via apt-get. I also faced the same problem in older virtualbox version running Ubuntu 14.04 as guest OS. To install guest additions, follow ...


6

You should use the latest official drivers that support your NVIDIA GEFORCE GTX 960M graphics. Uninstall the old NVIDIA drivers by executing: sudo apt-get purge nvidia* sudo reboot Install the new NVIDIA drivers by executing: sudo add-apt-repository ppa:graphics-drivers/ppa sudo apt-get update sudo apt-get install nvidia-358 nvidia-prime sudo ...


5

You need to install guest additions. Start a virtual machine, go to "Devices" menu and select "Install guest additions". Windows video driver will be installed. You will be able to set custom resolutions by resizing VM window by your mouse.


5

/etc/modules file is for kernel moludes ( aka drivers). It says right at the top of the file. That's not the right place to put custom commands. Step 1: Take those 3 commands, save in a set-screen.sh somewhere in your home directory. For example, mine would be in /home/serg/bin/set-screen.sh and that's how it would look like: #!/bin/sh sleep 15 xrandr ...


5

I seems like my trials of text-scaling-factor were close, but not the solution. I was able to solve my issue using: gsettings set org.gnome.desktop.interface scaling-factor 1 It was set to a factor of 2 from the installer!


5

You did not specify whether you saved your settings to the X configuration file (/etc/X11/xorg.conf) using nvidia-settings. That should solve this. Just open nvidia-settings as root: sudo nvidia-settings Then, choose the right settings and click on the "Save to X Configuration" button: If this does not work, there is something else overwriting your ...


5

Adding complicated commands to Startup Applications In General, you can add commands to run on start up (log in) by choosing: Dash > Startup Applications > Add. In this case, you have a complicated command to run. There are two options to do that: write a separate script: #!/bin/bash cvt 1368 768 xrandr --newmode "1368x768_60.00" 85.25 1368 1440 ...


4

I have a MacBookPro Retina display. The accepted solution partially worked for me but I was unable to get Java apps to work properly, and I found the OS to become too laggy while using 2x scaling. Changing resolutions while using Ubuntu's default Nouveau display driver would result in a black screen and force me to restart my computer. I finally found a ...


4

As @Zook pointed out in the comments, it was enough for me to (as superuser) enable and change the GRUB_GFXMODE=1152x864x16 variable in /etc/default/grub and then update-grub && reboot GRUB version is 2.02~beta2-9ubuntu1. Virtualbox version 4.3.16, Windows 7 Host, native resolution 1600x1050. Important for that to work was to remove any vga= ...


4

It's called scaling. There is both hardware scaling (which is done by the video card or the monitor) and software scaling. That is an example of software scaling. It's much like watching a big picture, at some point if the image can't be rendered directly the image is passed to an algorithm which tries to resize it in a reasonable way (notice that ...


4

1. Make a screenshot as usual, then automatically scale the latest screenshot you took with a shortcut key. Placed under a shortcut key, the script below will: Find the last added screenshot in your screenshot directory (which is ~/Picures, as you mentioned in a comment) Scale the image into an arbitrary percentage Rename and save the image as ...


3

I was able to disable the display port by adding video=DP-2:d to the grub boot options. Notice that xrandr was showing DisplayPort-1 even though in reality DP-2 was enabled. Here's how I was able to find out which was the real output device thanks to the ArchLinux wiki: *To get the name and current status of connectors, you can use the following shell ...



Only top voted, non community-wiki answers of a minimum length are eligible