Tag Info

Hot answers tagged

4

In your mv command you are using a relative path for opt/shiny-server/ so this will only work if you current directory has opt as a subdirectory. To ensure that this isn't the issue use a full path /opt/shiny-server/. To change permission of /opt/shiny-server/test/ use sudo chmod 777 /opt/shiny-server/test This opens up the permissions for everyone. A ...


3

You can try using rsync: rsync -av --include="*/" --include='*.png' --exclude='*' parent1 parent2 this creates directory parent2 and copies all files with .png extension with subdirectory structure to it. explanation -v verbose to see whats copied -a archive mode (copy subdirectories with same ownership, permissions etc.) --include '*/' ...


2

You can use secure copy (scp) with the recursive option (-r): scp -r /path/to/local/dir user@remotehost:/path/to/remote/dir Alternatively, I recommend rsync because you can resume transfers if the connection breaks, and it intelligently transfers only the differences between files: rsync -avz -e 'ssh' /path/to/local/dir ...


2

The filepicker autocomplete path stub needs to be separate from any other string. In your example: command --argument=/path/stub<TAB> Bash is just going to see the --argument and bug out. You could probably improve it by making it parse through that but that's not entirely trivial.


1

You were right, you need a debian/my_package.postint file to perform such operation: #!/bin/sh #DEBHELPER# set -e USER="my_user" mkdir -p /var/log/my_package/ if id -u $USER > /dev/null 2>&1; then chown ${USER}:${USER} /var/log/my_package/ fi Note: The script checks if the user exists before calling chown.


1

To recursively give directories read,write&execute privileges to all. sudo find /path/to/the/directory -type d -exec chmod 777 {} \; To recursively give files read,write&execute privileges to all. sudo find /path/to/the/directory -type f -exec chmod 777 {} \;


1

Your problem is the difference between absolute and relative path. So opt/shiny-server/ is not the same as /opt/shiny-server/ ; the first starts in the current directory and the second starts at root or / Same problem with test and /test See http://www.linuxnix.com/2012/07/abslute-path-vs-relative-path-in-linuxunix.html


1

First try running this command to configure the libraries: sudo ldconfig If that doesn't solve it, you'll need to add these lines to ~/.profile file: export PYTHONPATH=$PYTHONPATH:/usr/local/lib/python2.7/dist-packages export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib This assumes that you actually have python2.7 installed and that ...


1

When you cancel the copying of file there might appear a problem in the filesystem. So reboot into Windows and run chkdsk /F <drive> It should find and fix errors that can't be fixed inside Ubuntu. Offtopic: I dream about such application that would scan disk in Ubuntu without need to boot Windows…


1

Numeric permissions can solve your problem. sudo chmod 775 'your directory' if you want to know why only 775 here's your answer 400 read by owner 040 read by group 004 read by anybody 200 write by owner 020 write by group 002 write by anybody 100 execute by owner 010 execute by group 001 execute by anybody 400 +040 +004 +200 +020 +100 +010 +001 =775 ...


1

First make sure you have the bash auto completion package installed on the system. sudo apt-get install bash-completion Next for Ubuntu 13.10 to enable smart completion, edit your /etc/bash.bashrc file to enable it. Uncomment the following lines, by removing the # in the beginning of the lines: #if [ -f /etc/bash_completion ]; then # . ...



Only top voted, non community-wiki answers of a minimum length are eligible