Tag Info

New answers tagged

0

Adding the Utopic packages changes a lot. They are part of the Hardware Enablement Stack and constitute major upgrades which are not normally done. See Kernel/LTSEnablementStack - Ubuntu Wiki According to How to Upgrade Ubuntu 12.04.2, 12.04.3 to 12.04.4, the next Hardware Enablement Stack? - Ask Ubuntu you should include --install-recommends when doing ...


0

Try opening a Terminal window and run these commands: sudo apt-get remove --purge vlc sudo apt-get install vlc


0

I had the same problem, but found another ppa that worked fine. First, remove the ppa that didn't work out ppa:noobslab/indicators: sudo add-apt-repository --remove ppa:noobslab/indicators Next, add the new ppa and install: sudo add-apt-repository -y ppa:elementary-os/unstable-upstream sudo apt-get update sudo apt-get install indicator-synapse Log ...


1

Try running this command to install all of the dependencies. sudo apt-get install unity-control-center gnome-control-center ubuntu-system-settings gnome-bluetooth unity8 ubuntu-system-settings-online-accounts libpng12-0:i386 address-book-service


0

I feel to guess an anwser, still feel free to add your own anwser. I've learned there is a /var/lib/dpkg/available database, as raw‑text. I checked for python3 (to go on with the same example as in the question) it says Provides: python3-profiler: there is no python3:any. So may be the anwser is: there is not always a direct match between a requirements ...


2

python3:any (>= 3.3.2-2~) is not a virtual package, it's a substitution string created by the ${python3:Depends} pattern and filled by dh_python3 when called from dh_gencontrol when the package was built. Take a look at the debian/control file of the apturl source package: Package: apturl-common Architecture: any Depends: ${python3:Depends}, ...


0

I wanted to thank everyone for helping me out. I followed murus's post first and then Thiago Zanetti's post with: sudo dpkg --purge --pending then i used: apt-get install -f and eventually all packages got fixed again. Thank you to everyone who tried to help me I really appreciate it!


1

Force a downgrade to the lower version of python: sudo apt-get install python=2.7.8-1 If that doesn't work, download it, and use dpkg directly: sudo apt-get download python=2.7.8-1 sudo dpkg -i python_2.7.8-1*.deb Python is too important a package to be messed with, or even removed.


1

Try to remove the package you attempted to install by doing: sudo dpkg --purge <tgz_package_converted_to_deb> Alternatively you can try sudo dpkg --purge --pending but I think it could break your entire system since you have a lot of unmet dependencies issued by this python's installing attempt.


4

TL;DR: You can use reverse-depends src:$(what-source libsslcommon2). There is no libsslcommon2 source package. Instead, libsslcommon2 is one of a number of binary packages built from the qpid-cpp source package. In general, a binary package may or may not have the same name as the source package used to build it, and source packages may provide multiple ...


2

The reverse-depends software doesn't automatically detect the source package from which a given binary package is generated. The src: label is used to indicate that what follows is the name of a source package. It so happens that the name of the source package for bash is, well, bash. But for libsslcommon2, the source package is named qpid-cpp: $ ...


1

This seems to be a bug of apt. Version 1.0.1 is affected. We've built version 1.0.9.2 from source, and it behaves as expected: reports unmet dependencies and exits with non-zero status. Perhaps this is the same bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=745046


1

I installed aptitude and got these proposed solutions: $ sudo aptitude install makerware The following NEW packages will be installed: avrdude{a} conveyor{a} conveyor-common{a} conveyor-ui{a} libarmadillo4{a} libarpack2{a} libboost-program-options1.54.0{a} libcoin80{a} libdap11{a} libdapclient3{a} libdigitizer{a} libepsilon1{a} libfreexl1{a} ...


0

For me, I re-installed libdpkg-perl and it worked. You can allow synaptic to downgrade this package if you use synaptic


0

FWIW, I ran into this same problem and it turned out to be an issue with the version of wkhtmltopdf I was trying to install. I have an Ubuntu 12.04.5 64-bit system and was trying to install a 32-bit version of the package. Looks like you have the 32-bit version there as well; should it be amd64 instead of i386? All package downloads here: ...


1

You can just "resolve" this by installing all pending updates. The message will go away. It is rather annoying, but there's not much you can do about it. For more information check this bug report: https://bugs.launchpad.net/pipelight/+bug/1318321


0

What worked for me is to re-install the dependency. It is the case where the installed version is more recent than the latest (what synaptic shows). It is actually equivalent to allow synaptic to downgrade the dependency package.


0

Teamviewer depends on some dll and therefore needs wine to work. sudo apt-get install wine1.7 Download teamviewer (32/64bit depends on wine settings). Open terminal, navigate to the downloaded file. Run (rename filename if needed) sudo dpkg -i teamviewer_linux.deb


0

According to this possible duplicate, you need to install the 32-bit version instead of the 64-bit. Read the first answer for more details.


0

I needed to add trusty repository instead of utopic one. To install codelite follow instructions on codelite official installation page except for: sudo apt-add-repository 'deb http://repos.codelite.org/ubuntu/ trusty universe' run this instead: sudo apt-add-repository 'deb http://repos.codelite.org/ubuntu/ utopic universe'


1

try this just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below: at first, delete damaged files by rm command: sudo rm -fr /var/cache/apt/archives/libc6-dev-i386_2.19-0ubuntu6.6_amd64.deb now, change your sources.list generate your new list from here: http://repogen.simplylinux.ch/ copy all the lines and ...


1

sudo dpkg --remove --force-remove-reinstreq linux-image-extra-3.16.0-24-generic* allowed to remove first the extra package and then followed by: sudo apt-get autoremove linux-image-3.16.0-24-generic The package was removed. I could tell that df -h dropped /boot space from 98.5% to 85% and I used the same command with other packages. Credit to ...


0

Well after roughly two days trying to figure this out; I took another look at the logs and it seemed to show the libgbm1 issue around the Unity-Control-Center Something apparently got corrupted during an install of an app or program. I reinstalled it via Synaptic and it removed and re-installed quite a few items. So far things are back to normal, emphasis ...


0

That error means the package you are trying to install depends on some other packages, but for whatever reason, they aren't going to be installed. There are a few ways to try to get around this. Installing each listed dependency manually. You can try running apt-get install on all the dependencies listed in that window, but this could take forever and lead ...


0

Given you are seeing "fork failed: Cannot allocate memory" I'm guessing you have run out of memory or a related resource. Try closing you browser and other memory hungry applications before you reattempt. A reboot would also help.


0

Use "aptitude" to solve the problem. sudo apt-get install aptitude sudo aptitude remove mysql-apt-config Now follow the proposed solutions.


0

This error occurs because the package you are trying to download and install requires libstdc++6 >=4.9. The latest version of libstdc++6 available on the Ubuntu 14.04 LTS repositories is 4.8.2-19ubuntu1, which is older than 4.9. I'm assuming that you're running Ubuntu 14.04, because the libstdc++6 package on your computer is stuck at 4.8.2-19ubuntu1. The ...


1

Your unmet dependencies problem is caused by the MySQL APT Repository repository. MySQL Server 5.6 from the MySQL APT Repository requires libstdc++6 >=4.9 however MySQL Server 5.6 (mysql-server-5.6) from the the default Ubuntu repositories requires libstdc++6 >=4.6. When you install the version of MySQL Server 5.6 from the Ubuntu Software Center, it ...


0

libstdc++6 : Depends: gcc-4.9-base (= 4.9.2-10) but 4.9.1-0ubuntu1 is installed The package gcc-4.9-base (= 4.9.2-10) is only available for Ubuntu Vivid. Check this (utopic) and this (vivid). Remove the package mysql-apt-config, installed by these instructions and use mysql-server to get the latest version. sudo dpkg --force-all -P mysql-apt-config ...


1

A good way to solve these problems is to use "aptitude". sudo apt-get install aptitude sudo aptitude update sudo aptitude install xserver-xorg-input-synaptics Now several ways to solve the problem were proposed. Choose the solution that uninstalls the least packets. Write down what packages are removed. Install the packages again, you still need.


0

First remove the node.js-legacy PPA and uninstall nodejs and npm. Open the terminal and type: sudo add-apt-repository --remove ppa:chris-lea/node.js sudo apt-get update sudo apt-get remove nodejs npm Install the latest versions of nodejs and npm sudo apt-get install curl curl -sL https://deb.nodesource.com/setup | sudo bash - sudo apt-get ...


0

This could occur if the location containing the script (in this example, /var) has been mounted with the noexec option. You can confirm this by running mount. If so, modify /etc/fstab and re-mount appropriately.


0

Which version of the Graphics Installer are you using? The current one seems to support only Ubuntu 14.10. The Intel Download Page tells you that: Beginning with the v1.0.8 release of the Graphics Installer, we discourage using the Graphics Installer with Ubuntu 14.04. Your error tells you that the installed version of a packet is not the one which the ...


0

The OP posted this solution as an edit (reproduced here with minor copy editing). First I tried to type in the terminal: sudo apt-get clean sudo apt-get autoclean sudo apt-get install -f This didn't work. Then I tried sudo apt-get autoremove which also didn't work. Finally thanks to kindness of people here this code worked: sudo ...


0

Did you try the suggestion? Try ' apt-get -f install ' with no packages (or specify a solution) If this doesn't work try the following sudo apt-get autoclean && apt-get clean sudo aptitude update && sudo aptitude -y upgrade sudo aptitude install <package> And please tell if its from a ppa maybe this link could be a solution for ...


1

Solved the problem forcing a reinstall of wireshark-common package. Steps: sudo apt-get purge --remove wireshark-common sudo apt-get install wireshark-common nbox


0

Please update your repositories first by following command(check if you get any errors while update): sudo apt-get update Then try this: sudo apt-get -f install vlc The -f option will try forcefully install the package. If nothing works please try removing the dependencies or purging vlc.


0

BACK UP IMPORTANT FILES FIRST Type the following in terminal to remove libreoffice and openoffice: sudo apt-get remove --purge libreoffice* openoffice* sudo apt-get clean sudo apt-get autoremove Then install one or the other, this seems to be the only way. sudo apt-get install libreoffice OR sudo apt-get install openoffice If it is not found sudo ...


2

Open a terminal and type the following commands: sudo apt-get update sudo apt-get dist-upgrade sudo apt-get autoremove sudo apt-get autoclean sudo apt-get install gnome-shell gnome-shell-extensions Please post any errors, thanks. Aah, it appears you don't have the universe repository enabled. Go to software center or synaptic and go to edit > ...


0

Instead of installing through apt-get, you can also download Ubuntu GNOME desktop OS for free from their website : http://ubuntugnome.org/download/ Or, if you just want the Stand alone Gnome desktop without ubuntu, then you can simply go to www.gnome.org and Download GNOME 3.16 the latest version os for free. Personally, I prefer to download and install ...


1

This is because rhc and commander requires different versions of highline. Try this: sudo gem install highline --version 1.7.1 sudo gem install highline --version 1.6.1


0

I do not often use aptitude, but in case of problems with different gcc versions and unmet dependencies, apt-get is some times unable to correct problems saying "you have held broken packages" That's the day, you should install aptitude, and try to install the package you wish. It clearly shows all dependencies and makes not only one suggestion. First ...


2

Just remove these packages to let you use apt for other packages. Execute this commands in terminal. sudo apt-get remove openssh-server openssh-client --purge && sudo apt-get autoremove && sudo apt-get autoclean && sudo apt-get update Then reinstall openssh server and client . sudo apt-get install openssh-server openssh-client


0

Try: sudo gedit /etc/apt/sources.list.d/ondrej-php5-trusty.list Than remove the hashes (#) re-enable that PPA which were probably disabled by system sudo apt-get update sudo apt-get install skype


0

To remove package test from your system, you would run: sudo apt-get remove test To remove package test and its configuration files from your system, you would run: sudo apt-get remove --purge remove test Or you could use synaptic package manager to the same


3

I believe it depends on the package. Obviously, some dependencies are also dependencies for other packages, so those will stay installed. However, if you run sudo apt-get remove test or sudo apt-get purge test, then it will let you know that there are a bunch of dependencies that can be removed (albeit manually via sudo apt-get autoremove) if there are any ...


0

It says using the flag -f. That's an option. But you can also use this: sudo apt-get update && sudo apt-get dist-upgrade



Top 50 recent answers are included