Tag Info

Hot answers tagged

4

TL;DR: You can use reverse-depends src:$(what-source libsslcommon2). There is no libsslcommon2 source package. Instead, libsslcommon2 is one of a number of binary packages built from the qpid-cpp source package. In general, a binary package may or may not have the same name as the source package used to build it, and source packages may provide multiple ...


2

The reverse-depends software doesn't automatically detect the source package from which a given binary package is generated. The src: label is used to indicate that what follows is the name of a source package. It so happens that the name of the source package for bash is, well, bash. But for libsslcommon2, the source package is named qpid-cpp: $ ...


2

python3:any (>= 3.3.2-2~) is not a virtual package, it's a substitution string created by the ${python3:Depends} pattern and filled by dh_python3 when called from dh_gencontrol when the package was built. Take a look at the debian/control file of the apturl source package: Package: apturl-common Architecture: any Depends: ${python3:Depends}, ...


1

Try to remove the package you attempted to install by doing: sudo dpkg --purge <tgz_package_converted_to_deb> Alternatively you can try sudo dpkg --purge --pending but I think it could break your entire system since you have a lot of unmet dependencies issued by this python's installing attempt.


1

Force a downgrade to the lower version of python: sudo apt-get install python=2.7.8-1 If that doesn't work, download it, and use dpkg directly: sudo apt-get download python=2.7.8-1 sudo dpkg -i python_2.7.8-1*.deb Python is too important a package to be messed with, or even removed.


1

Try running this command to install all of the dependencies. sudo apt-get install unity-control-center gnome-control-center ubuntu-system-settings gnome-bluetooth unity8 ubuntu-system-settings-online-accounts libpng12-0:i386 address-book-service


1

You can just "resolve" this by installing all pending updates. The message will go away. It is rather annoying, but there's not much you can do about it. For more information check this bug report: https://bugs.launchpad.net/pipelight/+bug/1318321


1

This seems to be a bug of apt. Version 1.0.1 is affected. We've built version 1.0.9.2 from source, and it behaves as expected: reports unmet dependencies and exits with non-zero status. Perhaps this is the same bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=745046


1

I installed aptitude and got these proposed solutions: $ sudo aptitude install makerware The following NEW packages will be installed: avrdude{a} conveyor{a} conveyor-common{a} conveyor-ui{a} libarmadillo4{a} libarpack2{a} libboost-program-options1.54.0{a} libcoin80{a} libdap11{a} libdapclient3{a} libdigitizer{a} libepsilon1{a} libfreexl1{a} ...



Only top voted, non community-wiki answers of a minimum length are eligible