Hot answers tagged

3

Turkish repo have some problems. You can change /etc/apt/sources.list file. replace all lines http://tr.archive.ubuntu.com/ubuntu to http://archive.ubuntu.com/ubuntu and execute sudo apt-get update; sudo apt-get upgrade


2

I've got the same problem and fixed it. The problem occurred after I manually installed an incorrect gcc version with dpkg. First, you need to know which package caused the dependent problem. Use dpkg -l | grep gcc to find the wrong gcc package from the different package version. gcc-5-base is the incorrect version package for me. Then I try to reinstall ...


2

I was getting the exact same error. In the Software & Updates changing the server from my local country to Main server, and also adding the Canonical Partners from the "Other Software" tab helped installing the openssh-server in my case. I am not sure which of the two helped.


1

I had the exact same problem upgrading from 14.04 to 15.10. Following the OP's train of thought, I was able to solve this by running: sudo apt-get purge texlive* context dvipng feynmf fragmasater latex* luatex musixtex pmx propser tex4ht* tipa plus a few other dependencies that would emerge as I iterated on the apt-get purge command. After purging all the ...


1

To get Code::Blocks installing you have to get a bit creative, as first download the packages for Ubuntu 15.10 from here (simply do a search for libwxgtk2.8-). For a 64-bit system you can as well use the following links to download the packages. Best do the now stated commands in a separate directory so you not install any other downloads you maybe did ...


1

I think the issue is not the lack of dependencies in Linux, the problem is the WebEx update a couple of weeks ago. I read in other blog, that new WebEx is not longer supporing JAVA, reason why is not working for us.


1

No, it is not possible to have two versions of the same package, because there will be conflicting files. If a library is capable of being installed in two different versions at the same time is a different matter. If you're brave, you could get the source code for one version and see if you can install that to a different directory. This could very well ...


1

No, you can not have different versions of the same package installed at the same time. Usually dependencies are expressed as at least version X. For packages that are all built from the same source however, the dependency is often exact. This is what you have run into. libncurses5 and libtinfo5 are both built from the ncurses source package. If you ...


1

libc6-dev : Depends: libc6 (= 2.23-0ubuntu2) but 2.23-0ubuntu3 is to be installed libc6 and libc6-dev need to be the same version but the version of libc6-dev found on the mirrors apt is set up to use is older than the version of libc6 on your system and apt wont normally downgrade packages. In this case it looks like your issue is a badly outdated ...


1

You don't have any software sources configured, which means something went wrong with your installation. As there may be more problems I'd install the system again. Make sure you use an official up-to-date Xubuntu image. If you want to try to repair your system you can use for example https://repogen.simplylinux.ch/ to create a new sources.list After ...


1

Have a look here for a modified VidyoDesktop installer without the dependency on libqt4-gui: https://information-technology.web.cern.ch/comment/28#comment-28 Please note that it is a CERN protected page, so I prefer not to post the full link here, since the VidyoDesktop package is not free software


1

I had this exact same problem after the 16.04 upgrade. The thing is that I had emacs built from source, so I solved it by: re-downloading the source package, compiling & re-installing. See https://www.gnu.org/software/emacs/manual/html_node/efaq/Installing-Emacs.html for specific instructions. Hope it helps.


1

The error messages you get from apt in this kind of situation are slightly misleading: it's in fact telling you that the libwxgtk2.8-dev package is present but uninstallable. You can get better diagnostics by setting up an environment where apt has your PPA in its sources.list (the chdist tool can be helpful here to avoid disturbing your normal environment ...


1

You have to remove .save files cd /etc/apt/sources.list.d /etc/apt/sources.list.d$ ls and remove all with this /etc/apt/sources.list.d$ sudo rm opera-stable.list.save /etc/apt/sources.list.d$ sudo rm steam.list.save /etc/apt/sources.list.d$ sudo rm ubuntu-wine-ubuntu-ppa-xenial.list.save /etc/apt/sources.list.d$ sudo rm spotify.list.save Rastgele.


1

You can't tell Ubuntu to ignore the problem, but you can fake the installation of a package by building a dummy version. It's not that painful. sudo apt install equivs nano openjdk-7-jre Paste in something like the following: Section: misc Priority: optional Package: openjdk-7-jre Description: Dummy package And then run: equivs-build openjdk-7-jre ...


1

I have found another "arguably more appropriate" answer. This will actually give you the ability to correct the dependency mentioned inside the culprit package. You need atool (sudo apt install dpkg-dev devscripts atool) and gdebi (dpkg will do too, but I prefer gdebi) $pkg = the name of the package that is causing issue. apt-get download $pkg mkdir pkg ...


1

You can do that with << example: libvtk6-dev (>= 6.0.0), libvtk6-dev (<< 6.2.0) This way you have locked the range between 6.0.0 and 6.1.0. The same way you have to specify for each package individually, there is no if this dependency is this then ask for that.



Only top voted, non community-wiki answers of a minimum length are eligible