Hot answers tagged

7

If you do need a reboot after installation you will make a call to /usr/share/update-notifier/notify-reboot-required in the .postinst script for your package. This can easily be found be reading the .postinst script of any linux-image package. However, I would be concerned about any custom PPA that requires a reboot after installation. Other than ...


7

I also got this error and found a workaround. just manualy download and install the .deb package from this link and the error is gone. http://www.ubuntuupdates.org/package/google_talk_plugin/stable/main/base/google-talkplugin


5

The short answer is yes, you'll need to rebuild your snap if you need to update a dependency. However, there's a longer answer here, too. Say you have some application that uses SSL (could be some embedded software or a full-blown website using Apache). You do your research and utilize specific key exchange and symmetric algorithms. Now say a security ...


3

Building a package.deb from directories : cd new-folder/ && mkdir -p packagename/DEBIAN Your files e.g. usr/local/bin/executable goes into packagename/ ... and the file control into DEBIAN/ Example control file : Package: name Version: 1.1-1 Section: base Priority: optional Architecture: amd64 Depends: Maintainer: Jerry Donut <jerry@donut....


3

The file appears to be corrupted, it's not an installation issue. Delete the file, redownload it, and try to dpkg it again.


2

The reason why you can't find the .deb file in the /var/cache/apt/archives/ directory is because it isn't there anymore. The locate command finds it because locate does not look at the actual directory contents but works from a cache. From man locate: locate reads one or more databases prepared by updatedb(8) and writes file names matching at least ...


2

Based on what you explain I am understanding that you are using Software Center to install your .deb files. I suggest you to use the terminal, this way you can see what is causing the problem and probably fix it directly in the terminal. The majority of the times a .deb install and find errors, the system reverts the changes in order to avoid incomplete/...


2

Open a Terminal window and type: sudo apt-get install gdebi. When install has finished, close the Terminal, right-click on deb file and choose 'Open with gdebi'. Wait for the installation to finish, close Gdebi and start SublimeText from the main menu. Gdebi never failed me with any native deb file. It failed me only once, but the deb file was converted from ...


2

Take a look at https://github.com/ubuntu/snappy-playpen/blob/fd5d4a3a1e3f0acc13370adbf98c9a3481d1328a/leafpad/snapcraft.yaml for a simple example. The relevant part of snapcraft.yaml here is: parts: leafpad: plugin: nil stage-packages: [leafpad] Here you define a part called leafpad, for which nothing needs to be done (nil plugin), but the ...


1

As described here. wget http://de.archive.ubuntu.com/ubuntu/pool/universe/q/qtmobility/libqtmultimediakit1_1.2.0-1ubuntu2_amd64.deb sudo dpkg -i libqtmultimediakit1_1.2.0-1ubuntu2_amd64.deb 3.sudo apt-get install -f sudo sh -c "echo 'deb http://download.opensuse.org/repositories/home:/olav-st/xUbuntu_15.10/ /' >> /etc/apt/sources.list.d/screencloud....


1

This can't be done with just the dependencies on your package. Without special configuration, apt-get always prefers the highest version available, so, even if your package depends on python-cherrypy3 (<< 3.2.5), it will pick the highest version of python-cherrypy3 available. And since Ubuntu 15.10 and above have only 3.5.0+, that's what you'll get. ...



Only top voted, non community-wiki answers of a minimum length are eligible