Hot answers tagged

23

I had the same problem with conky in fluxbox. I solved the problem by changing own_window_type override to own_window_type normal (line 17 in your .conkyrc) Check out more conky configuration settings here: http://conky.sourceforge.net/config_settings.html The above answer would apply in most cases, however in this particular case it doesn't work well. ...


18

Seems like setting window type to desktop is not enough sometimes. Try: own_window_type desktop own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager Got it from here. Works for me in XFCE. I'm guessing it'll be fine for lxde/openbox as well.


10

When own_window_type override is used the distortion is caused. Now to clear the distortion one may use own_window_type desktop in the .conkyrc instead of own_window_type override . But this causes other problems like disappearance of conky when trying to work in the desktop(i.e right clicking, opening a menu from panel etc.). Therefore instead of ...


8

A): Your .conkyrc states own_window yes. This means that conky has it's own window. By stating own_window_type normal the window is being told to act "normally". Thus the conky-window will as well as any other window minimize when the "Show desktop" option is used. B): What would keep conky in its place is changing own_window_type normal to ...


8

Lua scripting solution This is indeed possible using Lua scripting. You can use the script below (the number conversion is taken from rosettacode.org). The script can do a boring option, which will translate 12:45 to "twelve forty-five", and an awesome option which will translate it to "a quarter to one". It also does a Uri Herrera option which does the ...


8

Just replace own_window_type override with following lines: own_window_type normal own_window_argb_visual yes and use following command to start conky automatically at startup: bash -c "sleep 20; conky"


6

This config works, on Gnome and Cinnamon and is the way to do it. own_window yes own_window_transparent yes own_window_type dock own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager own_window_argb_visual yes own_window_argb_value 100 gap_x 940 gap_y 20 The last 2 attributes absolutely position it on screen and need to be changed for your ...


6

Conky is a lightweight system monitor. It sits wherever you put it in your desktop and tells you a bunch of system info like RAM usage, CPU, etc. It can work in both Unity and GNOME Classic (not sure about GNOME3) and any Environment for that matter. To install Conky, simply type sudo apt-get install conky in the terminal. After the installation had ...


6

According to the Conky help, you can specify this in the config file ~/.conkyrc Quote: temperature_unit Desired output unit of all objects displaying a temperature. Parameters are either "fahrenheit" or "celsius". The default unit is degree Celsius.


6

Install Conky in Ubuntu/Linux Mint open terminal Ctrl+Alt+T and copy the following commands in the Terminal: sudo apt-get install conky conky-all First of all Download Startup script with following commands: cd && wget -O .start-conky http://goo.gl/6RrEw chmod +x .start-conky Now open Startup Applications > click Add > New Dialog box will ...


6

NetworkManager itself can change a network interface MAC address and it will not be changed back to the default one while the connection is established. Edit the network connection (NetworkManager indicator -> Edit connections -> Wireless tab -> Select a connection -> "Edit" button). In the "Wireless" tab you'll find a "Cloned MAC address" textbox. Type in ...


5

Just make script that will change mac address and make it run whenever you connect to network #!/bin/sh sudo ifconfig wlan0 down sudo macchanger -a wlan0 sudo ifconfig wlan0 up How to run cron job when network is up? EDIT @n00b, answers to your questions. So as I read here you can set macchanger to change MAC address automatically using macchanger ...


5

You need echo $temp*9/5+32 | bc. Variables are prefixed with a $ and can not be inside single quotes.


5

After some searching around I found that an issue between Compiz and Gnome-WM meant that Conky was starting before Compiz was loaded. The workaround is to delay starting Conky with examples suggesting about 20 secs. Create a new file with Text Editor named ~/.conkystart Paste the following code into the file and save it #! /bin/bash sleep 20 ...


5

To solve these problems, don't paste the settings for opening in a new window, just delete the code. What to delete (usually if you copied the code, it has this): #Create own window instead of using desktop (required in nautilus) own_window yes own_window_hints undecorated,below,skip_taskbar background no


4

Segmentation fault (core dumped) means that the application has done something unexpected, hence the crash. For that, need to: ensure you are up to date with latest version of the package enable apport (see https://wiki.ubuntu.com/Apport#How to enable apport) ensure /var/crach/compiz.crash is cleaned (rm /var/crach/*compiz*.crash) wait for it to crash :) ...


4

Yes it is. The idea is that you edit your lightdm configuration file (/etc/lightdm/lightdm.conf) and set the greeter-setup-script variable to start conky. A complete example might be found at: http://vogelchr.blogspot.com.br/2012/11/ligthdm-custom-app-on-login-screen.html


4

Had that problem yesterday. What I did was change my .conkyrc file. In window specifications: own_window_type normal to own_window_type desktop And everything worked. Hope you fix yours.


4

Provided that you installed your conky correctly use the following: Name a file .conky_startup and put the following lines in it: #!/bin/bash sleep 10 && conky ; Put the file in your home directory (the directory with your username). Next go to Session and Startup and the tab Application Autostart , create a new entry with Add and fill in a ...


4

Conky can show actual amount of RAM being used plus cached memory or just the former one. To toggle between two, You can use buffer settings: If no_buffers yes Conky will show only actual amount of RAM being used. If no_buffers no Conky will show actual amount of RAM + Cached memory


4

This is a classic issue with conky. the solution is usually to have it wait a few seconds. One way to do this is to write a script that calls conky with a delay and add that to your startup applications instead of conky itself: #!/usr/bin/env bash ## Wait 10 seconds sleep 20 ## Run conky conky Save the script above as (for example) $HOME/start_conky.sh, ...


4

If you're having problems updating in Ubuntu do this: Remove the file nitrux-icon-theme.list in /var/lib/dpkg/info/, and update your package cache. The packages have been updated since, so do that, and re-install it.


4

I figured it out. Thanks to this thread I made some changes to the window parameters they are now: own_window yes own_window_type normal own_window_argb_visual yes own_window_transparent yes own_window_hints undecorate,sticky,skip_taskbar,skip_pager,below own_window_type was override and I added the own_window_arb_visual yes parameter Hope this helps ...


4

I found solution: just disable “Hide Skip Taskbar Windows” in General Settings in Compiz-config-settings-manager (ccsm) howto-disable-conky-minimization-on-show-desktop


4

This is possible with xscreensaver: 1) Install xscreensaver sudo apt-get install xscreensaver xscreensaver-data 2) run "xscreenserver-demo" once in order to create an initial configuration file xscreensaver-demo 3) Edit the configuration file .xscreensaver in your home directory gedit ~/.xscreensaver 4) Append the following line to the list of ...


3

"If I change own_window_type to 'normal' it have transparency and doesn't disappear on clicking on desktop but it minimize when I click on show desktop button and doesn't recover (still running)." Do not minimize on Show Desktop Using Compiz: If the 'Show Desktop' button or key-binding minimizes Conky along with all other windows, start the Compiz ...


3

Keep configuring conky (at least this worked for me): own_window_type desktop #own_window_type override own_window_transparent yes #own_window_transparent no


3

"So, what should I do to raise all the windows?" Presumably you mean all the conky windows? Since wmctrl is not doing what you want by specifying the window name, you should use the more exact method of speciying the window id. To get the list of window ids one does wmctrl -l So assuming your windows have superconky in the title, to extract just the ...


3

You need to first start hddtemp as a background daemon with the commmand: hddtemp -d /dev/sda ${hddtemp ...} is a conky built-in object. It connects to 127.0.0.1:7634 by default to get the disk temperatures. You therefore need to start, independently, the hddtemp daemon which listens on this port and replies with the information. An alternative is to ...


3

If you don't want to have hddtemp running in daemon mode all the time, you could also run hddtemp as an external command instead. However, hddtemp needs to be run as root: $ hddtemp /dev/sda /dev/sda: open: Permission denied $ sudo hddtemp /dev/sda /dev/sda: ST3500418AS: 35°C So, you will first need to give your user permission to run the command. Run ...



Only top voted, non community-wiki answers of a minimum length are eligible