Tag Info

New answers tagged

1

sudo apt-get install libssl-dev ./configure --prefix=/usr --libdir=/usr/lib/x86_64-linux-gnu sudo make sudo make install Is all I needed to build curl 7.43 on ubuntu 15.04


1

If you prefer to install Oracle JDK, a step by step instruction on installing Oracle JDK 8 is explained in this article : Install Latest Oracle JDK in Ubuntu


1

Basically, re-compiling the source is as easy as outlined in this code snippet on github, which mainly is making sure that the paths are correct for Ubuntu. Here is a short overview on which paths are important for ubuntu: ./configure --prefix=/etc/nginx \ --sbin-path=/usr/sbin/nginx \ --conf-path=/etc/nginx/nginx.conf \ ...


0

@karel answer is the correct one. But in the spirit of "teach them to fish": if you need to find which package provides a certain file, install apt-file sudo apt-get install apt-file sudo apt-file update (repeat the update from time to time) and then, in your case: [romano:~] % apt-file search vlc/vlc.h libvlc-dev: /usr/include/vlc/vlc.h


2

In all supported versions of Ubuntu vlc.h is provided by libvlc-dev. This package contains headers and a static library required to build standalone applications that use VLC features. To install libvlc-dev open the terminal and type: sudo apt-get install libvlc-dev When libvlc-dev is installed, the path to vlc/vlc.h is /usr/include/vlc/vlc.h


0

Install libqt4-dev or qtbase5-dev


0

peyo-hd's answer is correct!!! I faced the same issue today. And I fixed it by doing the flowing steps. Open grub2 default config sudo vim /etc/default/grub Comment out the two lines and set a proper timeout # GRUB_HIDDEN_TIMEOUT=0 # GRUB_HIDDEN_TIMEOUT_QUIET=true GRUB_TIMEOUT=10 Update grub sudo update-grub2 Reboot and select the older kernel


1

I quickly found out that it couldnt find some headers because i didnt properly copied them (silly me). But it didnt solve the linking problem. I managed to solve that with manually compiling opencv for every architecture and inlcuding the library files in the project, following this project as a reference: https://github.com/nikwen/ubuntu-tox-client


2

It seems kernel 3.13.0-59-generic caused this issue. Downgrading to 3.13.0-57-generic fixed it.


0

Home isn't a real directory: it's just what the file manager (nautilus) uses as a shorthand for the user's home directory, otherwise known in the shell as $HOME. It usually expands to /home/username (where username is replaced by your actual login name) but you should confirm by running echo $HOME in a terminal.


1

My two cents: The file with the name /usr/lib/gcc/i686-linux-gnu/4.8/libgcc.a is part of the package libgcc-4.8-dev Therefore sudo apt-get install --reinstall libgcc-4.8-dev


1

I found the problem. There was an old, corrupt installation of gcc-4.8, which doesn't get replaced when build-essential is installed. I used sudo apt-get remove gcc-4.8 sudo apt-get remove --purge sudo apt-get auto-remove sudo apt-get install build-essential Now the test runs fine.


0

It might be better to remove the offending macro by deleting line 66 from the rtw_debug.c file. sed -i -e '66d' /home/andy/RTL8812AU_linux_v4.3.8_12175.20140902/driver/rtl8812AU_linux_v4.3.8_12175.20140902/core/rtw_debug.c Now you can continue with the build: cd /home/andy/RTL8812AU_linux_v4.3.8_12175.20140902/ sudo make clean make sudo make install


0

Add -lrt after the source file, example: g++ -O3 -o netmon netmon.cpp -lrt Here is an other discussion about the same problem.


3

Usually the build process from the ~/Downloads/vmd-1.9.2/ folder should be: ./configure make sudo make install I am not familiar with vmd at all to know if it is possible to run on your system, but those are the steps that I have followed on the majority of installs from source. Hope this helps.


0

This is not Ubuntu specific. /home/sam/buildroot/buildroot-2015.05/output/host/usr/bin/x86_64-buildroot-linux-gnu-gcc seems to be missing. Normally buildroot builds its own toolchain first. Maybe you have some craft in /home/sam/buildroot/buildroot-2015.05/output ? Try to remove the output directory and try again.


0

You do not need any drivers for your wireless dongle. They are already included in Linux kernel. You tried to install a very old driver that was needed when kernel did not support this device out of the box. That old driver will not build for new kernels anyway.


0

It seems there are some sintax errors, maybe a dot or dot-comma symbol is missing in the file, error: expected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘attribute’ before ‘rtl8187_usb_probe’ . As in any programming file, the problem could be near the beginning of the file.


0

I did it by downgrading GCC in my Ubuntu here it is .. 1 - Uninstall GCC 5.1.1 : sudo apt-get remove gcc-5 sudo apt-get remove --auto-remove gcc-5 sudo apt-get purge gcc-5 2 - install gcc 4.9.2 sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update sudo apt-get install g++-4.9 3 - make a link to your gcc 4.9.2 ln -s /usr/bin/gcc-4.9 ...


0

You can switch your modem to only modem mode by running in terminal echo -e 'AT^SETPORT="A1,A2;10,12,13,A2"\r' | sudo tee /dev/ttyUSB0 then re-plug the modem and wait for 30 seconds. After this setting the modem may not work with vendor software in Windows. You may need to setup a telephone connection there. This setting can be undone by echo -e ...


0

I found some bugs in the link above: I need to modify the CMakeLists.txt file in data directory by commenting the single line in it, because this line tries to install unity file inside /pam.d directory where normal users cannot do this, so I created the folder manually and copied the file then changed permissions. I had to manually create the folder ...


0

Please, do not use vendor drivers from Une, Tigo, and the rest of the Movile broadband devices vendors. That drivers cause a lot of problems and can simply break your internet connection. I had a similar problem with a ZTE modem from Movistar, i tried to install the driver, but that let me wihout internet and borke my modem manager. Check if you have ...


1

Without understanding your PATH variable, I believe, there are some typos export PATH=$PATH:/opt/local/bin:/opt/local/sbin:/usr/bin/c++/usr/bin/make between .../c++ and /usr/bin... Use export PATH=$PATH:/opt/local/bin:/opt/local/sbin:/usr/bin/c++:/usr/bin/make And install g++ sudo apt-get install g++


3

That directory is part of a full kernel source tree. The standard way to compile it is together with the rest of the kernel. For some part of the tree it is possible to compile some module standalone --- but it s not a trivial task. You can look in this thread for a starting point.


3

That is part of the kernel tree, and not a separate external module. It's to be built with the build of the kernel, depending on how the build is configured. If you want to build that module for an older kernel, you need to build it in the context of the older kernel, as a module, and you may need to do quite some back-porting work on 12.04 as that tree is ...


0

sudo apt-get install apt-file sudo apt-file update apt-file search -x /hdf5.h$ should yield libflann-dev: /usr/include/flann/io/hdf5.h libhdf5-dev: /usr/include/hdf5/serial/hdf5.h libhdf5-mpich-dev: /usr/include/hdf5/mpich/hdf5.h libhdf5-openmpi-dev: /usr/include/hdf5/openmpi/hdf5.h libopencv-flann-dev: /usr/include/opencv2/flann/hdf5.h I have no idea ...


0

Simply install the right packages: sudo apt-get install sfftw-dev sudo apt-get install libhdf5-dev


0

Note: the underlying issue is likely that the configuration of the software you are trying to build is based on an out-of-date version of the GNU autotools system. The right way to fix it is probably to modify the scripts and regenerate a more appropriate ./configure script: if I understand the process correctly, autoreconf should help with this, but seems ...


0

It says that "FindIntltool.cmake" is not provided. This file is distributed in the cmake-extras package. Install it in the chroot (kit) that is used to build the project.


3

From the log: configure:3478: gcc -03 conftest.c >&5 gcc: error: unrecognized command line option '-03' The option is -O3 with the letter O, not the number 0. So, you should run, as given in the README: ./configure CFLAGS="-O3"


2

Looks like your CFLAGS has a zero instead of capital O. That is invalid, and causing the compilation to fail. You can fix it, but really, look for a later version of the package which has been fixed.


1

My guess would be that you have the basic C compiler installed, but not the headers for the standard library. Try: sudo apt install libc6-dev [Edit: this produces similar symptoms, but wasn't the case here. The CFLAGS answers appear to be correct.]


1

If you read the requirements for building aircrack-ng from source on linux, you can see that it needs libssl-dev. So install it using: sudo apt-get install libssl-dev


0

Yes, you can. Especially if you compile the latest Ubuntu kernel. ;-) You can also use mainline kernels in Ubuntu. But you do not have to build them. They are already built in Ubuntu Mainline PPA. You can always redo it in educational purposes. New kernel with new features will "magically" work in Ubuntu. Compiling a custom kernel with removing unneeded ...


0

I recommend to install GNU Radio via pybombs. The version in the repo is usually pretty outdated.


5

To understand this answer, please read the entire revision history of OPs question. Follow ALL steps and not only what you think ;) Before you can start make … Install the following packages sudo apt-get install swig sudo apt-get install libboost-all-dev sudo apt-get install cmake-data sudo apt-get install liblog4cpp5-dev sudo apt-get install ...


3

install libhdf5-dev add patch to libhdf5 in Makefile.config. example: INCLUDE_DIRS := $(PYTHON_INCLUDE) /usr/local/include /usr/include/hdf5/serial/



Top 50 recent answers are included