Hot answers tagged

3

Notepad++ is not a compiler and does not contain a compiler. You must install a separate compiler, then configure Notepad++ to use it. The NppExec plugin (docs) can be made to do this. (I've never done it, so I cannot verify that the following currently works.) This answer over on stackoverflow gives detailed instructions to use NppExec to save the ...


2

To install the biogeme program, download the deb file at http://biogeme.epfl.ch/distrib/biogeme_2.4.0-1_amd64.deb and run sudo dpkg -i biogeme_2.4.0-1_amd64.deb. This will install the necessary binaries to your /usr/local/bin directory. As can be seen in section 4 of page 6 of the PDF at http://biogeme.epfl.ch/documentation/bisonfirstmodel-2.4.pdf, to use ...


2

Geany should already have a build configuration for Objective-C, provided by the filetypes.objectivec file (part of the geany-common package): [build_settings] # %f will be replaced by the complete filename # %e will be replaced by the filename without extension # (use only one of it at one time) compiler=gcc -Wall -c "%f" linker=gcc -Wall -o "%e" "%f" -...


2

I managed to build LLVM 3.7.1 using the following steps. I am not sure if this is the 'proper' way to do it, but hopefully others can correct me if any of the steps are wrong. This was largely based on http://linuxdeveloper.blogspot.com/2014/06/building-llvm-342-from-source.html mkdir llvm cd llvm wget http://llvm.org/releases/3.7.1/llvm-3.7.1.src.tar.xz ...


2

You can set CONCURRENCY_LEVEL variable for that. Run the command this way CONCURRENCY_LEVEL=8 fakeroot debian/rules binary-headers binary-generic This variable is set to the number of CPUs automatically.


2

Core dumping is disabled by default in Ubuntu by setting the maximum dumping file size to 0 for all users. You can check this by: ulimit -c By default it would show 0. Now to enable core dumping, set the size to the value you want (or unlimited). For example, setting the maximum dumping file size as 4 KB: ulimit -c 8 -c takes block numbers with each ...


2

Section 6.39 Dollar Signs in Identifier Names of the GCC manual states: In GNU C, you may normally use dollar signs in identifier names. This is because many traditional C implementations allow such identifiers. However, dollar signs in identifiers are not supported on a few target machines, typically because the target assembler does not allow them.


1

Assuming you've installed nodejs (sudo apt-get install nodejs), the problem is the same as reported here — Ubuntu and Debian now install node at /usr/bin/nodejs rather than /usr/bin/node. The two solutions least likely to break your system (in the long-run), are either: Install nodejs-legacy (sudo apt-get install nodejs-legacy), which provides a symlink ...


1

You'll want to add a -Idir flag to your CXX flags in the make file and likely the cmake file. The dir would be the path to the headers you do want to use. If just including the proper directories doesn't work then it would be best to also disable the default include paths with --nostdinc but this shouldn't be needed since it searches the include directories ...


1

The package installation of other architecture compilers puts them into a system area. The executables are uniquely named, but the package is too "helpful" and thinks you really need a short name link (like gcc) to point to them, and whoa, another package already uses that link, gotta delete it for you. This might be fine in a virtual machine, dedicated to ...


1

ParaView : I saw openmpi mentioned somewhere ... ... so it will be $ sudo apt-get install libhdf5-openmpi-dev Ubuntu 14.04 - 64bits : I also installed libqt4-dev , and the cmake configuration is OK : The Makefile was created ... and make runs OK so far. One thing to mention : A lot of small files are downloaded to 'build/ExternalData/ while the "make" runs....


1

As we can see from your diagnostic output, gcc uses the external program as (which is /usr/bin/as) - the GNU assembler - and it is this that is failing. Somehow, it appears that the as binary executable has been corrupted on your system, to the point where even /usr/bin/as --version causes a bus error. (Although apparently it is intact enough for the file ...


1

If you just need kernel symbols to run systemtap, easiest way is to install the dbgsym package for your kernel, it'll be a lot less painful than recompiling the whole kernel yourself: Head over to How to install Ubuntu kernel debug symbols. If there's no matching dbgsym package you might need to upgrade your kernel. See apt-cache search 'linux-image.*...


1

The above is not working anymore with the current versions. I ended up with the following: git clone https://github.com/sass/libsass.git ~/libsass echo "export SASS_LIBSASS_PATH=~/libsass" >> ~/.bashrc source ~/.bashrc git clone https://github.com/sass/sassc.git ~/sassc cd ~/sassc make echo "export PATH=$PATH:~/sassc/bin/" >> ~/.bashrc source ~...


1

Based on this blog article, if you specify INSTALL_ROOT the PHP apache module will try to install in that directory. INSTALL_ROOT=/the/dir/path/to/install/in make install The other thing you might want to try adding this option to your ./configure of php-src: --libexecdir=DIR program executables [EPREFIX/libexec] --sysconfdir=DIR read-...



Only top voted, non community-wiki answers of a minimum length are eligible