Tag Info

New answers tagged

0

The "coloring" is called syntax highlighting and it is based on the detected file type. The file type detecting pretty much works on two paths: from file extension. So a file with extension .py is recognized as Python file. This can be configured via Tools->Configuration Files->filetypes_extensions.conf from manual choice from inside Document menu. So ...


0

One can check out ccat. It adds syntax highlight to output files.


0

You can manually specify the filetype via the menu at "Document->Set Filetype". In your case, you would want "Document->Set Filetype->Scripting Languages->Python source file".


1

This is working in gnome-terminal + vim on Ubuntu 14.04: Firstly, set the bash setting as the end of ~/.bashrc file like this: if [ -n "$DISPLAY" -a "$TERM" == "xterm" ]; then export TERM=xterm-256color fi Next, set the vim setting at the end of ~/.vimrc file like this: if $COLORTERM == 'gnome-terminal' set t_Co=256 endif You will need to load a ...


1

Have you looked at redshift? Although designed for a different purpose, it does have features for setting the colour temperature of your screen. sudo apt-get install redshift This is my config file ~/.config/redshift.conf: [redshift] temp-day=5700 temp-night=4600 brightness-day=1.0 brightness-night=0.75 gamma=0.8 adjustment-method=vidmode ...


2

Since you have an Nvidia GPU, you can use Nvidia X Server Settings to create your own color correction settings. Install Nvidia X Server Settings: $ sudo apt-get install nvidia-settings Launch: $ nvidia-settings Find the Color Correction tab for the display you wish to calibrate (under "GPU 0 - (Quadro FX 2700M) -> DFP-0 - (LGD)" in the following ...


-1

UPDATE- As waltinator says executing bash command right after ls command will create child shell which will probably eat up resources , I had to look for another solution. I tried executing echo -ne '\e[1;31m' light after ls command therefore I put it in the bls funciton. I somehow reached to my own solution to this problem. The suggestions by meuh and ...


0

Commands which set colours may finish by sending the sequence ESC [ 0 m to reset the current attributes for the terminal. The easiest thing for you to do is change your shell prompt to always set the colour back to what you want. Add to your .bash_profile: export PS1='\e[1;31m'"$PS1"


0

Very simple Add these three lines to ~/.bashrc root@hostname# vi ~/.bashrc export LS_OPTIONS='--color=auto' eval "`dircolors`" alias ls='ls $LS_OPTIONS' If you want to apply the changes, type the following in your home directory: root@hostname# . .bashrc


1

I think you can achieve what you want with xcalib If it's not installed: sudo apt-get install xcalib try something like xcalib -i -a xcalib -invert -alter xcalib -co 70 -a To reset screen xcalib -c For more info about xcalib check out http://manpages.ubuntu.com/manpages/precise/man1/xcalib.1.html or xcalib -h Following link may also ...



Top 50 recent answers are included