Tag Info

Hot answers tagged

55

For 13.04: Pre-Install: Three terminal-commands: sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 sudo apt-get install dkms libqtgui4 wget execstack libelfg0 dh-modaliases sudo apt-get install linux-headers-generic xserver-xorg-core libgcc1 Additional two terminal-commands for 64-bit: sudo apt-get install ...


16

For 12.10: It works for me!! And here is the how-to which I created for you: Pre-Install: Three terminal-commands: sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 sudo apt-get install dkms libqtgui4 wget execstack libelfg0 dh-modaliases sudo apt-get install linux-headers-generic xserver-xorg-core libgcc1 Optional ...


10

For 13.10 it works without tweaking on a fresh Ubuntu 13.10 install: 1) Open the terminal and type sudo apt-get install fglrx fglrx-pxpress 2) and reboot


7

I haven't tried it yet but I found this PPA. The latest fglrx that supports pre-HD5000 GPUs, is Catalyst 12.6 Legacy. But it doesn't support Ubuntu 12.10 from what I have heard. I am also concerned about this as I want to update to Quantal but fgrlx is a must have for me. I still don't have Quantal so I could not test it. Test it at your own risk.


7

I suggest two things 1 In a terminal type the following fglrxinfo This will tell you if fglrx is installed and working well you should see an output similar to: $ fglrxinfo display: :0 screen: 0 OpenGL vendor string: Advanced Micro Devices, Inc. OpenGL renderer string: ATI Radeon HD 4300/4500 Series OpenGL version string: 3.3.11399 Compatibility ...


6

After using amdcccle to set the monitors as required, apply and exit, then from System -> Preferences -> Screen Resolution [or Monitors in Debian], verify it is showing the resolution you configured in amdcccle and click apply. The next time you restart or login the settings will be preserved.


5

Here is the correct way to remove the ATI drivers: sudo sh /usr/share/ati/fglrx-uninstall.sh sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* Note: ignore any errors you may have got form running the first 2 commands. Remove your xorg.conf file sudo rm /etc/X11/xorg.conf Re-install xorg sudo apt-get install --reinstall ...


4

For 13.10: Pre-install: Execute three terminal-commands: sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 sudo apt-get install dkms libqtgui4 wget execstack libelfg0 dh-modaliases sudo apt-get install linux-headers-generic xserver-xorg-core xserver-xorg-video-all libgcc1 Additional two terminal-commands for 64-bit: ...


4

I thought I'd make another answer (can't comment ffs) seeing as though I got this issue on a clean 14.04 install and it took me another step to get it to work First thing I did was run sudo apt-get install gksu As Remy5460 said, but I was just getting a graphical prompt that told me my password was wrong instead! To fix this, all I had to do was run ...


4

For the purpose of this question: Catalyst = fglrx = proprietary AMD/ATI display driver The most problems people are having come from the fact that: 1. Ubuntu has moved to newer driver versions, that don't support some older ATI/AMD chips 2. Ubuntu has moved to newer Xorg versions Symptoms: No. 1 - 'not supported' errors / Jockey not detecting proprietary ...


3

If any software (driver too) is closed source (like what you installed) it isn't open to reviewing or improving anything.Closed software can be reverse engineered but it is problematic (legally too) If you don't have to use closed source software then don't. When it is closed source no one knows what the code is except from who made it, so this is also a ...


3

I have a Vaio VPCSE with AMD/Intel hybrid graphics, too, and I followed your how-to step by step. Unfortunately, when I changed to integrated graphics in Catalyst, I got lost after login just as you desribed. When changing to discrete graphics, it works – but I can use fglrx from the sources for that. So my only workaround, which I'm not quite happy with, ...


3

I don't use a 4xxx series card but there is a new PPA available for the purpose you describe. instructions here: http://www.ubuntuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html


3

Just run amdcccle from terminal, you can also make a shortcut, to run as root use sudo amdcccle.


3

Delete the file ~/.config/monitors.xml.


3

try sudo rm /etc/X11/xorg.conf and reboot your system which will delete your X server setting so next time you reboot x server will try to detect your optimal setting , and i solved a problem which faced me with resolution with the same method


2

I am a user of a very similar card, with a fully functioning Ubuntu set up with Catalyst aka fglrx. You want Catalyst 12.9 out of the repositories i.e. what Ubuntu suggests in the Software Sources part of the Software Center. Don't go for earlier versions and don't go for more recent versions. You will also want to install linux-headers-generic. If you ...


2

Maybe installing legacy fglrx 12.6 would help. Chceck it out: http://www.ubuntuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html


2

This answer was provided by Tom Rakoncátlan who as a new user cannot answer this protected question, so I have posted it here on his behalf. Solution is described at https://help.ubuntu.com/community/BinaryDriverHowto/ATI Quote: "If you experience underscan when outputting video to an HDTV, this may resolve the issue: sudo aticonfig ...


2

I had the same issue a couple of months ago after installing the Catalyst drivers. Try this: From the LightDM login screen, hit Ctrl-Alt-F1 to switch into a console. Login with your administrative username and password. From there, try running the following commands: sudo mv ~/.Xauthority ~/.Xauthority.backup sudo service lightdm restart Then try to ...


2

Same problem here, with Ubuntu 12.04TLS amd64, on a AMD A10 with integrated AMD Radeon HD6670 video and a AOC 23" monitor connected via HDMI. I had the same monitor on a 32bit 12.04TLS Ubuntu on a much older AMD CPU and its integrated video card, and the screen used also a part of the panel, but changing the DTV settings in Catalyst Control Center solved it ...


2

Not the optimal solution, but at least you don't need to change your system's regional preferences. Catalyst defaults to English if you remove (or rename) the language file in it's folder. :) In my system (Ubuntu 13.10 with Catalyst 2.18) the language files were in: /usr/share/ati/amdcccle I hide it from the system by renaming the amdcccle_XX.qm file to ...


2

George A. solved the problem in his question: The problem must lie with Pulseaudio, as I followed the instructions here to uninstall it and, after rebooting, everything worked perfectly!


2

some times may be that graphic driver will behave like that, and nothing to worry about this problem. You have to reset or change to default settings of Graphic driver or Screen Settings provided by Ubuntu Operating system.


2

I'm running with a Radeon HD 6400M, and 13.04 seems to really not like the updated graphics drivers (or at least, that's the conclusion I've come to). After installing them I had exactly the same issue. For me, the following worked: sudo apt-get purge fglrx followed by (possibly after a reboot, I can't quite remember. Probably do one just to be sure) ...


2

First, check your graphic card name and chipset: sudo update-pciids #optional command, requires internet lspci -nn | grep VGA It should report something like this for your graphics card: 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710 [Radeon HD 4550] then you can check that is your graphic card is fully supported of not ...


2

From http://wiki.cchtml.com/index.php/Ubuntu_Saucy_Installation_Guide#Removing_Catalyst.2Ffglrx Removing Catalyst/fglrx The uninstall script in the first command will only exist if you downloaded the drivers and installed them directly (rather than building packages as this guide does). Skip the first command if it does not exist. sudo sh ...


2

When booting, press and hold shift key to get the GRUB menu, and enter the recovery mode: Then drop into the root shell prompt: You will be given a command line interface. Issue these commands to remove ATI drivers: sudo apt-get remove fglrx sudo apt-get remove fglrx-updates If you have manually installed the ATI driver by downloading ...


1

You'd better install the proprietary drivers from the release repository : sudo apt-get install fglrx fglrx-core fglrx-amdcccle fglrx-pxpress sudo ln -svT /usr/lib /usr/lib64 #Only for Ubuntu 64bits sudo amdconfig --initial never again, it's NVIDIA or nothing next time! My previous laptop was nvidia hybrid and it was as difficult as for amd graphic ...


1

I have the same version of Ubuntu and I installed the same drivers. I think you have a couple of ways to determine the catalyst version: use amdcccle and under the Information tab you get the software version look in /var/log/apt/history.log the version of the most recent fglrx package you installed. Whatever you choose, the answer to your question (as ...



Only top voted, non community-wiki answers of a minimum length are eligible