Tag Info

New answers tagged

1

I have no idea why (never really understood the escape codes), but adapting the other prompt seems to work: PS1='\[\033[1;32m\][\W]\$ \[\033[00m\]' Apparently, you need to enclose the escape sequences in \[...\], to tell bash not to count them while determining the prompt width. Therefore, both the above PS1 and the following would work equally well: ...


3

You can create a script in /etc/profile.d/ to make aliases for all users: Create a file called 00-aliases.sh (or any other fancy name) in /etc/profile.d: gksu gedit /etc/profile.d/00-aliases.sh Put you aliases in this file. Example: alias foo='bar --baz' alias baz='foo --bar' Save the file Restart any open terminals to apply the changes. Enjoy! ...


1

Personal background I spend a lot of time in GVim which I’ve configured to use the Solarized colour and I love it; I really like being able to switch back and forth between the light and dark versions (depending on the ambient light conditions). Once I tried it configuring my terminal emulator and it worked fine on my local computer because I had other ...


1

What will you need ? xdotool (sudo apt-get install xdotool) and couple different profiles. I have 8 different profiles in my gnome-terminal , all with different colors or background settings. Make sure you have the menu bar (File, Edit, etc.) enabled. Otherwise - won't work The command xdotool key alt+f b $( expr $RANDOM % 8 ) Explanation: we get a random ...


1

To add a file to your PATH, first find out what PATH is with: echo $PATH Then, move the file to one of those directories.


4

If what you are trying to do is open the .bashrc file for editing, you need to open it with any text editor, such as nano, vi, or gedit. If you are trying to update after altering it in any way, you could use source .bashrc command. For instance , look at my screenshot bellow, where i altered my .bashrc file


-3

What you actually did is about execute a file ~/.bashrc which doesn't have the privilege. You can add the action permission to the file: chmod +x ~/.bashrc and see what you get. When you call a file directly on terminal, it presumes it contains shell commands. What you really wanna do is nano ~/.bashrc to enable the edit.


0

~/.bashrc isn't supposed to be executed. You're supposed to run something like gedit ~/.bashrc You're getting that error because the execute bit isn't set, but it shouldn't be.


0

Append the line . ~/.bash_profile to your ~/.bashrc file. It will "Source bash_profile to set JAVA_HOME and add it to the PATH because for some reason is not being picked up". See also this question: Why ~/.bash_profile is not getting sourced when opening a terminal?



Top 50 recent answers are included