New answers tagged

1

You can add the user flag to the mount options stored in /etc/fstab from gnome-disks. Just click on edit mount options.


0

All your options to mount partitions are covered in this page. Ensure you use the UUID for your drive, as directed in the linked page. Edit: As noted by another member, do not mount your Windows partition that has your OS on it as RW, make sure it's Read-Only! Other partitions that are only used as storage can be Read/Write. I had originally assumed you ...


1

Ok so after lots of reading: Since Ubuntu 15.04, fstab entries are converted into systemd units (*.mount files found under /run/systemd/generator) by systemd-fstab-generator and are then mounted in no particular order, which is why mine was failing. However systemd supports dependencies, and these can be specified using the fstab option ...


0

i mount my hdd's in: /etc/fstab my root filesystem UUID=84a8ae47-0504-4b4a-9911-2612c4186ac7 / ext4 errors=remount-ro 0 1 my ext4 hdd UUID=623643e8-f7ef-4edc-9c83-7b13c89b002d /media/Shared ext4 defaults 0 0 my ntfs hdd UUID=2EB81EA6B81E6D19 /media/Storage ntfs-3g defaults,windows_names,locale=en_US.utf8 0 0 ...


0

I can get Ubuntu to automount my ZFS pool by opening up the /etc/rc.local file and adding the following line to it: zfs mount -vO -a Now my ZFS pool is automounted on reboot.


0

"One option is to postpone mounting until after /etc/fstab has completed, this gives you full control over the mount order." How can I specify the order in which filesystems are automatically mounted?


0

Auto-mounting from terminal with sudo mount -t ntfs-3g /dev/sdb1 /media/Elements mounts as root. Since ntfs does not have explicit permission management on a file-system basis, there's no point in using chown, chmod or chgrp. To mount it so it is user accessible from terminal, you need to use the user mount option, like this: sudo mount -t ntfs-3g -o user ...


0

Ok, I got it. All of the above did not work but I noticed that /media/username was also out of bounds, which was really weird as as was logged in as username. I guess it all has to do with changing the UID a while back. Anyhow, deleting /media/username let it be recreated automatically upon the next plug-in with the right permissions.


0

Try this: Unplugg the usb Open a terminal:Press Ctrl+Alt+T Run it: exec sudo -i mkdir /media/Elements chown -R -v sarah:sarah /media/Elements chmod -Rf 777 /media/Elements


0

Not sure if it will work because I can't test it myself but here is what I would try. First make sure that the USB is not plugged in and mounted. Check /media/Elements and see if it exists. If it does I would delete it then insert the USB again and see whats in the /media/ folder. If Elements isn't in there and some other folder is .. then the Label on ...


2

you need to add user option to your fstab (/etc/fstab) like this /dev/sdc1 /media/sdc1 vfat uid=1000,noauto,user 0 0 /dev/sdd1 /media/sdd1 vfat uid=1000,noauto,user 0 0 /dev/sdb1 /media/sdb1 vfat uid=1000,noauto,user 0 0 Normally, only the superuser can mount filesystems. However, when fstab ...


1

Here is a way you can have a share mount at boot. First open a terminal, it should open at your home directory. Type the following: touch .smbcredentials then open ~/.smbcredentials in your favorite editor and add the following lines username=your user name password=you user password Save the file and open terminal again and type: sudo chmod 600 ...


1

Have you recently not unmounted the drive correctly, either power failure or a crash while writing to or reading from the drive? This can cause errors with the drive and while once mounted it functions normally the superblock may have errors causing it to not mount correctly. As Requist asked, check dmesg immediately after inserting you flash drive, you may ...



Top 50 recent answers are included