Hot answers tagged

26

16.04 and later (unity 7) In addition to the gsettings menu option introduced in 15.04, this has been added to Settings - Appearance: 15.04, 15.10 & 14.04 15.04 now has the ability to toggle the global menu as well as the local integrated menus (Via System Settings - Appearance - Behaviour tab) to be permanently on or off. If you are running a ...


19

You can't currently autohide the panel in Unity. It is also not a planned feature. There are ways you could possibly make the panel autohide: Post an idea on Ubuntu Brainstorm to add this option and hope a developer sees it and implements it or creates a for with this feature. Report a bug on Launchpad stating that this option should be available and hope ...


18

12.04 [according to this post the 'Menu always visible' option is gone from the unity-revamped ppa] Now it's possible. The Unity Revamped PPA which provides Unity with two patches: Dodge Windows and minimize/unmaximize on click for the Unity launcher, has been updated yesterday with some fixes which aren't yet available for the Unity package from the ...


12

Auto-Hide of Side bar in Ubuntu desktop can be easily done as following: Go to System Settings Then go to Appearance Click on Behavior Turn on the Auto Hide Launcher (By default it is off)


10

Avoid holding down the Super button. When locking the screen with Super + L the Super key is normally held down before pressing L. But holding down Super is in itself a shortcut to get the Shortcut Help Screen up. By using this to lock the computer, you make the sidebar reveal itself before it's "interrupted" by the screen locking. This is the reason why ...


8

The is suggested in the following bug. As a user you can vote for it. Menus are hidden by default


7

You can use the "Super" button for this. Most keyboards and notebooks have a button with a "Windows" logo on it. As long as you press the button, the launcher is visible. An other solution, if you press Alt+F1, after that the Launcher appears, press again Alt+F1, the Launcher disappears.


7

The Unity panel cannot be hidden because the code doesn't currently allow it. Why it doesn't allow it is because nobody has added the code to allow it. Is it written in stone that it has to be that way? I don't know. I doubt it. If you can come up with good solutions to the problems that arise when the panel is hidden, I'm very confident they will be ...


5

First of all, install the Compizconfig settings manager from Ubuntu Software Center or just run following command: sudo apt-get install compizconfig-settings-manager Start it under System -> Preferences menu, find “Ubuntu Unity Plugin” and click into its configuration page. Then change AutoHide Launcher to: Never How can I configure Unity?


4

There's a workaround for this problem posted by Doug McMahon here: https://bugs.launchpad.net/unity/+bug/1057000/comments/37 From the comment: To be a bit more verbose - for those looking for a tmp workaround till fixed - if no current /etc/X11/xorg.conf then create one with this in it Section "Device" Identifier "NVIDIA GeForce" Driver "nvidia" ...


4

Try changing the Launcher Reveal Pressure. The default is 20. You might consider setting it at 1 and systematically try other settings to pick the ideal one. You can get to this configuration through CCSM (the CompizConfig Settings Manager). Click on Desktop -> Ubuntu Unity Plugin -> Launcher and change the Launcher Reveal Pressure. You may have to ...


3

I had the same problem. In my case it was related to the compability nvidia-current-updates (wich I installed before the upgrade to 12.10) with compiz. I fixed it by installing the version 310.19 of the nvidia driver avaiable through this ppa (this is not the official supported version on ubuntu, but works pretty well): sudo add-apt-repository ...


3

I'm using virtualbox too and I suffer the same problem, this is a virtualbox bug. The easiest thing you could do is to install gnome-fallback and use it instead of unity, since you're not using the unity dash anymore. Check this link with details on how to switch to the default gnome desktop, if it's not installed by default, you can open a terminal and ...


3

Add the following lines at the beginning of your script: AUTOHIDE=$(dconf read /org/compiz/profiles/unity/plugins/unityshell/launcher-hide-mode) dconf write /org/compiz/profiles/unity/plugins/unityshell/launcher-hide-mode 1 The first line saves whether or not we currently autohide to the variable AUTOHIDE. The second line simply turns on autohiding. ...


2

If you have logged out and back in and it hasn't resolved itself, likely some of your settings have become corrupt. The easiest way to fix this is with UbuntuTweak sudo add-apt-repository ppa:tualatrix/ppa sudo apt-get update sudo apt-get install ubuntu-tweak You can read more about it at webup8.org The programs first page looks like this: Click on ...


2

I think i figured out what was going on. One of the settings in ConfigCompiz was Duration of Sticky Edge Release After Break, which didn't sound relevant at first, so I hadn't tweaked it. It was originally set to 1000, I set it to 0, which I think solved the problem.


2

A bit of Googling returns this: Add this to ~/.gtkrc-2.0. style "xfce-panel-window-style" { # Time in miliseconds before the panel will unhide on an enter event XfcePanelWindow::popup-delay = 225 # Time in miliseconds before the panel will hide on a leave event XfcePanelWindow::popdown-delay = 350 } class "XfcePanelWindow" style ...


2

Edit the configuration at /etc/apt/apt.conf.d/50unattended-upgrades to comment out the line: Unattended-Upgrade::Allowed-Origins { "${distro_id}:${distro_codename}-security"; // "${distro_id}:${distro_codename}-updates"; // "${distro_id}:${distro_codename}-proposed"; // "${distro_id}:${distro_codename}-backports"; }; Remove the ...


2

I solve it by changing the button with CCSM (CompizConfig Settings Manager): If not already done, install compizconfig-settings-manager with the following command: sudo apt-get install compizconfig-settings-manager Open CCSM. Select "Desktop" -> "Ubuntu Unity Plugin" -> "Launcher" Turn the "Hide Launcher" from "Never" to "Autohide".


2

In the world of Linux, any file or directory that's name starts with a . is considered hidden. Note that hiding a file or directory is not a measure of security, it's just for convenience, so that unnecessary files such as configuration files don't bother your daily routine. They can be listed easily if you wanted, e.g. ls -lA. As for hiding partitions, ...


1

found the extension to do this: Panel Settings


1

even though i am a newer, but i have some ideas that they can solove your problem, click the right key of the Mouse(or touch board) , then click the option "change the Background of the desktop", choose the option card " Behavior" , there is the settings of the "hide or display the LAUNCHER",, IF you have try this, and it doesn't work eiher, it may the ...


1

Using GNOME Fallback is one way to work around this problem, but there are other workarounds that also merit consideration. It is worth noting that if anyone wants to use a GNOME2 style desktop instead of the default Ubuntu desktop, then you should know that the MATE desktop is available. It IS (a fork of) Gnome 2, it is just not called Gnome 2 anymore to ...


1

It's related to the new Nvidia 304.51 drivers, it's a known bug with no fix at the moment, the only way to get the panel behaviour back is to revert to the previous driver release version.


1

Short answer: no, no support for that. You may try MyUnity, it has a few tweaks for launcher, but not what you want. And I guess even with serious hacking this may not be possible.


1

I got the same problem too. And then I did this: press Super+S to open desktop switching view, choose one of the empty desktop (not the current). Then your launcher would hide right away. Go back to your previous desktop, the same way by pressing Super+S. It worked to me.


1

Here's a workaround: select a track in the library pane in Clementine, then drag it towards the left side of the screen, 'pushing' the launcher away. The launcher should disappear, and might behave ok for a little while longer. The problem sometimes is that after this trick, it is difficult to get the launcher to appear long enough when you really want it. ...


1

Sometimes this happens to me, to solve press and hold the super key(Windows Key) for 5 seconds and autohide back to normal.


1

A similar question was answered to scribes developers PPA in Launchpad. They have said, It is not possible. There's no option to disable the top panel. Reference



Only top voted, non community-wiki answers of a minimum length are eligible