Tag Info

New answers tagged

2

/usr/bin/gcc is just a symbolic link, eg: $ ls -la /usr/bin/gcc lrwxrwxrwx 1 root root 7 Mär 12 17:28 /usr/bin/gcc -> gcc-4.9 Why the link on your system does not exist (anymore), we can only speculate about it. You have two options: Create the symbolic link sudo ln -s /usr/bin/gcc-4.8 /usr/bin/gcc or Reinstall the package gcc sudo apt-get ...


1

Try the following commands: sudo apt-get clean sudo apt-get update sudo apt-get -f If that fails you will have to try running sudo dpkg --remove --force-remove-reinstreq package You will have to run that for each package that is giving you an error, for example sudo dpkg --remove --force-remove-reinstreq liblockfile1 sudo dpkg --remove ...


3

The problem is that as you are using no quoting, you need to escape both the shell and the regular expression interpreter both to interpret . as literal. That's the reason why quoting is important. Your first pattern would work if you just use quotes around it : apt-file search --regexp '.*ssl.*\.so.*' The main thing to note that our final goal is to let ...


1

If you don't use a quoted pattern, you have to escape the backslash for the RegEx: apt-file search --regexp .*ssl.*\\.so.* With a quoted pattern, you don't need that: apt-file search --regexp '.*ssl.*\.so.*' Example $ apt-file search --regexp .*ssl.*\\.so.* > ~/tmp/bar $ apt-file search --regexp '.*ssl.*\.so.*' > ~/tmp/foo $ diff foo bar | wc ...


4

You need a double backslash \\ because the single backslash is not only the regex escape character but also the one your shell uses. E.g. you escape the dot, which on shell level just interprets to a regular dot, that is then passed to apt-get and machtes every character (as a regular dot usually does). So the answer is, first the string is interpreted by ...


0

Enter the following commands into the terminal: sudo apt-get update sudo apt-get autoclean sudo apt-get clean sudo apt-get autoremove Then enter: sudo apt-get install tcl8.5 libx11-dev libxss-dev libxext-dev libxft-dev tk8.5.11-1 Now try installing tcl8.5-dev and tk8.5-dev again: sudo apt-get install tcl8.5-dev tk8.5-dev


0

You could delete the soures.list file, and then push setting and then the update icon, and then hatch the upper chranoical, and then reload and it might work fine this way


0

In addition to A.B. answer, another solution: dpkg -L package-name Or in long format: dpkg --list-files package-name man dpkg -L, --listfiles package-name... List files installed to your system from package-name. So in your case run: dpkg -L maven and dpkg -L ant


2

try following in terminal: $ sudo apt-get install steam -f


0

I don't agree with levlaz's answer, when meta packages are removed, related packages are listed in automatically installed and are no longer required list. APT will not force you remove them, only if you run explicitly apt-get autoremove to remove them. AFAIK, It looks like a package version or a package architecture conflict: The following NEW packages ...


0

Okay it is some what tricky to get you the right advice given that you've probably modified files in few places. At least that's how I read your question. step one Trace you steps back and undo everything you did. sources.list has certain syntax to it and I don't think you can append just any URL to it. This looks like a good guide for future reference, ...


0

I don't think this has anything to do with when you isntalled iproute. The only time that massive packages get removed like this from my experience is when you remove packages that are linked to meta packages. For example if you remove Evolution, it likes to remove a whole bunch of gnome stuff since the gnome stuff were dependencies for Evolution and by ...


0

I am not familiar with this distro of Ubuntu... However, you could take a peek at the .bash_history(sp?) for any other people that may have rights to make changes to your server. Another option if you input 'N' at the very last is to try and run apt-get -f install and see if that doesn't help. That command 'should' fix your broken packages problem.


-2

hope this can help you. Just try to go into your home folder, press Ctrl+H (to see hidden folders) and there they should be. Cheers


8

Via dpkg-query: dpkg-query -L maven dpkg-query -L ant or with a filter using grep dpkg-query -L maven | grep '^/usr/bin' sample output $ dpkg-query -L mc /. /usr /usr/share /usr/share/applications /usr/share/applications/mc.desktop /usr/share/doc /usr/share/doc/mc /usr/share/doc/mc/README.Debian /usr/share/doc/mc/NEWS.Debian.gz ...


0

You can try this: cd ~/Downloads/ wget http://www.cmake.org/files/v2.8/cmake-2.8.10.tar.gz tar xzvf cmake-2.8.10.tar.gz cd cmake-2.8.10 ./configure make -j4 sudo make install This works for me on Ubuntu 12.04. I had to close and reopen my terminal to see the version change. cmake --version cmake version 2.8.10


0

Currently I am following this procedure. Log into my Koding cloud space. Fire-up a terminal there and download the package's deb file using apt-get download. Extract the downloaded .deb file using dpkg-deb -R <deb-file> . to get the content of the file. Move the contents to a suitable directory. For example, /home/anwarshah/contents In local pc, ...


0

You could use a hook for apt to run a script after each invocation of apt-get/dpkg. A script that will list all installed package and commit the new list in a git repo For example, in /etc/apt/apt.conf.d/99-dpkg-snapshot DPkg::Post-Invoke {"/usr/bin/dpkg -l > /root/apt.git/dpkg-list.txt; git commit -a -m `date +%Y%m%d%H%H%S` -C /root/apt.git"; }; and ...


1

There's some tools that can do the job using snapshots (not like version control systems): Systemback: Simple system backup and restore application with extra features Systemback makes it easy to create backups of system and users configuration files. In case of problems you can easily restore the previous state of the system. There are extra ...


0

dpkg --get-selections | grep "mysql"(It list all installed mysql in your system) If still mysql installed In Your System remove it first by using following commands. sudo apt-get --purge remove mysql sudo apt-get autoremove mysql sudo apt-get autoclean mysql check for /etc/mysql/my.cnf and /var/lib/mysql files. If these files still exist then ...


1

I hope it's not too late.But I also ran into same problem while installing glfw lib. How I solved it: Navigated into my parent directory using cd ~ Ran sudo apt-get install libxinerama-dev Navigate again to directory of glfw and ran cmake -G "Unix Makefiles" This time the error was xcursor lib not found. so i repeated the above steps and installed xcursor ...


1

I did the update yesterday on 14.04, and 15.04, and it went OK. What I think it does, it removes an older version, and installs a newer one. Both systems have been rebooted, and they both work fine.


1

libdb: The Berkeley Database (Berkeley DB) is a programmatic toolkit that provides embedded database support for both traditional and client/server applications. Berkeley DB is used by many applications, including Python and Perl, so this should be installed on all systems. you can install it: sudo apt-get install libdb5.1 But I assume it must be already ...


1

I think I found the problem, as Kodi is now installing correctly: First I found all the packages that were still hanging around from saucy by running dpkg --list | grep saucy One by one I removed them all using apt-get remove <packagename>. (I suspect these were old packages that were installed via some weird ppa when I installed gnome.) After ...


1

Remove the cached deb file: sudo rm /var/cache/apt/archives/mysql-server-5.5_5.5.43-0ubuntu0.14.04.1_amd64.deb and try it again: sudo apt-get install -f sudo apt-get install mysql-client mysql-server Alternatively, install version 5.6: sudo apt-get remove mysql-server mysql-client sudo apt-get install mysql-server-5.6 mysql-client-5.6


0

I'd start by getting a solid PHP 5.5 system: sudo add-apt-repository ppa:ondrej/php5 sudo add-apt-repository ppa:ondrej/php5-oldstable sudo apt-get update sudo apt-get -f install Remove all the things but pay attention to what's being removed: sudo apt-get -s remove ^php.* dh-php5 libapache2-mod-php5 Remove the PPAs: sudo add-apt-repository --remove ...


0

I changed default DNS server to the Google DNS servers 8.8.8.8 8.8.4.4 Now i can install everything again.


-1

Could it be HDD problems? I have been having the same problems and my file system kept on falling back to a read-only system.


0

Try running this sudo apt-get install -f sudo dpkg --configure -a sudo apt-get clean sudo apt-get update This should clean up any broken packages. Then you should try this again sudo apt-get install kodi kodi-bin Hope this helps


0

The packages that could not be installed are of the ARM architecture. Your CPU is an Intel one, so such packages cannot be installed on it. EDIT Jetpack is only available with NVIDIA Nsight Eclipse Edition when using the AMD architecture. The explanation is simple when looking at the required .deb package: cuda-repo-ubuntu1204_6.0-37_amd64.deb - it's an ...


1

As I take from our conversation in the comments, you have no software sources configured. This can be due to the following reasons: No sources were configured on installation. (is this even possible?) The software sources were removed accidentally or maliciously deliberately. They were lost due to another reason, which would most likely indicate a system ...


1

libmysql-ruby appears to be a transitional package that has been phased out: the new package name seems to be ruby-mysql. If you are running Ubuntu 14.04 or later you will need to use sudo apt-get install ruby-mysql


1

Run: sudo apt-get -f install sudo apt-get update sudo apt-get install r-base This may fix the problem for you, otherwise check here for additional troubleshooting.


0

As @steeldriver notes and you experienced, the dependencies won't help. But with a bit of luck you may find out what apt-get remove did by looking at the logs of apt to be found in /var/log/apt/term.log*, as aptly noted in this post. More answers in the same thread point to further log files, e.g. /var/log/apt/history.log, which may be even easier to ...


0

I believe the command you seek is: sudo apt-get -f install That should attempt to correct for any broken dependencies you have.


2

Your sources.list is stored at /etc/apt/ folder. To see and edit them you can run: cat /etc/apt/sources.list To edit that file run: sudo nano /etc/apt/sources.list or sudo apt edit-sources Your PPAs are stored to: ls /etc/apt/sources.list.d/* Though do mention when editing those files manually make sure you know what you are doing/editing that ...


1

This error is coming because, your apt-get dependency tree has reached an inconstant state, due to the installation of mariadb-client package which is of newer/older version than as as expected by mariadb-server. Try uninstalling mariadb-client by $ sudo apt-get purge mariadb-client-5.5 Then try to correct your dependency tree by $ sudo apt-get -f ...


2

There are ways that you could do this for an OS, but I'm not sure how transferable from distro to distro it would be. You could do it (using apt & dpkg) for Debian based distros and it would probably work fairly consistently. But there are plenty of distros that don't use apt/dpkg and so it almost certainly wouldn't work for those. E.g. Fedora uses yum ...


0

You just edit the jetty startup script /etc/init.d/jetty I assume, and put a clean exit on the 2nd line: #!/bin/sh -e exit 0 then apt-get update && apt-get -f install And that will cleanly remove jetty. it fails because the init script fails.


1

From official Nvidia website: The latest version of NVIDIA Nsight Eclipse Edition with support for CUDA C/C++ and is supported on MAC and Linux platforms. Just install the CUDA Toolkit and run 'nsight' on the command line. Check it with: apt-cache policy nvidia-cuda-toolkit The packages included are listed here one of them as you can see nvidia-nsight: ...


0

Although this is a couple months old, if you did want g++ --version to output 5.1 follow these instructions: How do I use the latest gcc (hint: symlinks)


0

They just mean that the special new tags have not yet been added to the boot scripts. Try removing insserv and try again.


0

Not sure if you mean this: /etc/apt/sources.list


0

TL;DR The following entry must be removed from the file /etc/apt/sources.list: deb http://debian.neo4j.org/repo stable/ Therefore Remove the Neo Technology Debian repository with the command below: sudo sed -i '/deb http\:\/\/debian\.neo4j\.org\/repo/d' /etc/apt/sources.list Update the package database sudo apt-get update Now install gdevelop


1

If you have installed the package from source file you need to manually remove all the files inserted into the system by the package. For future reference i would suggest you to install packages from official repositories. If for some reason you need to install from source always use checkinstall instead of make install. make install simply copies file ...


1

./Makefile.am is the wrong approach. Start the commands below to build the project: cd /home/me/Desktop/mfcuk-master automake autoconf ./configure make Running ./mfcuk -C -R 0:A -v 2 Source


0

Edit, as root, with the editor of your choice, the /etc/apt/sources.list file, and delete (or comment by placing # at the beginning of the line) the offending line (line 10). One way to comment line 10 uses sed (read man sed): sudo sed -i~ -e '10s/^/#/' /etc/apt/sources.list This leaves a backup copy in /etc/apt/sources.list~


0

You could just delete the sources.list file, and then push settings and then enter software update, and hatch the upper option in the first line, and then close and reload and the malfunction is gone.


0

Try this: apt-get download libc-bin dpkg -x libc-bin*.deb libdir/ and then: sudo cp libdir/sbin/ldconfig /sbin/ sudo apt-get install --reinstall libc-bin sudo apt-get install -f Taken from old Ubuntu forum archives.


1

I had the same problem with banshee (dependency on libglib2.0 2.44.1). It looks like banshee came out of the proposed repository sooner than the libglib it is dependent on. I was able to work around this as follows: Enable vivid-proposed Upgrade libglib sudo apt-get install libglib2.0-0/vivid-proposed libglib2.0-bin/vivid-proposed Disable proposed ...



Top 50 recent answers are included