New answers tagged

3

You have not provided the release codename. For example, for Ubuntu 14.04 (trusty): deb http://archive.canonical.com/ubuntu trusty partner Replace trusty with the codename of the release you are using. As you are using 16.04 (xenial): deb http://archive.canonical.com/ubuntu xenial partner You can find out the release codename by: lsb_release -c ...


0

If you are after the X11 version of nethack simply run: sudo apt-get install nethack-x11 And then the glory of this old game will be revealed, as installed on my system: No fiddling with repositories here, it is in the Universe Repositories which should be activated my default on your system...


0

This was taken from the Ubuntu documentation for an explination about sources: Main - Officially supported software. Restricted - Supported software that is not available under a completely free license. Universe - Community maintained software, i.e. not officially supported software. Multiverse - Software that is not free. As for Wily I believe ...


1

Debian and Ubuntu enforce SHA256 or higher entries in the Release and/or Packages files since March. Repositories missing these need to be fixed by their owners. There is an overview of broken repositories in the Debian wiki.


1

It appears that find / -exec dpkg -S {} \; 2>&1 | fgrep "no path" | cut -d' ' -f7- works for this case. Thanks Muru!


0

The same method, different command: $ dpkg -S /etc/profile dpkg-query: no path found matching pattern /etc/profile $ dpkg -S /etc/ssh/ssh_config openssh-client: /etc/ssh/ssh_config


0

You could - like me (shame on me) - have uninstalled gnupg in order to install gnupg2 to have no conflicts -hahaha I guess I got to reinstall everything again...


0

apt-mark shows architecture, if the package has different architecture than the native architecture of the OS.


0

I had a similar problem, and i've downloaded and installed the lsb-core package for Ubuntu 14.04, and it works. Try this: sudo add-apt-repository "deb http://cz.archive.ubuntu.com/ubuntu trusty main" && sudo apt-get update && sudo apt-get install lsb-core -y Then, try to install epson-inkjet-printer-201303w again.


0

I had the same problem with apt-cacher-ng from ubuntu 12.04 when trying to use my mirror with ubuntu 16.04 clients. Canonical pushed an updated package that fix the problem without any additional configuration.


2

No, you're not wrong. Ubuntu is maturing. <yoda>Will you, less sources, see henceforth</yoda> As per the Release notes of Xenial, some packages/repos were dropped. Updated Packages As with every new release, packages--applications and software of all kinds--are being updated at a rapid pace. Many of these packages came from an ...


0

To get Code::Blocks installing you have to get a bit creative, as first download the packages for Ubuntu 15.10 from here (simply do a search for libwxgtk2.8-). For a 64-bit system you can as well use the following links to download the packages. Best do the now stated commands in a separate directory so you not install any other downloads you maybe did ...


1

Had the same problem, solved by forcing the update of apt and cleaning the current installation as Andrew suggested: $ sudo apt-get update $ sudo apt-get upgrade $ sudo apt-get -f install (not "install -f"!) $ sudo apt-get -y install apt $ sudo do-release-upgrade


0

At least in Ubuntu 16.04, libgtk2.0-0 contains libgtk-x11-2.0.so.0, so sudo apt-get install libgtk2.0-0 works.


1

It's just a silly misunderstanding, caused by the hasty recognition of the development team of apt maintainers about SHA1 algorithm as obsolete. The problem is that it is directly embedded in the source code of APT, but if you're willing to spend an extra 1-2 hours on the self-assembly of the package, I can tell you how to solve this nuisance. So: sudo ...


0

Update Sigh.. Jumped the gun too soon. I was reading this and noticed that when I viewed /etc/X11/xorg.conf I had: Section "ServerLayout"Identifier "layout"Screen 0 "nvidia" Inactive "intel"EndSection This is even though my single monitor is connected to the onboard display adapter for my Intel card. So doing: sudo service lightdm stopsudo prime-select ...


0

A potential solution is to remove the directory /var/cache/apt/archives/apt-fast every time you want to run apt-get clean. This also means you are clearing the cache for apt-fast.


0

16.04 is new and all packages are not ready to use in all servers. Using Main Server to download packages solve my problem. System Settings Software & Updates Select "Main Server" from "Download from" section


1

You linked to the source package, but the python-support package definitely does exist in the binary repositories: https://launchpad.net/ubuntu/xenial/+package/python-support I'm not sure why it doesn't show up in the source repos -- maybe because it's just a Python script that can be executed directly, rather than something that requires compilation into ...


0

I changed my download server and it worked like charm. Here is how you can do it 1.Open 'software and updates' and click the 'Ubuntu Software' tab. Click 'Download from' and choose 'Other' Click 'Select Best Server'. Ubuntu will take some time to select the best server for you. Accept it. Now try running the software update again. It should work. If it ...


1

edit /etc/apt/sources.list add deb http://us.archive.ubuntu.com/ubuntu trusty main multiverse Save sudo apt-get update sudo apt-get install libgeotiff-epsg


1

Enable deb-src type repository in /etc/apt/sources.list: deb-src http://archive.ubuntu.com/ubuntu/ trusty main Replace trusty with the codename of the release you are using. You can find the codename by: lsb_release -c Now sync the local package lists with remote repositories: sudo apt-get update Now you can download the source package of apt in the ...


0

The problem was the repository server, i changed it to USA from Turkey server, seems turkey server is outdated.


1

There is no official support in repository for Ubuntu 16.04 You can see it, if you click on the link https://packages.linuxdeepin.com/deepin/dists/ We'll have to install from source: https://github.com/linuxdeepin


0

Turns out there isn't a stable release of MAAS for Xenial which means I need to be on the ppa:maas/next repository instead of ppa:maas/stable. The issue was brought about after stepping through the MAAS getting started guide which wanted asked me to ad the ppa:maas/stable repository. After removing it with sudo add-apt-repository --remove ppa:maas/stable ...


0

Run your installation command with sudo. The error is basically saying are you root. It needs to create a lock file, which is not possible if you aren't root sudo apt-get install [package name]


1

I just got into a similar situation with a botched upgrade and subsequent messing around in recovery mode, where a certain subset of packages (namely apport) were hanging on dpkg --configure -a with that same Started Braille Device Support. message. The hack that got me through this was: If you're currently staring at a hung apt-get command, hit ctrl+c to ...


1

You can use... echo password | sudo -S recover.sh Password being your sudo password. From sudo manpage.. -S, --stdin Write the prompt to the standard error and read the password from the standard input instead of using the terminal device.


1

Do: grep remove /var/log/dpkg.log


2

Why not just run the script as superuser? sudo sh recover.sh


0

Found a solution here. Just needed to install it using dpkg -i location/of/package.deb


2

I was having an awful problem installing my Epson printer in Ubuntu 16.04 I had messages dependences not met lsb3.2 in the ubuntu software center; the same message for gdebi. I will point out at this time the gnome software center apart from being short of a number of packages I have previously used does not show the missing dependences so I installed the ...


2

Hot tip: You don't need 'apt-get' in 16.04, only 'apt'. Example: sudo apt install aptitude


0

As @Timo mentioned in his comment, python -c "import sys; print sys.path" will give you the Python module load path for your install of Python. On a relatively fresh install of 16.04, there are three directories of note (among the 10 total that were in mine): '' (application's directory) '/usr/local/lib/python2.7/dist-packages' (where pip installs modules) ...


3

You can always use sudo apt-get update sudo apt-get upgrade to update your system, but if you like using aptitude sudo apt-get install aptitude should install aptitude.


0

Seems https://launchpad.net/ubuntu/xenial/+source/aptitude is available. Just open your terminal and type sudo apt-get install aptitude Then try again. Thank you.


2

If you want Python 3 support in vim, install the vim-nox package (sudo apt install vim-nox). However, if you still need Python 2 support, install the vim-nox-py2 package (sudo apt install vim-nox-py2).


1

Try to install r from CRAN. Add deb http://cran.rstudio.com/bin/linux/ubuntu trusty/ to your /etc/apt/sources.list then add the key to archive sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E084DAB9 Then everything should be OK sudo apt-get update sudo apt-get install r-base r-recommended rstudio P.S. Don't forget to update ...


0

You should remove the package first, you can do this via terminal by typing : sudo apt-get remove masalla-icon-theme or by using synaptic, then run this command : sudo apt-get install -f , bytheway, this problem happened when you install external package in your system ,


1

Please note that we intend to shut off SHA1 completely on January 1, 2017. Google Chrome's repositories is half-broken since March 18th 2016. So it is issuing the warning. The problem with the Google source is on Google's end so apt-get is just reporting the issue as a warning. This issue does not stop you from upgrading packages. You can find the list of ...


-1

I write script for fast login in LDAP http://itc-life.ru/skript-vvoda-debian-8-v-ldapdomen/


1

Try installing vim-gnome instead of vim. sudo apt-get install vim-gnome If that can help, you can install the package python-support by downloading the latest version of python-support_X.X.X_all.deb there : https://launchpad.net/ubuntu/+source/python-support Open a terminal in same folder and install with: dpkg -i python-support_X.X.X_all.deb See if it ...


0

This should solve your problem: sudo apt-get update --fix-missing sudo apt-get install npm Hope this works out!


0

/dev/null should have 0666 permissions and that is what /etc/udev/rules.d/device-permissions.rules says: KERNEL=="null|zero|full|random|urandom", MODE="0666" But unfortunately this is a virtual server. So the kernel has not been updated: # uname -a Linux memocamp 2.6.32-042stab063.2 #1 SMP Tue Oct 23 16:24:09 MSK 2012 x86_64 x86_64 x86_64 GNU/Linux A ...


1

you can download deb package from https://launchpad.net/ubuntu/wily/+package/libicu52 works for me.


2

imagemagick may be a dependency for other pieces of software run apt-cache showpkg imagemagick to see what packages depend on imagemagick to run However if you want to force a removal, this may cause unintended consequences! run sudo dpkg --purge --force-all imagemagick


2

You can do this in a terminal window sudo apt remove --purge imagemagick But doing it you will remove also other software that you may need, like parts of the printing system. My recomendation? don't remove image magic


2

Go to "Ubuntu Software Center->Edit->Software Source" select from "Download From" and choose "Other..." and click "Select Best Server". It will take some time... And it comes up with best server for you. Then chose that server and type command below again, sudo apt-get update


-1

Go to Language Support then click Install / Remove Languages... then uncheck the languages that you don't want. If you removed all languages, it will default to generic English. Note that en-US packages are considered a separate language, so you have to uncheck English to uninstall its packages.


2

The new package is php7.0-cgi. php5 is being replaced with 7.0. I would strongly installing the newest version. sudo apt-get install php7.0-cgi However I would recommend installing php-cgi meta package that depend on php7.0-cli for Ubuntu 16.04 to ensure you will always get latest PHP version on upgrades: sudo apt-get install php-cgi



Top 50 recent answers are included