Tag Info

Hot answers tagged

9

apt-file is used to do a search of which package provides a file. Consider it the offline and somewhat limited version of http://packages.ubuntu.com. Since you used apt-file update without sudo, it cannot use a system-wide directory (typically /var/cache/apt/apt-file), and instead uses a directory in your home (~/.cache/apt-file). Searches by other users ...


3

Try this workaround if it works for you. Make sure you have not activated unstable repos for different releases or pre-released updates but for 14.04 LTS recommended only check in --> system settings/software & updates. then run: sudo apt-get -f install sudo dpkg-reconfigure libc6 sudo dpkg-reconfigure libc-bin sudo apt-get install --reinstall libc6 ...


2

I believe it depends on the package. Obviously, some dependencies are also dependencies for other packages, so those will stay installed. However, if you run sudo apt-get remove test or sudo apt-get purge test, then it will let you know that there are a bunch of dependencies that can be removed (albeit manually via sudo apt-get autoremove) if there are any ...


2

You can try this bash script: #!/bin/bash all_files=( $(dpkg -L "$1") ) for file in "${all_files[@]}"; do [ -f "$file" ] && du -h "$file" done Pass the name of the package as first argument e.g. bash script.sh nano. dpkg -L package will list all the files installed by package, we have saved the list as an array. It will include the parent ...


2

Try this: sudo apt-get install gcc


2

I managed to get it working after running the following commands: sudo apt-get clean sudo apt-get autoclean sudo apt-get autoremove sudo apt-get install -f


1

Extras is being retired. It'll hang around until 14.04 runs out of support in 2019 but it won't have newer distributions added to it. What you are seeing is the result of upgrading too early (Vivid isn't realeased yet) so the upgrader script you used didn't remove it from your sources, (per this bug). To fix, simply edit the relevant lines out of your ...


1

It look like there is no a package, as sysads.co.uk reports: On newer 64-bit DEB-systems with Multiarch-support (Debian 7) teamviewer_linux_x64.deb cannot be installed because the package ia32-libs is not available anymore on these systems. In this case you can use teamviewer_linux.deb instead.


1

Could not resist expanding a bit, completely based on heemayl's concept, to make a script with two options: Only output the (total) size of an installed package (but without its dependencies, since dependencies are practically always shared, so which package should have it on its "account"?) an example: $ check_size gimp 6644.1K or: ...


1

This I had already done and in fact someone else had posted a similar problem and after having tried exactly the same thing, received no more answers. BUT it finally occurred to me-- given that apt-get sends me over to dpkg, why not trying purging there? sudo dpkg --purge dropbox and voila'! problem solved!!!


1

Open your sources.list: sudo nano /etc/apt/sources.list Check for any lines starting with deb cdrom: Comment them out by prefixing the lines with #, then press Ctrl+O, Ctrl+X to save and exit, finally run sudo apt-get update


1

You probably have some sort of cache corruption error. Error 2 means "File not found" so it is likely that an index is pointing to a file but the file is not there. If you have no problem re-downloading packages from the net (i.e. you don't pay crazy price for your data) you can delete the apt database and cache: sudo rm -rf /var/cache/apt ...


1

Just remove these packages to let you use apt for other packages. Execute this commands in terminal. sudo apt-get remove openssh-server openssh-client --purge && sudo apt-get autoremove && sudo apt-get autoclean && sudo apt-get update Then reinstall openssh server and client . sudo apt-get install openssh-server openssh-client


1

Click on the Unity dash (or other menu system) and open "Software Sources" sometimes also called "Software & Updates". Then what you need to do is go to the "Other Software" tab, and uncheck the option listing a cdrom. Then click apply, and update again and that should fix it



Only top voted, non community-wiki answers of a minimum length are eligible