Tag Info

Hot answers tagged

104

11.04 - 13.10 Yes, the Desktop version of Unity will use the global menu by default. To disable the global menu remove the indicator-appmenu package, then log out and back in. Unity will continue to run without it and your menus will appear inside the application windows as normal. You can also tell the appmenu to ignore specific applications if ...


36

Run an application To start an application (eg., gcalctool) with the menu within the application rather than in the panel, run the following in a terminal: UBUNTU_MENUPROXY= gcalctool To start the application with the menu enabled in the application and the panel, run: APPMENU_DISPLAY_BOTH=1 gcalctool Instead of using the terminal, you can use the Alt ...


35

Solution 1: Make the global menu for gvim work To get global menu for gvim and to get rid of the warning message, add this to ~/.bashrc and restart the terminal: function gvim () { (/usr/bin/gvim -f "$@" &) } Solution 2: Disable global menu for gvim To just get rid of the warning message, you can disable the global menu, at least for gvim: How do ...


31

On the one hand, we are making menu's "bigger" and "easier to hit" by using the edge of the screen, as noted in the first answer. On the other, we will actually deprioritise them, by using the panel primarily to show the application name (or window title) and only showing the menu when you mouse towards the panel, or use accelerator keys related to the menu. ...


24

For reference, here is how to disable the global menu on a per application basis: https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationMenu#Troubleshooting To disable appmenu support on a per application basis, set the UBUNTU_MENUPROXY variable to null, with: env UBUNTU_MENUPROXY= eclipse the env keyword is useful if your trying to launch ...


24

11.04 - 13.10 - How to disable the global menu (appmenu / application menu) For current user only, all applications Add this to ~/.gnomerc and log out of the desktop and in again: STARTUP="env UBUNTU_MENUPROXY= $STARTUP" For current user only, only applications launched from the shell Add this to ~/.bashrc and restart the shell: UBUNTU_MENUPROXY= ...


16

12.04 [according to this post the 'Menu always visible' option is gone from the unity-revamped ppa] Now it's possible. The Unity Revamped PPA which provides Unity with two patches: Dodge Windows and minimize/unmaximize on click for the Unity launcher, has been updated yesterday with some fixes which aren't yet available for the Unity package from the ...


16

Look & Feel: GTK+ and Java Swing Applications do not play well at all together when it comes to look and feel. I am afraid we'd have to wait for Java 8 for a proper fix. For the time being, if you're not using Kubuntu but Ubuntu and Unity, you have to switch to the native look and feel which is Metal. Go to your netbeans directory (ex: ...


15

Yes, if you need a classic menu in Unity you can use "classic menu indicator applet", press Ctrl+Alt+T on your keyboard to open Terminal. When it opens run the commands below: sudo apt-add-repository ppa:diesch/testing sudo apt-get update sudo apt-get install classicmenu-indicator Else you can open application via the Unity dash Links ...


15

Navigate to about:config, search for 'unity', and toggle from true to false. That did it for me just now. (the full preference name is ui.use_unity_menubar)


13

12.04 The global menu cannot be prevented from autohiding using the standard Unity install. Unlike previous versions of Unity where opening an application never showed the global menu, in 12.04, the global menu appears for two seconds after an application has been launched before fading. ... you can also delay the autohiding of the global menu for up-to ...


12

14.04 The Global Menu can be optionally switched in favour of Local Integrated Menus (LIM) - aka - more traditional window based menus. The reason for this additional ability is ostensibly due to the increasing prevalence of high-resolution displays and as such the perceived mouse-travel from application to the global-menu would be relatively large. To ...


12

In general, I'd recommend using the toolkit supported ways to put menus in the global menubar... but, I'm assuming it's too late to convince you at this point :-) Also, I'll note that even thought we're using Dbusmenu and registration in 12.04 the goal is to move to GMenuModel and marking the window with its menus by 14.04, so this information will become ...


11

If you install lo-menubar , then the HUD works with LibreOffice. It's the same mechanism. It hasn't been used by default because it hasn't been stable enough. But whether or not it will be default by the time 12.04 is released, I don't know. Why isn't lo-menubar installed by default in LibreOffice?


11

The announcement lists reasons and design goals. It's named the Application Menu (as global menu was the name of an older project). For testing plans and more technical details see this page.


11

Actually there is a way to support global menus for Eclipse: Use VI to edit the following file: sudo vi /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so. Search for Eclipse (type /Eclipse) and replace the E character with an X (type rX). Save it (type :wq) and run sudo ldconfig.


11

I found some useful instructions which work for me (Ubuntu 10.04). How to Install MATLAB on Ubuntu Linux How do I create shortcuts, aliases, or links to MATLAB? How do I put MATLAB on the dock? The command to copy-paste after having checked your version: /usr/local/MATLAB/R2012b/bin/matlab -desktop


10

From what I've read, there may be cases where it does not work correctly. For now, at least, it is not enabled by default: https://bugs.launchpad.net/lo-menubar/+bug/760879 https://bugs.launchpad.net/ubuntu/+source/lo-menubar/+bug/739184


10

If you want one particular application to not use the global menu you can set a little known (but very useful) environment variable: UBUNTU_MENUPROXY=0 Thus, the following entered in a terminal will start gimp with the global-menu disabled: UBUNTU_MENUPROXY=0 gimp-2.6 You'll note the global menu is disabled for Gimp - it's now with the main Gimp ...


9

This happend to me aswell after upgrading to 12.04. You should install indicator-appmenu which wasn't installed on my system (or was removed by the installer). After this my global menu was working perfectly. (May require a log out and in or restart to connect.) sudo apt-get install indicator-appmenu To immediately apply without re-login restart Unity: ...


9

I just updated to Firefox 22.0 under Ubuntu 12.04 / Unity. The add-on is indeed gone. There is a config setting that appears to disable the (tremendously annoying) global menus. Open firefox. Enter about:config in the address bar (like you're trying to go to that URL as a website). Use the Search field to find the use_unity_menubar setting. ...


9

First, one of the same reasons Mac OS has always used a global menu applies equally here. One of the key principles -- tautologies, really -- in UI design is that "bigger" things are easier to "hit" with a mouse. What is less obvious until one thinks about it, is that things on the edges of the screen have infinite height or width (depending on whether ...


9

The application menu or global menu [as some people like to refer to it] that comes with unity provided by appmenu-gtkand indicator-appmenu doesnot work on gnome-shell. There is an alpha status globalmenu extension for gnome-shell which can be installed via ppa. But it won't look exacly like what is seen in unity the video in the link shows how it works. if ...


9

You can adjust the font settings using gnome-tweak-tool . Do note that installing gnome-tweak-tool also installs gnome-shell. To install gnome-tweak-tool, you can run the following command in a terminal: sudo apt-get install gnome-tweak-tool After installing it, open the tool and go to Fonts. The configurations that you should be changing are 'Hinting' ...


8

I found a great way to do this. All of the answers I was able to find involved launching Adobe Reader in a special way. Unfortunately I needed it to be part of the launcher. If you open up: gksudo gedit /opt/Adobe/Reader9/bin/acroread You'll be in the actual Adobe Reader launcher. Just add the line export UBUNTU_MENUPROXY= to the first blank space you ...


7

For me, this didn't help. I had to also remove the Truecrypt lock file as per these instructions. In terminal enter: rm ~/.TrueCrypt-lock-USERNAME Where you replace USERNAME with your username.


7

This is a known whishlist bug. Point is: the icons aren't suppsed to be there by default (it's about the /desktop/gnome/interface/menus_have_icons GConf key), so it looks like nobody really cared about that case.


7

There is a library called java-gnome (a java gtk wrapper) that allows your apps to behave like all of the native apps. It provides all the glory to them: native widgets, global menu, etc. The library is available on the ubuntu repositories: Library: libjava-gnome-java Examples: libjava-gnome-java-doc The goal of the library is to develop a rich Java + ...


7

Instead use this: sudo apt-get install appmenu-gtk indicator-appmenu indicator-applet-appmenu Add it to your panel by right clicking on the panel, choosing Add to Panel and then select Indicator Applet Appmenu I got this from OMGUbuntu Hope that helps!! :)


7

The is suggested in the following bug. As a user you can vote for it. Menus are hidden by default



Only top voted, non community-wiki answers of a minimum length are eligible