Tag Info

Hot answers tagged

71

You can revert back to the older style of window switcher by enabling the Static Application Switcher plugin in CompizConfig Settings Manager: Warning: What are some of the issues with ccsm and why would I want to avoid it? Steps: CompizConfig Manager is gotten through sudo apt-get install compizconfig-settings-manager (thanks to @donbright) sudo ...


33

13.04 and 13.10 For 13.04 and 13.10, to enable or disable the "Show desktop" option in application switcher you can use unity-tweak-tool 12.10 For 12.10, a new setting has been added to CCSM to enable or disable the "Show desktop" option in application switcher. Run this command in a terminal to install CCSM: sudo apt-get install ...


28

To get the behavior you want you need to do a few things in addition to stopping the pop-up delay: Install CCSM if not installed already. apt-get install compizconfig-settings-manager from the terminal or search for "Advanced Desktop Effects Settings (CCSM)" in the Ubuntu Software Center. Select the System Settings option in the power button menu (top ...


22

You should install CompizConfig Settings Manager. From there you can find the Unity plugin and disable the switcher, by clicking on each of the key bindings and unchecking 'Enabled' Then you can enable one of the other window-switcher plugins under Window Management. Warning: What are some of the issues with ccsm and why should I not use it?


19

It can be done! I've uploaded a Unity build for 12.04 that fixes this (no Show Desktop in the Alt-Tab switcher). To install, open a terminal and: sudo apt-add-repository ppa:izx/askubuntu -y sudo apt-get update sudo apt-get install unity You can enable the "Show Desktop Icon" setting in the Unity Plugin in Compiz (using ccsm) to get the icon on the ...


12

Here is how to solve this: Open CompizConfig Settings Manager Go to the Unity Plugin settings and deactivate (uncheck enbabled) for the Alt+Tab and Alt+Tab+Shift shortcuts (or even all the other "switcher" related shortcuts. Then go to the CompizConfig main menu and to the "Window Management" section and enable one of the "Switchers", for example "Shift ...


10

Alt+~ will allow you to switch between windows of the same app. i don't know how to turn it off permanently, but it will allow you to navigate them. Additional hint: I have a German keyboard and a German Keyboard layout. Nevertheless the Alt+~ works with the same key where the English keyboard has, so for German users it is Alt+^ .


9

You can replace the background image for the launchers with a transparent one. In a terminal, run the following (this is for Ubuntu 12.04, in 11.10 you'd change the path to say 4 instead of 5): Backup the original: sudo cp /usr/share/unity/5/launcher_icon_back_150.png{,.back} Edit the file: gimp /usr/share/unity/5/launcher_icon_back_150.png In GIMP, ...


8

Seems Application Switching is turned of by default. To activate it you need to run the following command ccsm That will bring up CompizConfig Settings Manager. Go to the Window Management section. Check off ✔ Application Switcher. Then the Alt+Tab will work. Require installation of the compiz-plugins-extra package.


7

You can change the behavior of Alt + Tab with an option in compizconfig-settings-manager that lets you group the applications together from the active viewport. To install CCSM, run the following command in a terminal: sudo apt-get install compizconfig-settings-manager To enable the setting click on Ubuntu Unity plugin and select Switcher tab and tick ...


6

As far as I know...the size of the default "Switcher View (Alt+Tab)" is hardcoded in the Unity source. You can try to edit the source code to change the size according to your needs. NOTE: I recommend you to do this in a Virtual Machine or in a Test Machine to see if you get the desired results.In this example I'm running Ubuntu 13.04 with unity 7.0.0 and ...


6

Well, just to finalize the answer, a reboot has done the trick for me after doing the following: I went to system-settings -> keyboard -> shortcuts and almost all of them were disabled. I assigned "Alt+Tab" to "Switch applications". Then even though the problem specified in one of the comments above persisted, a reboot has solved the problem and I'm able to ...


5

To get all windows expanded from the beginning in a single list while switching with ALT-TAB I've gone to CompizConfig -> Windows Management -> Static Application Switcher (enabled this): Dialog popped up, I selected to solve the conflicts, in any of the question pop ups I've hit the most rightest button to deactivate the conflicting button. Thats all. (To ...


4

I'm also using Gnome Classic (with effects or without them). I have reported the bug about Alt+Tab, but Sebastien Bacher said that it is not a bug. I found that it's duplicate of 971051. Let's make these bugs heater! As temporary solution we can install CompizConfig Settings Manager and select 'Application Switcher' or 'Static Application Switcher' from ...


4

It sounds like you might be waiting for the application switcher to appear on screen before pressing Tab again. You don't have to do this; pressing Alt+Tab, Tab before the application switcher appears will still bring the third window into focus. If you'd like to reduce the 0.2-second delay before the application switcher is displayed, see How do I adjust ...


4

The normal behavior doesn't require extra key presses to be able to to switch between the instances. When you get to an application that has multiple instances just keep a while the Alt key pressed (maximum 2 seconds) and you will see that after you can switch between instances also using the same shortcut: Alt+Tab. Just don't take your finger from the Alt ...


3

Open System Settings/Keyboard, there select the Shortcuts Tab. Now select Navigation and scroll down till you find Switch Applications. There you can select another shortcut just by typing it.


3

The shortcut to spread multiple windows that is Alt+` (that's the same key as the ~, on the top left) You can use it directly with the current program, or use it with Alt+Tab after your chosen program is highlighted. Firefox example:


3

After poking around awful module docs i found a solution. It is hacky, but it works as I wanted it to work. awful.key({ modkey, }, "Tab", function () awful.client.focus.byidx(1) if awful.client.ismarked() then awful.screen.focus_relative(-1) awful.client.getmarked() end if client.focus ...


3

I was scared to use ccsm until I read this blog which makes it look like all that ccsm does is to edit the compiz .xml configuration files A search for compiz reveals: ~/.config/compiz-1 ~/.config/compiz-1/compizconfig ~/.gconf/apps/compizconfig-1 ~/.gconf/apps/compiz-1 ~/.cache/compizconfig-1 I backed up these directories and then made then changed from ...


3

I was like you and so frustrated by all this time I'm loosing to search for the good window in the application switcher ! A little resarch brought to this page : http://askubuntu.com/a/68171/123882 And I can not thank this guy enough !


3

I like the previews as well. First, I made sure CompizConfig was installed. I brought it up and disabled static application switcher, then enabled application switcher (there were some keybinding conflicts with Unity's switching behavior, but I just chose to favor the application switcher keys). This worked for me.


3

I guess I just figured it out! Both Ring and Shift Switcher, in Ubuntu, use Super+Tab by default instead of Alt+Tab so they don't conflict with Untity's Switcher. So far, so good... The problem is... Super alone is used in Unity to show the Launcher! So when you Super+Tab, then release Tab (or let both pressed for a while), Super will trigger the launcher ...


3

Unfortunately this is not configurable, but you can easily get this back manually compiling the unity source (please, file a bug to ask to add an option, btw). As I was saying, you can get this back editing the file BamfLauncherIcon.cpp changing the line: bool only_top_win = !any_urgent; to bool only_top_win = true; I know this is not the best solution, ...


2

As evident from the screenshot, the icons for Google Chrome, Terminal and Emacs are fine. This means that the resolution of icons used in other applications is low. Hence when they are scaled to a bigger size, the quality degrades. There is no problem in Compiz or any other package. You can either manually replace the icons with higher ...


2

This can be done in CompizConfig Settings Manager using "Application Switcher". Install CCSM: Hit Alt+Ctrl+T to open terminal and run following command: sudo apt-get install compizconfig-settings-manager Or search for compizconfig-settings-manage in Software Center and install from there. How to have a Windows like Task Switcher? Once installed, Hit ...


2

I have noticed that this kind of icon blur happens when an application opens a dialogue or any window for something. You can try making 192x192 and 256x256 versions in Gimp by clicking Image>Scale, it might help. This might sound a little odd, but try deleting every icon size for that app except for the scalable one. I have made an entire icon set with ...


2

In the "Window Management" section of CompizConfig Settings Manager(CCSM) there are a few window switcher options that have the "All windows" feature. Application Switcher is a basic 2d switcher while Ring Switcher and Shift Switcher offer more eye candy. Whichever one you pick, remember to set hot keys for the bindings marked "All windows".


2

Yes, if you press the down arrow when you have selected the terminal in the alt+tab view, then you get previews for all terminals and can choose one. Then only that terminal is raised. The intention is to raise only the last used window when you use alt+tab, and raising all of those terminals is a confirmed bug: ...


2

You can change your Keyboard Settings from System >> Keyboard >> Shortcuts. Under Navigation, you should see "Switch Application". You can click it and set the new short cut as you want. Hope it helps.



Only top voted, non community-wiki answers of a minimum length are eligible