Tag Info

New answers tagged

2

First, putting the subprofiles into complain mode. You can manually do this by adding flags=(complain) to the profile. eg. /usr/lib/firefox/firefox{,*[^s][^h]}//browser_java flags=(complain) { ... } Once that is done reload the profile. Now for at first pass at the rules you will need to add to /usr/lib/firefox/firefox{,*[^s][^h]}//browser_openjdk to ...


1

You can try adding the following rules to your ..../browser_openjdk child profile: owner /run/user/*/icedteaplugin-*/* r, /usr/bin/logger Pix, @{PROC}/@{pid}/cmdline r, owner /run/user/*/dconf/user rw, @{PROC}/sys/net/ipv4/ip_local_port_range r, owner @{HOME}/.mozilla/firefox/profiles.ini r, unix (send, receive, connect), I'd be a little concerned about ...


0

Assuming you'll be including the base abstraction in each profile, edit that: Add /etc/* r, to /etc/apparmor.d/abstractions/base and make sure #include <abstractions/base> is in every profile. However, /etc/* r, (or whatever you're linking to) will be one line anyway. Either way you have to add a line. I have no idea why you would want to do this, ...


0

Because it's optional and not on by default as it may be too restrictive for the average user. Until more usage cases are known the profile cannot be "perfected". No mystery.


1

The problem arises from the opening brackets ( { and } ). The #include statement is already inside the main profile's declaration, so the brackets are not required. # Site-specific additions and overrides for usr.bin.firefox. # For more details, please see /etc/apparmor.d/local/README. # Allow gnome keyring integration to work dbus (send,receive) ...


1

In my case the problem was the /etc/mysql/my.cnf file permission. I changed it for cenvenience but it caused erros like kernel: [604528.290448] type=1400 audit(1424350956.727:193): apparmor="STATUS" operation="profile_replace" profile="unconfined" name="/usr/sbin/mysqld" pid=15008 comm="apparmor_parser" The my.cnf permission was 766 and I changed it to ...


1

You can disable thumbnails for dvi files. Open a terminal and type the following commands: Clean the thumbnails cache folder: rm -rf ~/.cache/thumbnails blacklist the dvi files: dconf write /org/gnome/desktop/thumbnailers/disable "['application/x-dvi']" Finally restart Nautilus: nautilus -q


0

This is the first hit on "initializing DST: openssl failure", which was the error I got when my DNS broke as a result of upgrading ubuntu from lucid to precise, so I'd like to mention the solution here. In my case, it was due to bind depending on an ssl library that was not in its chroot jail. The solution was: mkdir -p ...



Top 50 recent answers are included