Tag Info

New answers tagged

0

After little more effort I'm able to work with my htdocs folder. First i set my owner of my htdocs from root to My User after that i set permission of my htdocs 755 (drwx-rx--rx-) for my all directories in htdocs User this code to do that find htdocs -type d -exec chmod 755 {} \; and for files i set 644 (rw-r-r) User this code to do that find htdocs ...


0

I'm able to forward the ports by running VirtualBox as root. This restriction is just an OS thing, not really anything with VirtualBox itself. Just open VirtualBox with sudo: sudo /path/to/VirtualBox Then the OS will allow you to use ports below 1024, which, of course you should do responsibly :)


1

You need to add this line, where yourDomainName.ca-bundle should be prefferably a .crt file you obtained from Comodo: SSLCertificateChainFile /etc/ssl/ssl.crt/yourDomainName.ca-bundle into the /etc/apache2/sites-available/default-ssl.conf Source: ...


-1

This error occurs when you don't specify CA certificate for the server certificate signed by CA. So specify 'SSLCertificateChainFile' also. Digital Ocean how to is for self signed certificates. cat COMODORSADomainValidationSecureServerCA.crt COMODORSAAddTrustCA.crt AddTrustExternalCARoot.crt >> mydomain_com.ca-bundle.crt Add this line to apache vhost ...


0

In general to change file and/or directories permissions you need to use chmod command (you already knew that). There is two way to use chmod more information in official ubuntu docs page. In the nutshell either use letters e.g r read (readable) w write (writeable) x execute (executable) OR use numbers 4 == r 2 == w 1 == x Here are some example ...


1

It is perfectly safe to change ownership of files in /var/www, and indeed anything in that folder is yours to edit and change how you wish. For example, if user tsmith needs to be able to write to files in /var/www/myweb then it's perfectly fine to set the owner of these files to tsmith. Or if you prefer, keep the owner as root and require tsmith to sudo ...


0

So you can try to create a group like its said in the links given by you, then add in this group all the users that can modify the files which belong to wp-user. finally all the files creates by wp-user need to let the write permission to this group. Or create a directory where only users who are authorised to modify the files of wp-user can acces to this ...


0

If you only need to serve content (html, images, etc), there is no need to set a special ownership to the directories/files in /var/www, as long as the apache2 user (www-data) has permission to access the content. In case you need to do some more, you may need to modify the ownerships. For instance, if you need to upload files from a CMS (like WordPress, ...


0

It's not very secure to use any directories or files with root permissions (either ownership or single permissions). For static HTML files it would not be a big security problem but as soon as there are running scripts (PHP, JavaScript, any forms and so on) you can get serious problems.


0

Not just duplicate mentions of Listen 80 but also mention of this in addition to Listen 80 Include ports.conf


0

I'd start by getting a solid PHP 5.5 system: sudo add-apt-repository ppa:ondrej/php5 sudo add-apt-repository ppa:ondrej/php5-oldstable sudo apt-get update sudo apt-get -f install Remove all the things but pay attention to what's being removed: sudo apt-get -s remove ^php.* dh-php5 libapache2-mod-php5 Remove the PPAs: sudo add-apt-repository --remove ...


2

Even after you remove apache2 completely, you will still have its "default site" files sitting in /var/www/. By default, Nginx will attempt to serve these or its own version of these files for sites it cannot otherwise match. You can see this all in /etc/nginx/sites-available/default. What you're seeing is by design, it was just unexpected. To fix it, you ...


0

run the command: sudo dpkg-reconfigure phpmyadmin u need to reconfigure it because lampp and xampp run phpmyadmin in different ports. So, its probably a ports conflicts. You can also open server.xml in your lampp and change the port no. which would be different from that of xampp. Then both mySQL(of xampp and lampp as well) will run.


0

Just run the command: sudo dpkg-reconfigure phpmyadmin


0

Fixed. Since the panel interface I was using was Virtualmin, I merely ran install.sh which reinstalls Virtualmin. Apparently it was enough to resolve this problem, although they dont recommend doing it over a previous install, all seems to be ok thus far.


0

I am serving files from a non-standard directory so to make the upgrade work I had to edit /etc/apache2/apache2.conf and add: Options Indexes FollowSymLinks AllowOverride None Require all granted After this, and the recommended changes above, the 403 error went away.


0

2 options: Check on the musicserver with ifconfig that its ip address is indeed 192.168.0.191 and remove the 127.* entries of the music server from the hosts file. This will keep dns lookup and traffic local. Make sure your router always assigns this ip-address to the music server. Remove all hosts entries for the music server. DNS lookup will then likely ...


1

As I take from our conversation in the comments, you have no software sources configured. This can be due to the following reasons: No sources were configured on installation. (is this even possible?) The software sources were removed accidentally or maliciously deliberately. They were lost due to another reason, which would most likely indicate a system ...


0

I had a similar problem to this. I needed two PCs, one on Ubuntu and another on Arch, to sync files through Unison but ran into the same permission denied error. Just for the sake of those who are having the same problem as I was, here's what I did: First: Installed the same version of Unison on both PCs. This was a bit challenging as the one available on ...


0

You should run sudo apt-get remove php5, then for 5.5 specifically, which was not used in 15.04, you will need to add a source from utopic by opening /etc/apt/sources.list in your favorite text editor and adding the following lines deb http://us.archive.ubuntu.com/ubuntu utopic main and deb-src http://us.archive.ubuntu.com/ubuntu utopic main. Next, to ...


1

With help from http://stackoverflow.com/questions/2530372/how-do-i-disable-directory-browsing The following can be done to have only the ownCloud service available to WAN. They may be redundant, but combined they can only make for a safer system. 1) Assuming it is not needed, Apache's default home page can be moved to a storage place (and out of the ...


0

To create a second virtual host for your wordpress installation save the following as e.g. /etc/apache2/sites-available/wordpress.conf: <VirtualHost *:80> ServerName wordpress DocumentRoot /var/www/wordpress ErrorLog ${APACHE_LOG_DIR}/wordpress-error.log CustomLog ${APACHE_LOG_DIR}/wordpress-access.log combined <Directory ...


1

Unfortunately, there isn't enough information here to fully diagnose the connection issues. Your MySQL error log says that MySQL crashed but nothing about why. You can continue investigating if you'd like, but there's a solution you can apply in the meantime. Every five minutes, automatically restart MySQL if it's not accepting connections Note: this will ...


1

You do not have to use gedit. Since you are on a server system, likely with only a terminal console available, you will need to either use X11 forwarding with ssh, or a terminal based editor. To edit the file under sudo, just use sudo nano rather than gksudo. If you wish to forward your display, you can use ssh -X and then gksudo and gedit will work, but be ...


0

You need to modify this lines in /etc/apache2/apache2.conf Original /etc/apache2/apache2.conf : # Include generic snippets of statements IncludeOptional conf-enabled/*.conf # Include the virtual host configurations: IncludeOptional sites-enabled/*.conf New /etc/apache2/apache2.conf : # Include generic snippets of statements IncludeOptional ...


1

You cannot enter DNS names in "VirtualHost". Try the following: <VirtualHost *:80> ServerName somesite.com ServerAdmin webmaster@localhost DocumentRoot /var/www/somesite.com/httpdocs/ ErrorLog ${APACHE_LOG_DIR}/error.log CustomLog ${APACHE_LOG_DIR}/access.log combined </VirtualHost> ...


1

@Erik Stagg, I know it is late but indeed to use unoconv with other user you can leave an open a port with sudo in another process: $ sudo unoconv --listener Meanwhile this process is running, you can use unoconv with a normal user: $ unoconv -f docx file.doc


0

It is possible that the wsgi module is not installed on your machine. Then obviously activating it will fail. Do sudo aptitude install libapache2-mod-wsgi to install it. The installer will also enable the module for you. You then have to restart apache with sudo service apache2 restart and it should work.


0

You've got a couple options. Here's my take, and you'll need a total of 4 servers: Start by moving your database off of the server now, and onto a server dedicated to the DB ('DB Server', #1 in this suggestion). Migrate it to its own MySQL instance on a separate server, and configure that server's firewall (and MySQL) to listen for connections ONLY from ...


0

Try NGINX as a load-balancer for two web servers: http://nginx.org/en/docs/http/load_balancing.html Use rsync over ssh to keep your doc roots in sync. Clustering MySQL will be trickier.


1

Resolved the issue by using this as my .htaccess file RewriteEngine On RewriteBase /~admini/me/ RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^ index.php [QSA,L]


0

You could be running two different instances of Apache. One serving files from var/www/html and the XAMPP/LAMPP instance serving from opt/lampp/htdocs/ (That's the default LAMPP directory) If you have that directory you could copy your project to it. Then start apache inside of LAMPP and see if it works as expected. Note: For LLAMP your site might be ...


0

you do not have to run the apache2 service manually. LAMP is all you need as we all know LAMP = Linux, Apache, Mysql and Php


0

Answered the same question on StackOverflow and got an answer there: http://stackoverflow.com/questions/30935328/php-wordpress-blog-and-tomcat-on-same-server-is-it-possible/30938420#30938420


0

It seems it may be a problem with AppArmor; I would recommend removing it then restarting your computer / server and trying again. You can remove it via typing sudo /etc/init.d/apparmor kill sudo update-rc.d -f apparmor remove Hope this helps!


0

I've never dealt with Omeka, so I can't help with that. How to set up VirtualBox so that the LAMP server on Ubuntu's address will be 127.0.0.1 on Windows Paraphrasing the VirtualBox manual's section on port forwarding: If you want the LAMP server to work only on your actual machine: Open a Windows command prompt. Run the following, replacing VM name ...


0

Official way Yes, there's official program for apache, called ApacheGUI To install it open terminal by pressing Ctrl+Alt+T, type in terminal: git clone https://github.com/jrossi227/ApacheGUI, after it will be downloaded move full folder in /var/www/html That's all. If you want to know more from official website Click Here.


3

Webmin is still available for Ubuntu even if it's not shipped with the default applications or repositories. Edit the source file: sudo -H gedit /etc/apt/sources.list.d/webmin.list Add this line into the end: deb http://download.webmin.com/download/repository sarge contrib Download and install the key: wget -q http://www.webmin.com/jcameron-key.asc ...


1

I would use the proper command to disable a mod in Apache: sudo a2dismod mpm_prefork


0

Edit: After reading what happened before the fast-forward. I think I would reinstall the whole OS. Too much different permissions in the whole /var structure. (And why would anybody advice a "chmod -R 777 /var"?)


0

The problem is not with your firewall but with your apache configuration. As, muru explained correctly, you can see by this line: tcp6 0 0 :::80 :::* LISTEN 19199/apache2 that apache is listening on both ipv4 and ipv6. Since you mentioned it is working from localhost I would suggest checking your ...


0

There is something else running that uses port 80. It could be another web server like nginx or another running instance of apache... might even be skype. You can see what's using port 80 with this command: netstat -tulpn | grep :80


1

You can manually edit file /etc/apache2/sites-enabled/000-default.conf (I am supposing you have a strictly default Apache configuration on your server). You then change the line #ServerName www.example.com and put in whatever IP address you use to connect from your clients, probably the server's IP address on eth0: ServerName 192.168.0.100 If ...


0

You've got a number of problems here so I think you may need to spend some more time learning Docker, see: Docker User Guide, but to give you a couple of pointers ... Firstly there's a problem with your -p option. You've only specified the port on the inside, i.e. in the docker container (8080). You haven't specified the port on the outside, i.e. the host. ...


0

So after some face palming the code snipet i was using seg faulted at getenv("SERVER_HOSTNAME") see "Request number %d running on host <i>%s</i>\n", ++count, getenv("SERVER_HOSTNAME")); so I replaced with (also fixed the html) "Request number %d running on host <i>host</i></body></html>\n", ++count); and ...


1

Certainly possible. I actually created a small script which sets up a virtual environment like you describe (although I use it purely as a server, I develop on my local machine). I put it on Github if you're interested: https://github.com/Bartwillemsen/virtual-devbox Basically what you need to do on your Ubuntu guest settings is create a second Network ...


0

<VirtualHost *:80> ServerName example.com Redirect permanent / http://www.example.com/ ServerAdmin webmaster@localhost DocumentRoot /var/www/html/example ErrorLog ${APACHE_LOG_DIR}/error.log CustomLog ${APACHE_LOG_DIR}/access.log combined ScriptAlias /cgi/ /var/www/html/cgi-bin/ <Directory /var/www/html/cgi-bin/> Options ExecCGI ...


0

If you're setting up just a development machine you don't need outside url's to lead into your machine as you should be developing in such a way that the url doesn't matter. I have multiple projects going at the same time and all of them work fine with no internet connection. This is how I setup my platform. localhost does not need to have internet to work. ...


0

ERR_TOO_MANY_REDIRECTS most often results when Apache write a location header to the requested URL itself, resulting in infinite redirects.. For example, if you add the following to link.php, you get the above: <?php header("Location : /link.php"); Another source may be a fradulent mod_rewrite. You need to find the source and fix it.


0

You were close: the directory /var/www/ should be owned by www-data (as a user) and www-data as a group. So the proper command, if things get messed up, is: sudo chown -R www-data:www-data /var/www



Top 50 recent answers are included