Hot answers tagged

12

OK here are all the steps to get this to work. I had problems with all responses I found online, bits and pieces everywhere without any certain order and no single working solution, (running Android Studio, Jmonkey 3D, and Ubuntu 14.04) If adb devices shows android device as ????????? (no permissions) follow these instructions: 1) create file ...


11

If you think, you have latest SDK but the adb tool is older one, Use, # adb version Android Debug Bridge version 1.0.31 # wget -O - https://skia.googlesource.com/skia/+archive/cd048d18e0b81338c1a04b9749a00444597df394/platform_tools/android/bin/linux.tar.gz | tar -zxvf - adb # sudo mv adb /usr/bin/adb # sudo chmod +x /usr/bin/adb # adb version Android ...


6

There is a free application on the Google Play store called Software Data Cable: Once you've installed it, turn on your WiFi connection and launch the app. Tap on the "start service" button. It create a FTP server on the android device that let you connect from any computer by opening the resource: ftp://192.168.1.xxx:8888 where 192.168.1.xxx is the IP ...


6

This is so simple... Go to Android Studio=>Tools=>Create desktop Entry.. it will work


5

There is no need of external PPA anymore since Canonical released Ubuntu make that allow an easiest installation of Android Studio: Installing Ubuntu Make : For Ubuntu 14.04, 14.10 users : sudo add-apt-repository ppa:ubuntu-desktop/ubuntu-make sudo apt-get update sudo apt-get install ubuntu-make For Ubuntu 15.04 and up : Ubuntu make is already in ...


5

The issues gets solved when you provide [--accept-license Accept license without prompting] option umake android --accept-license


4

Whether a device (phone in your case) comes up as a block device (/dev/XdY where X and Y are hardware-dependent) or a character device (/run/user/nnnn/gvfs/mtp:) are a feature of the combined device's hardware and OS. So you'll never be able to have it listed as a block device (unless you write your own kernel module). Having said that: you can always ...


4

Try using sudo $(which fastboot) for instance sudo $(which fastboot) devices also sudo $(which fastboot) oem unlock


4

Found a better solution over here: http://stackoverflow.com/a/28127944/1621927 Here is the comment: Instead of forcing permissions via sudo each time you need to run fastboot, you can permanently fix the issue: use lsusb to identify your device USB VendorID configure udev to set proper permissions when your device is plugged in profit! As a bonus - it ...


4

Finally get it here. http://stackoverflow.com/a/19102096/5070449 1) Install 'adb' and 'fastboot' provided by the following third-party PPA. sudo add-apt-repository ppa:nilarimogard/webupd8 sudo apt-get update sudo apt-get install android-tools-adb android-tools-fastboot 2) Replace the copy of 'adb' and 'fastboot' provided by the official Android SDK with ...


4

here is a clear guide to create a Wi-Fi hotspot detectable by any Android phone on a Ubuntu 14.04 using the Network Manager and a minor hack: Click on Network manager -> Create new Wi-Fi network sudo nano the newly created file /etc/NetworkManager/system-connections/yourWifiNetworkName change the mode line to: mode=ap Thats all! From now on you can ...


4

From dmesg output, it is clear that the phone connected twice. [ 40.632283] 1st connected as USB bus 2 dev 3 [ 40.864690] disconnected [ 41.613079] 2nd connected as USB bus 2 dev 4 The problem is: Both phone connection modes are using same attributes idVendor/idProduct/bcdDevice. libmtp udev rules use only idVendor/idProduct to filter devices in ...


4

There is an Android application named AirDroid . You can download it from the play store. By using it you can view your android's files in ubuntu using a web browser. Here is the link : Airdroid.


3

If you are running 64bit you need to install ia32-libs: sudo apt-get install ia32-libs


3

This happens to me sometimes with certain devices. Here's what I find works: Step 1: Find the Vendor ID You can do this by typing lsusb. My output is something like this: Bus 002 Device 097: ID abc1:1234 Fictional Company, Ltd. In this case, abc1 is the Vendor ID. Step 2: Create an adb_usb.ini file Run the following echo "0x<your device's Vendor ...


3

Set mode from MTP to PTP. I had the same problem.


3

Interesting question I upvoted it ;) I actually have an Android device and this message pops up all the time I connect my device but I don't pay any attention to it. There's a tweak workaround to play with is USB dubugging mode inside Android System Settings navigate to Applications/Development there you'll find USB debugging. When you connect your phone ...


3

There are quite a selection of Android remote controls for a popular music players running on Ubuntu. Rhythmbox Remotebox on Google Play Rhythmote for download from the project's homepage VLC See list of remote application maintained by Videolan XBMC/Kodi Official remote application Kore from Google Play The remote applications vary ...


3

Here is my android-studio.desktop file. Its working after adding bash -i before program path. [Desktop Entry] Version=1.0 Type=Application Name=Android Studio Exec=bash -i "/home/user/android-studio/bin/studio.sh" %f Icon=/home/user/android-studio/bin/studio.png Categories=Development;IDE; Terminal=false StartupNotify=true ...


3

Steps I followed: Opened terminal and enter echo java_home Copied the path displayed in terminal - Ctrl+Shift+C copy in Ubuntu terminal In Android studio - Project Structure - Pasted the copied path Waited for the software to recognize and update the settings This solved the problem of Invalid Jdk settings


3

Improving on Organic Marble's answer, to only install the latest tools (not the whole sdk), use the platform-tool filter as below: tools/android update sdk -t platform-tool --no-ui


3

Solution Do I have to completely reflash my phone? No. Once you have ubuntu on there, you can simply update. Do I run the commands from phone, or computer? Computer, with phone plugged in. What command do I use? Boot up phone up normally, and run this command from your computer: adb reboot recovery Wait until the phone gets into recovery ...


3

You can track the current kernel version by looking at the version of linux-generic: $ apt-cache policy linux-generic linux-generic: Installed: 3.13.0.65.71 Candidate: 3.13.0.65.71 The history of versions can be seen from the changelog for this package: linux-meta (3.13.0.65.71) trusty; urgency=medium * linux ABI 3.13.0-65 -- Brad Figg ...


3

The cause of your issue is the version of the MTP library available in Ubuntu 14.04LTS - v1.1.6 - does not recognise our phone (Vodafone Smart Turbo - model 890N). The workaround I found was to recompile libmtp from the latest upstream sources which also includes all the latest bugfixes which resolves the your observed issues. We do have a question and ...


3

In the console just type these (remember to change to your current location) export ANDROID_HOME=/usr/local/android-sdk-linux/tools export PATH="$PATH:/usr/local/android-sdk-linux/platform-tools" If you want to make it permanent just add those lines in the ~/.bashrc file.


3

Your rom.zip is in Downloads, but you are pushing files from your home directory ( That is evident by looking at your prompt , where you have ~ before $. ) antonio@antonio-N150P-N210P-N220P:~$ adb push rom.zip /sdcard/ Do this: antonio@antonio-N150P-N210P-N220P:~$ adb push ~/Downloads/rom.zip /sdcard/


3

In this link, we read that: You can use the Trademarks, in accordance with Canonical’s brand guidelines, with Canonical’s permission in writing. If you require a Trademark licence, please contact us (as set out below). You will require Canonical’s permission to use: (i) any mark ending with the letters UBUNTU or BUNTU which is sufficiently similar to the ...


2

APT-GET can't see any program to install when it isn't in repositories base. You've forgotten the first and second line ;-) sudo add-apt-repository ppa:paolorotolo/android-studio sudo apt-get update sudo apt-get install android-studio Hope it help


2

Normal Installation - Current (64bit only) Try freshly downloading and freshly install the Android SDK package. This is probably what you originally did on your x64 system. On that install it configured it for your x64. Performing the same steps should configure it for your 32bit Ubuntu installation. Archived SDK (I386) I checked the installation of ...


2

You have Android Studio installed in your Download folder? Interesting... o_O For your learning curve, correct the permissions: sudo chown -R "$USER":"$USER" ~/Downloads sudo chmod -R u+w ~/Downloads After that, delete your installation :P and use this answer to install again.



Only top voted, non community-wiki answers of a minimum length are eligible