Hot answers tagged


Update: In the end, it appeared that the problem was due to using the mainline kernel. Once the Ubuntu kernel was updated to include vga_switcheroo, I tried again and installing OpenAFS via apt-get worked just fine. Running sudo service openafs-client start starts OpenAFS and mounts the AFS directory at /afs, and I use klog username to authenticate via ...


The version of the OpenAFS client in 12.04.4 does not support the kernel in 12.04.4. See bug 1206387. Specifically, OpenAFS 1.6.1 does not support Linux kernel 3.8, and the relevant patches to make it support that kernel have not been cherry-picked to the official package in precise. As a workaround, I believe you can use this OpenAFS PPA.


# means run with root or sudo 1. Create a mountpoint # mkdir /mount/point 2. Mount /proc /sys /dev to chroot # mount -o bind /proc /mount/point/proc # mount -o bind /dev /mount/point/dev # mount -o bind /dev/pts /mount/point/dev/pts # mount -o bind /sys /mount/point/sys 3. Copy resolv.conf to networking # cp /etc/resolv.conf /mount/point/etc/resolv.conf ...


Also, assuming I get OpenAFS installed, I'm not quite sure how to actually mount the remote filesystem to, say, /media/afs or some directory. To specifically answer this part, this can be done by passing the -mountdir option to afsd, or modifying the /etc/openafs/cacheinfo file. To mount AFS on /media/afs instead of just /afs, pass -mountdir /media/afs to ...

Only top voted, non community-wiki answers of a minimum length are eligible