5 of 7 added 655 characters in body; edited title

SOLVED - Realtek RTL8111/8168B PCI Express Gigabit Rev03 - keep losing driver/no link -WIRED

I'm using Mint 10 with 2.6.35-32-generic

The PC has two Wired Ethernet cards. They're both the same. One is built into the motherboard, the other is a PCI-E card. I'm using the built in one, but neither are working anymore. The only change I've recently made to my system until my Ethernet stopped working was to install Mint KDE 12.04 64bit as a dual boot. The strange thing is, that the built in Ethernet card works fine in that every time. That kernel is a 3.2 one.

So all of a sudden, Ifconfig tells me that there's no eth0 showing.

dmesg | grep r816 gives me nothing.

I've checked out just about every launchpad/ask ubuntu/ubuntu forum link I can find and the best results I get are from here:

https://unixblogger.wordpress.com/2011/10/18/the-pain-of-an-realtek-rtl8111rtl8168-ethernet-card/

I've even tried the $(uname -r) option & the blacklist of the r8169 was already there from a couple of years ago, when I had a similar issue on this machine. Build-essentials is installed.

Attached is a copy of my Terminal commands for my latest attempt to get this working. I have no other way to connect to the internet on this machine so I had to copy and paste this into a new text file and transfer it to my laptop via USB.

http://pastebin.com/f8zuKnii

So, everything (to me) looks as if it should be working. But, it's not. As soon as I restart (I've tried the power off completely method many times as well) I lose everything, and am back to square one.

I'm stuck.

Could the two cards be conflicting with each other? I might try removing one while I wait for an answer here.

Why would Kubuntu KDE 12.04 work (the kernel I assume) and not my old trusted Mint 10 anymore? Is one possible solution to upgrade the Kernel? Or, is that a really bad thing to do? Can I reverse that if needed?

Thanks in advance from a desperate (I need to get this PC going) Linux Convert.

[EDIT] I found this post and this command actually gets my Eth0 working.

"Then I tried

sudo service network-manager stop

followed by

sudo dhclient3 eth0 

"

http://askubuntu.com/a/76318/79953

But, with a restart, I lose everything again. Arrrgh.

[EDIT2] I note that even with "sudo dhclient3 eth0" my Gnome Panel Network Manager still shows no Ehernet connection, and a left-click displays "Network Manager is not running".

[EDIT3] So, that led me to this site:

bugs.launchpad.net +bug/524454 (can't post the link)

and the solution described in there gets the Network Manager Applet working correctly.

service network-manager stop
rm /var/lib/NetworkManager/NetworkManager.state
service network-manager start

I also added to NetworkManager.state [main]:

NetworkingEnabled=true

This means that as soon as I reinstall the driver, the ethernet is back up and running, but I still lose the driver on restart. So now, I'm guessing that all I need now is for my Ethernet driver to not disappear upon restart.

[EDIT4] Hooray!!! I can't believe I actually found a solution. This is what I did to get the driver settings to stick:

sudo -s
nano /etc/initramfs-tools/modules --- added r8168 (saved)
update-initramfs -v -u -k `uname -r`

...and that was it. I've restarted several times now and even with a full power-off.

I got that information from Ubuntuforums.org post 100 in thread 1022411.

Yeah! I'm the Man! Thanks so much to everyone that has left posts and advice on how to fix this problem on ANY forum/website.

Now, if only I could get the second Ethernet card (PCI-E Eth1) to be recognised....