Questions about X.Org Server (commonly known as Xorg Server, XServer or Xorg), the software that runs the X window system used by most desktop window managers (GNOME, KDE, etc)

learn more… | top users | synonyms (2)

0
votes
1answer
97 views

No input while using Xorg in (L)Ubuntu 14.04

I can't get any input device to work while Xorg is running on Ubuntu 14.04 (also tried 12.04). The system is running on ARM (armhf) device. The USB keyboard and USB mouse works perfectly fine in text ...
0
votes
0answers
126 views

lightdm multiple virtual terminals single seat

LightDM configuration semantics for multiple seats seem to have changed in Ubuntu 14.10. More, it seems there has always been ambiguity regarding whether multiple seats necessarily means separate ...
0
votes
0answers
49 views

Resolution problem and xrandr doesn'r solve

I've got a problem on my macbook air, intel hd4000, 1440x900, linux ubuntu 14.04, lightdm, kde. I was playing (in a stupid way) with resolutions, and i setted a resolution which doesn't work with x ...
0
votes
1answer
137 views

nvidia and intel low-graphics mode error

I have ubuntu 14.04.1 64bit installed with intel and nvidia video cards . I'm using xorg-edgers ppa to graphics drivers . Today i got an update for the drivers (i think it was the mesa drivers) . when ...
1
vote
0answers
52 views

UI is not appearing, xserver-xorg-video-intel not installed properlly?

I am new to Ubuntu , yesterday I have install OS , after that I have install some pakages like JAVA, VLC etc . Now I am not getting the UI. but yesterday(after installing OS) I worked with the help of ...
0
votes
0answers
97 views

NVidia Kubuntu 14.04 xorg.conf overwriten reset after reboot

Running Kubuntu 14.04 64bits. Followed tips on the launchpad: https://bugs.launchpad.net/ubuntu/+source/ubuntu-drivers-common/+bug/1310489 But xorg.conf keeps getting reset. It also seams that if ...
0
votes
1answer
101 views

Fresh install: Everything is fine. After installing updates - screen resolution is wrong. NVIDIA GeForce 8600M GT

I have a problem with my graphics card. It's an NVIDIA GeForce 8600M GT, a bit old one. After a fresh install of any Ubuntu release (it was 13.04 back then) everything works like a charm. After ...
0
votes
2answers
149 views

How to restart remote X server on ubuntu 12.04 over vnc (vino)?

I'm using Ubuntu machine remotely over vnc (vino). Sometimes x server stop responding anymore (screen is not updating), so only manual restart ("sudo service lightdm restart" over tty when I do have a ...
1
vote
0answers
97 views

How to get two finger tap correctly working on 14.04 with Dell 7537?

I recently installed Ubuntu 14.04 in my Dell Inspiron 7537. The two finger tap in the touchpad that simulates the right click is not very responsive. Sometimes it works at the first time, and ...
1
vote
0answers
123 views

How to debug why Nvidia-331 is not working?

Since today, my nvidia-331 installation is broken again. The version history available from packages.ubuntu.com claims the driver itself hasn't changed: ...
1
vote
0answers
24 views

Why are there mystery phantom keystrokes entered in Konversation's input box in GNOME 3.12 after heavy load and how do I fix it w/o restarting IRC?

This is getting ridiculous. In 14.10, with GNOME 3.12 and Konversation 1.5-master #4303, I sometimes wind up in a situation where the system locks up for whatever reason (heavy load from other ...
0
votes
1answer
165 views

Strange screen freezing/hangs

I have a laptop with hybrid intel/nvidia graphics (core i5 and gt650m). At random moments the screen, and just the visual part, will freeze/hang. Using Ctrl+Alt+F1 & Ctrl+Alt+F7 to switch the ...
0
votes
1answer
33 views

How do I solve dependencies with replacements?

I work on a solution getting a closed-source driver, called EMGD, working on Ubuntu. But there is a problem with the lubuntu-desktop package. It depends on lubuntu-core -> xorg and xorg needs ...
0
votes
1answer
38 views

X11 doesn't show windows edges, task bar nor anything

I've got a problem with X11 as when I turn on my computer, after the system has launched, I see only my desktop. I don't see the upper nor left bar. When I doubleclick a file on my desktop, a new ...
0
votes
0answers
766 views

Xubuntu 14.10 upgrade issues with fglrx

I have ATI Mobility Radeon HD 5650: $ sudo lshw -C video *-display UNCLAIMED description: VGA compatible controller product: Madison [Mobility Radeon HD 5650/5750 / 6530M/6550M] ...
0
votes
0answers
29 views

My Xorg.conf file has both cards but only one monitor working?

I am trying to get my second monitor to work off two old amd cards (Radeon X1300/ rage Mach64). these cards are no longer supported by amd. When I generate the xorg.conf I have device sections for ...
1
vote
2answers
71 views

Problem With Guest Additions in Ubuntu Server [Virtual Box]

I have a problem installing Guest additions in ubuntu server with kernel 3.13.0-39-generic I install whole headers for this kernel with $ sudo apt-get install build-essential linux-headers-$(uname ...
0
votes
0answers
90 views

Pulseaudio acting strange with X11

I don't know what could be causing this, and all research I have done has come up blank. But when I try to play a sound from any app, the sound will not play until I switch virtual terminals, but I ...
0
votes
0answers
116 views

Ubuntu 14.04LTS Black Screen (Already purged NVIDIA)

What's happening: Black screen instead of desktop. I see the purple screen with the Ubuntu logo before it goes to black. My monitors are plugged into my motherboard (just like they were before I ...
1
vote
0answers
221 views

Dell XPS 13 Sputnik3 (Ubuntu 14.04) cannot find display-port

Here is the story. I've used the mini-display port from my XPS13 for about a year with an ASUS 2560x1440 res external display, via a mini-DP to DP connector. This has worked fine for 1 year. This ...
0
votes
0answers
47 views

EDID invalid => wrong resolution (identical monitors)

I have 2 identical monitors. However the one connected to the second port on my workstation is not recognized by the system. I have an NVIDIA GTS graphic card. The PC was shipped like it is now. No ...
0
votes
0answers
331 views

Nvidia Prime does not detect external VGA monitor after updating Ubuntu-drivers-common and xorg

This post is a followup to another post I had about accessing my external monitor after upgrading my ubuntu-drivers-common package. I had found the cause to be this bug, but now that a fix is ...
0
votes
0answers
40 views

How do I resolve login loop [duplicate]

^ Um, no it doesn't. I really, really wish it did. Ubuntu is in a login loop. I have set it to log in automatically, but it has started prompting me for a password. When I enter the password (which ...
0
votes
1answer
109 views

Firefox problem at showing some characters - ubuntu 14.10

My problem is what the title says. I show an image to illustrate: Some characters are not displayed and instead that square with random pixels appears. It can happen in any character, sometimes can ...
0
votes
1answer
32 views

X server does not respond when Spotify takes focus

I've been having problems running Spotify on Ubuntu 14.04. After having spotify open for a few hours, it will freeze all X windows when I return focus to it. I can still move my cursor and terminal ...
1
vote
1answer
84 views

Does HDMI require X in order to display?

I'm working with a user on a different question and I am beginning to wonder if I might be barking up the wrong tree. The original question deals with setting a script to run XMBC when the HDMI cable ...
0
votes
0answers
181 views

Setup multiseat with X.org and ONE NVidia card with two output ports? (Ubuntu 14.04)

I have been trying to setup my NVidia card to support a multiseat installation for 2 days now and I feel like I am not making any progress. First I tried to follow the Ubuntu instructions found here: ...
1
vote
1answer
239 views

xorg driver doesn't use my radeon videocard 14.04

I have a Dell Inspiron 5521 laptop with a Radeon HD 8730M videocard, running Ubuntu 14.04 However, when I use the X.Org X server open source drivers from xserver-xorg-video-ati, the computer uses ...
0
votes
1answer
122 views

How to get via SSH the active DISPLAY for a locally loged user?

I need to get the active DISPLAY for any loged in user, so if they enter through SSH, they can query it. Under Ubuntu 12.04, I used a script that, using the consolekit dbus interface, iterated ...
3
votes
0answers
161 views

Configure Xorg to work from integrated

I am using Ubuntu 14.04LTS, with an Intel CPU + integrated graphics, with a GTX650 GPU. I asked this question on SO but they said it was offtopic. I want to use my GPU for debugging CUDA code and for ...
3
votes
1answer
179 views

startx, gui on tty7 and sound on tty 1

I just installed ubuntu minimal and fluxbox. I have installed no login manager, so after the system boots, I login in the tty1 and use the startx command to run. After that, if I open Firefox and go ...
0
votes
0answers
62 views

Request for tester on 1600x900 resolution on nvidia driver 331.38

I am guessing the problem was due to nvidia driver 331.38 Ubuntu 14.04 custom resolution setting not working with 60hz refresh rate Here by , I hope someone would test a for nvidia driver 33.138 on ...
0
votes
0answers
151 views

configure Intel integrated graphics in thinkpad to drive external 4k display only, via HDMI, using xorg.conf

Using the interactive displays configuration tool from the Ubuntu desktop, I have successfully configured this Thinkpad X1 Carbon (2014) with its integrated Intel video to drive an external display at ...
0
votes
0answers
35 views

x11vnc server creates multiple screens

So this picture is showing the problem with scaling turned on. I'm only connecting to 5900 (display 0) and there's just one user. http://imgur.com/8KuHzLa It's super slow so why does it do it and ...
0
votes
0answers
150 views

Not able to start StartX on Ubuntu Server configured inside KVM

I have Ubuntu Server installed as guest OS inside KVM. I also installed Ubuntu Desktop on top of that but now when I am trying to start GUI using StartX, I am getting below message and my screen ...
0
votes
4answers
485 views

Xorg Crashes after installing Catalyst

I am trying to install the AMD Catalyst, but after reboot I hit a black screen. I checked the /var/log/Xorg.0.log and everything is fine up to the point where it has a segmentation fault. [ ...
1
vote
0answers
58 views

$DISPLAY env var gets cleared at random times

Stock Ubuntu 14.04 Trusty. I seem to regularly experience the $DISPLAY environment variable getting cleared for some reason I don't understand. Basically everything will work just fine until it's ...
0
votes
0answers
80 views

Higher Resolution Xrandr 1400x1050 Legacy GPU

Dear Ubuntu Community, recently I (re)found my 10 year old Sony Vaio laptop, a PCG-GRT916V to be exact. I immediately had the idea to put this old laptop to good use. Over the course of two weeks I ...
0
votes
1answer
171 views

ALPS Touchpad speed adjustment with synaptics driver

How could I change cursor speed (tocuhpad sensitivity?) for AlpsPS/2 ALPS DualPoint TouchPad from command line?
2
votes
0answers
31 views

Low Color Depth on only one screen

I have recently updated to 14.10 using the update manager, but now I have one problem: On my internal laptop screen, it looks like the color depth is something lower than 24bit. When using an ...
0
votes
0answers
348 views

Ubuntu 14.04 custom resolution setting not working with 60hz refresh rate

Ubuntu 14.04 64bit Nvidia GTX550 ( Using Nvidia binary driver - version 331.38 from nvidia-331 ) Monitor 2312hm I had been asking at Ubuntu forum http://ubuntuforums.org/showthread.php?t=2249608 but ...
1
vote
0answers
548 views

Nvidia Gtx 755M - Cannot access secondary GPU Permission denied [13]

I installed bumblebee and the Nvidia 331 drivers. I ran glmark2 and expected it to launch but I got this error. How do I run a program on the Gtx 755m graphics card? $optirun -vv glmark2 [ ...
0
votes
1answer
25 views

Laptop display stopped working with correct resolution for no reason

I'm, running latest xubuntu on a laptop with 1366x768 resolution and Radeon 4330 card. Default radeon driver. Never made any manual config changes, everything ran smoothly for a couple of months after ...
1
vote
0answers
87 views

Two monitors one 23“ hd and one 28” 4k

I have two monitors connected to my computer, I am using Ubuntu 14.04.1. One screen is set at full hd 1920x 1080 and the other monitor is 28" 4k set to 3840 x 2160. I have nvidia 760 display card. I ...
0
votes
0answers
24 views

Reinstalling Unity greatly increased start time

I had some issues with xrandr; namely, I set a primary monitor as DVI0 instead of DVI-0 which caused a whole mess of issues. After an hour of searching/messing around in the root terminal, I managed ...
0
votes
2answers
556 views

Steam error > NVidia problem, fix = can't open xubuntu

I installed the latest linux nvidia driver as per this and this. I thought it was running fine but in Additional Drivers it was I'm using the proprietary driver but none is selected in the list. ...
0
votes
0answers
13 views

remotemouse iphone pointer does not show in xinput

I installed remotemouse windows version with wine seemingly successfully, but the iphone only has control of the pointer location, it can't click or do any other features. I used xinput in the ...
0
votes
0answers
19 views

Display is broken after login [duplicate]

I have big problem with settings $DISPLAY and xorg. After login to my account screen is black for few seconds and back to login page again. It is only for one account on my computer and I think I need ...
0
votes
0answers
125 views

Dual monitors not working - Nvidia GeForce 8500 GT

I'm running Ubuntu 14.04 and I have two Dell U2413s that I've connected to my graphics card. One connects to the DVI port and the other one connects to the VGA port with a VGA to DVI-D converter. In ...
3
votes
1answer
355 views

I have a blank screen after upgrading to Ubuntu 14.10

I upgraded from Ubuntu 14.04 LTS, to Ubuntu 14.10. When I start my computer, I have a blank screen. If I plugin my laptop to my TV, at first only the TV turns on, but the login screen shows up on my ...