Questions about X.Org Server (commonly known as Xorg Server, XServer or Xorg), the software that runs the X window system used by most desktop window managers (GNOME, KDE, etc)

learn more… | top users | synonyms (2)

0
votes
0answers
10 views

How to debug why Nvidia-331 is not working?

Since today, my nvidia-331 installation is broken again. The version history available from packages.ubuntu.com claims the driver itself hasn't changed: ...
1
vote
0answers
11 views

Why are there mystery phantom keystrokes entered in Konversation's input box in GNOME 3.12 after heavy load and how do I fix it w/o restarting IRC?

This is getting ridiculous. In 14.10, with GNOME 3.12 and Konversation 1.5-master #4303, I sometimes wind up in a situation where the system locks up for whatever reason (heavy load from other ...
0
votes
1answer
60 views

Strange screen freezing/hangs

I have a laptop with hybrid intel/nvidia graphics (core i5 and gt650m). At random moments the screen, and just the visual part, will freeze/hang. Using Ctrl+Alt+F1 & Ctrl+Alt+F7 to switch the ...
0
votes
1answer
21 views

How do I solve dependencies with replacements?

I work on a solution getting a closed-source driver, called EMGD, working on Ubuntu. But there is a problem with the lubuntu-desktop package. It depends on lubuntu-core -> xorg and xorg needs ...
0
votes
1answer
19 views

X11 doesn't show windows edges, task bar nor anything

I've got a problem with X11 as when I turn on my computer, after the system has launched, I see only my desktop. I don't see the upper nor left bar. When I doubleclick a file on my desktop, a new ...
0
votes
0answers
49 views

Xubuntu 14.10 upgrade issues with fglrx

I have ATI Mobility Radeon HD 5650: $ sudo lshw -C video *-display UNCLAIMED description: VGA compatible controller product: Madison [Mobility Radeon HD 5650/5750 / 6530M/6550M] ...
0
votes
0answers
16 views

My Xorg.conf file has both cards but only one monitor working?

I am trying to get my second monitor to work off two old amd cards (Radeon X1300/ rage Mach64). these cards are no longer supported by amd. When I generate the xorg.conf I have device sections for ...
1
vote
2answers
27 views

Problem With Guest Additions in Ubuntu Server [Virtual Box]

I have a problem installing Guest additions in ubuntu server with kernel 3.13.0-39-generic I install whole headers for this kernel with $ sudo apt-get install build-essential linux-headers-$(uname ...
0
votes
0answers
80 views

Pulseaudio acting strange with X11

I don't know what could be causing this, and all research I have done has come up blank. But when I try to play a sound from any app, the sound will not play until I switch virtual terminals, but I ...
0
votes
0answers
44 views

Ubuntu 14.04LTS Black Screen (Already purged NVIDIA)

What's happening: Black screen instead of desktop. I see the purple screen with the Ubuntu logo before it goes to black. My monitors are plugged into my motherboard (just like they were before I ...
1
vote
0answers
34 views

Dell XPS 13 Sputnik3 (Ubuntu 14.04) cannot find display-port

Here is the story. I've used the mini-display port from my XPS13 for about a year with an ASUS 2560x1440 res external display, via a mini-DP to DP connector. This has worked fine for 1 year. This ...
0
votes
0answers
14 views

EDID invalid => wrong resolution (identical monitors)

I have 2 identical monitors. However the one connected to the second port on my workstation is not recognized by the system. I have an NVIDIA GTS graphic card. The PC was shipped like it is now. No ...
0
votes
0answers
89 views

Nvidia Prime does not detect external VGA monitor after updating Ubuntu-drivers-common and xorg

This post is a followup to another post I had about accessing my external monitor after upgrading my ubuntu-drivers-common package. I had found the cause to be this bug, but now that a fix is ...
0
votes
0answers
39 views

How do I resolve login loop [duplicate]

^ Um, no it doesn't. I really, really wish it did. Ubuntu is in a login loop. I have set it to log in automatically, but it has started prompting me for a password. When I enter the password (which ...
0
votes
1answer
46 views

Firefox problem at showing some characters - ubuntu 14.10

My problem is what the title says. I show an image to illustrate: Some characters are not displayed and instead that square with random pixels appears. It can happen in any character, sometimes can ...
0
votes
1answer
17 views

X server does not respond when Spotify takes focus

I've been having problems running Spotify on Ubuntu 14.04. After having spotify open for a few hours, it will freeze all X windows when I return focus to it. I can still move my cursor and terminal ...
1
vote
2answers
61 views

Does HDMI require X in order to display?

I'm working with a user on a different question and I am beginning to wonder if I might be barking up the wrong tree. The original question deals with setting a script to run XMBC when the HDMI cable ...
0
votes
0answers
32 views

Setup multiseat with X.org and ONE NVidia card with two output ports? (Ubuntu 14.04)

I have been trying to setup my NVidia card to support a multiseat installation for 2 days now and I feel like I am not making any progress. First I tried to follow the Ubuntu instructions found here: ...
1
vote
1answer
70 views

xorg driver doesn't use my radeon videocard 14.04

I have a Dell Inspiron 5521 laptop with a Radeon HD 8730M videocard, running Ubuntu 14.04 However, when I use the X.Org X server open source drivers from xserver-xorg-video-ati, the computer uses ...
0
votes
0answers
26 views

How to get via SSH the active DISPLAY for a locally loged user?

I need to get the active DISPLAY for any loged in user, so if they enter through SSH, they can query it. Under Ubuntu 12.04, I used a script that, using the consolekit dbus interface, iterated ...
2
votes
0answers
52 views

Configure Xorg to work from integrated

I am using Ubuntu 14.04LTS, with an Intel CPU + integrated graphics, with a GTX650 GPU. I asked this question on SO but they said it was offtopic. I want to use my GPU for debugging CUDA code and for ...
3
votes
1answer
77 views

startx, gui on tty7 and sound on tty 1

I just installed ubuntu minimal and fluxbox. I have installed no login manager, so after the system boots, I login in the tty1 and use the startx command to run. After that, if I open Firefox and go ...
0
votes
0answers
38 views

Request for tester on 1600x900 resolution on nvidia driver 331.38

I am guessing the problem was due to nvidia driver 331.38 Ubuntu 14.04 custom resolution setting not working with 60hz refresh rate Here by , I hope someone would test a for nvidia driver 33.138 on ...
0
votes
0answers
34 views

configure Intel integrated graphics in thinkpad to drive external 4k display only, via HDMI, using xorg.conf

Using the interactive displays configuration tool from the Ubuntu desktop, I have successfully configured this Thinkpad X1 Carbon (2014) with its integrated Intel video to drive an external display at ...
0
votes
0answers
14 views

x11vnc server creates multiple screens

So this picture is showing the problem with scaling turned on. I'm only connecting to 5900 (display 0) and there's just one user. http://imgur.com/8KuHzLa It's super slow so why does it do it and ...
0
votes
0answers
19 views

Not able to start StartX on Ubuntu Server configured inside KVM

I have Ubuntu Server installed as guest OS inside KVM. I also installed Ubuntu Desktop on top of that but now when I am trying to start GUI using StartX, I am getting below message and my screen ...
0
votes
4answers
185 views

Xorg Crashes after installing Catalyst

I am trying to install the AMD Catalyst, but after reboot I hit a black screen. I checked the /var/log/Xorg.0.log and everything is fine up to the point where it has a segmentation fault. [ ...
1
vote
0answers
43 views

$DISPLAY env var gets cleared at random times

Stock Ubuntu 14.04 Trusty. I seem to regularly experience the $DISPLAY environment variable getting cleared for some reason I don't understand. Basically everything will work just fine until it's ...
0
votes
0answers
34 views

Higher Resolution Xrandr 1400x1050 Legacy GPU

Dear Ubuntu Community, recently I (re)found my 10 year old Sony Vaio laptop, a PCG-GRT916V to be exact. I immediately had the idea to put this old laptop to good use. Over the course of two weeks I ...
0
votes
1answer
36 views

ALPS Touchpad speed adjustment with synaptics driver

How could I change cursor speed (tocuhpad sensitivity?) for AlpsPS/2 ALPS DualPoint TouchPad from command line?
1
vote
0answers
14 views

Low Color Depth on only one screen

I have recently updated to 14.10 using the update manager, but now I have one problem: On my internal laptop screen, it looks like the color depth is something lower than 24bit. When using an ...
0
votes
0answers
153 views

Ubuntu 14.04 custom resolution setting not working with 60hz refresh rate

Ubuntu 14.04 64bit Nvidia GTX550 ( Using Nvidia binary driver - version 331.38 from nvidia-331 ) Monitor 2312hm I had been asking at Ubuntu forum http://ubuntuforums.org/showthread.php?t=2249608 but ...
0
votes
0answers
96 views

Nvidia Gtx 755M - Cannot access secondary GPU Permission denied [13]

I installed bumblebee and the Nvidia 331 drivers. I ran glmark2 and expected it to launch but I got this error. How do I run a program on the Gtx 755m graphics card? $optirun -vv glmark2 [ ...
0
votes
1answer
19 views

Laptop display stopped working with correct resolution for no reason

I'm, running latest xubuntu on a laptop with 1366x768 resolution and Radeon 4330 card. Default radeon driver. Never made any manual config changes, everything ran smoothly for a couple of months after ...
1
vote
0answers
29 views

Two monitors one 23“ hd and one 28” 4k

I have two monitors connected to my computer, I am using Ubuntu 14.04.1. One screen is set at full hd 1920x 1080 and the other monitor is 28" 4k set to 3840 x 2160. I have nvidia 760 display card. I ...
0
votes
0answers
22 views

Reinstalling Unity greatly increased start time

I had some issues with xrandr; namely, I set a primary monitor as DVI0 instead of DVI-0 which caused a whole mess of issues. After an hour of searching/messing around in the root terminal, I managed ...
0
votes
2answers
155 views

Steam error > NVidia problem, fix = can't open xubuntu

I installed the latest linux nvidia driver as per this and this. I thought it was running fine but in Additional Drivers it was I'm using the proprietary driver but none is selected in the list. ...
0
votes
0answers
3 views

remotemouse iphone pointer does not show in xinput

I installed remotemouse windows version with wine seemingly successfully, but the iphone only has control of the pointer location, it can't click or do any other features. I used xinput in the ...
0
votes
0answers
19 views

Display is broken after login [duplicate]

I have big problem with settings $DISPLAY and xorg. After login to my account screen is black for few seconds and back to login page again. It is only for one account on my computer and I think I need ...
0
votes
0answers
71 views

Dual monitors not working - Nvidia GeForce 8500 GT

I'm running Ubuntu 14.04 and I have two Dell U2413s that I've connected to my graphics card. One connects to the DVI port and the other one connects to the VGA port with a VGA to DVI-D converter. In ...
3
votes
1answer
227 views

I have a blank screen after upgrading to Ubuntu 14.10

I upgraded from Ubuntu 14.04 LTS, to Ubuntu 14.10. When I start my computer, I have a blank screen. If I plugin my laptop to my TV, at first only the TV turns on, but the login screen shows up on my ...
0
votes
0answers
39 views

Certain games won't load - Nvidia

Certain games on Steam won't load. I can't figure out why. I upgraded to kernel 3.14.4 from 3.13.39 and this problem won't go away: [ 81.122225] bbswitch: enabling discrete graphics [ 81.593271] ...
0
votes
0answers
88 views

14.04 I Screwed Up the Graphics/Desktop/Something

Because I hadn't used Terminal in a long time I thought I'd fiddle with the on-board graphics . . . Using Synaptic I installed first one, then the other flavor of (I believe) fglrx for AMD ...
0
votes
1answer
43 views

Ubuntu Thinks I Have Two Monitors

Ubuntu thinks I have two monitors when I'm on a laptop. Here is my setup: Lenovo W520 Ubuntu 14.04 64 bit Nvidia Proprietary drivers (340.46) Symptoms: Display (and nvidia-settings) shows a ...
0
votes
0answers
24 views

Cannot reopen session after launching startx on UBUNTU

had an issue with Xorg so I launched startx from my terminal on ubuntu. It wasn't working well (only my wallpaper was on the screen after I launch the command). Then I force to shut down. My actual ...
0
votes
0answers
24 views

Moving from 12 to 14 loosing nvidia xinerama feature

I just installed ubuntu 14 on the computer I was using ubutun 12 on (clean install, not update). After some efforts I was able to activate the nvidia driver, but I cannot make it use my 3 monitors as ...
1
vote
0answers
134 views

How to set up a separate X server for the Oculus Rift?

Oculus SDK version 0.4.3 comes with an experimental Linux support for the Oculus Rift DK2. The documentation mentions two general options to run the Rift: running the Rift in a twinview ...
1
vote
3answers
2k views

Blank screen on TTY7 after upgrading from 14.04 to 14.10

I upgraded my 14.04 to 14.10 via "sudo do-release-upgrade" without strange messages. After rebooting and entering the password for the encrypted system partition in the graphical form, TTY7 keeps ...
0
votes
0answers
12 views

How to get windows in order they appear in xfce4-panel?

I'm using xUbuntu 14.04 and I want to add a shortcut Super+Left Arrow to focus on window that appears to the left of the currently active in xfce4-panel, e.g. here I'd have it switch to ...
0
votes
0answers
70 views

Ubuntu 14.04 Resolution Issue

First of, I've already tried to google what seems to be the problem to no avail. I've had this problem for a week now. Computer: Asus K53SV | Video Card: Nvidia GT540M When I was using Ubuntu ...