Questions about Virtualizing Ubuntu or virtualizing other operating systems within Ubuntu.

learn more… | top users | synonyms (3)

5
votes
0answers
701 views

Running vagrant inside VirtualBox

I'm running Xubuntu 14.04 in a VirtualBox VM on Windows 7. Inside the VM, I want to use Vagrant as part of my development environment. The Vagrant setup executes successfully, until it wants the VM (...
4
votes
0answers
839 views

MAAS, JUJU, VirtualBox 4.3 and virsh command

I've a problem with libvirt 1.2.2 and VirtualBox 4.3. After installing Ubuntu 14.04 server and setting MAAS and JUJU, I need to use virsh to see the list of my installed VM (as reported in the guide ...
3
votes
0answers
21 views

Ubuntu Server won't work in QEMU: KERNEL PANIC

I tried to install ubuntu-16.04-server-amd64.iso in QEMU as a virtual machine. This was my command to generate the image file: qemu-img create -f qcow2 confImage 100G After creating the image file ...
3
votes
0answers
294 views

Virtualization limits for Ubuntu Server 14.04 LTS with KVM

Essentially I'm after something like this, but for Ubuntu Server 14.04 LTS. I'm trying to create some KVM guests with very large 1TB+ RAM (through OpenStack Nova). I can boot the 1TB VM fine, but I ...
3
votes
0answers
745 views

KVM-Guest only boots single user mode

We have a Vserver Host running on Ubuntu 12.04 with KVM/QEMU and so far guests been running fine with various OS's (Ubuntu 10.04, 12.10, Debian 6,7, CentOS 5,6). After the installation of Ubuntu 14....
3
votes
0answers
2k views

Cannot install into target mounted with noexec or nodev while doing qemu-deboot strapping

I'm trying to install the armel version of Ubuntu with qemu-deboot-strap on my desktop X64 system,but I've found this error : $ mkdir precise $ sudo qemu-debootstrap --arch=armel precise ./precise/ ...
3
votes
0answers
345 views

How do I make wireless bridged networking work with linux guest in kvm/qemu?

I am running the ubuntu 13.10 cloud image on kvm/qemu. The guest networking works fine operating in NAT mode when on wireless. Wired bridged networking (eth0 + macvtap) works fine as well. When ...
3
votes
0answers
492 views

Mouse scroll wheel does not work for ubuntu 12.04 running under Hyper-V for Windows 8 Pro

I'm using Ubuntu 12.04 lts on a Hyper-V virtual machine (MS Windows 8 Pro) and I need some help with the mouse driver. The mouse responds fine in general: the cursor's moving, left/right click works ...
3
votes
0answers
345 views

How do I get the VT running X in my LXC container to my host?

I'm trying to run Lubuntu within an LXC container on my host already using a GUI. Is it possible to redirect the X output from the container to say; VT9 rather than VT7? If so where is the VT7 ...
2
votes
0answers
42 views

Oracle VM - Ubuntu 64bit

I recently updated my VirtualBox after not using it for about half a year (Newest version - 5.0.22 r108108). I have a 200GB VM running Ubuntu 64-bit (I can't remember what version exactly) and now ...
2
votes
0answers
33 views

virt-manager: “Storage parameter error: directory is not managed on the remote host” when importing an existing image from a mounted drive

A server I manage remotely has a KVM/QEMU image stored on a non-os, mounted drive /mnt/drive. When I use virt-manager to import the disk image, I get the following error: Storage parameter error. ...
2
votes
0answers
127 views

How to run a program in a Windows VM and have it be it's own window

I love Ubuntu greatly, but there is one Windows program that I really need to run in Ubuntu: Windows Live Movie Maker (I know, I should be ashamed!). I have Windows 10 running in Virtual Box. Is there ...
2
votes
0answers
156 views

QEMU-KVM with VLANS and no bridges

Please be gentle, I'm both a novice Ubuntu user and novice networking guy. I'm trying to put together a virtual server to support a couple of telephony applications at my office. Both applications ...
2
votes
0answers
144 views

How do I mount a Shared Folder from a Vmware Workstation Host (Windows 7) inside Ubuntu

I have been trying to do this for days now and I am getting no where. I have downloaded the latest Vmware Tools. What steps/commands do I use? Please help Gary
2
votes
0answers
785 views

kvm bridge dropping packets

Periodically one or more of the guests lose network connectivity. We are getting packet loss only in vms. Setup: We're running 3 KVM guests, all Ubuntu 12.04 LTS using bridged networking. OS on ...
2
votes
0answers
168 views

Host to Guest one way connection issue

I have guest run on my machine on qemu with configuration: /usr/local/kvm/bin/qemu-system-x86_64 -enable-kvm -cpu host -smp 8 -hda ${TEST_VIRT_ENV_IMAGE} -m 4096 -netdev user,id=user.0 -device e1000,...
2
votes
0answers
74 views

How to invoke a X Session and a VM instead of login prompt

The system is Ubuntu 12.04 but the OEM requirement is to make it appear as if it is a Windows system to the end user. Other VMs and daemons will be active in the system but it is controlled from ...
2
votes
0answers
110 views

What backup solution allows for the easiest migration and restore of machines, even if they're restored from a VM or bare metal and vice versa?

I manage a lot of Ubuntu machines, many physical, many virtual. Backup as a general concept is pretty simple, but backup of entire systems tends to get murky. I'm familiar with virt-p2v, but that ...
2
votes
0answers
50 views

Virtual Machines

I have 3 VMs and I need to know weather they reside on one physical host or not, and if they not, I need to clone them to one physical host using OpenStack features. I am not sure how they were ...
2
votes
0answers
96 views

How do I run the Ubuntu Phone Nexus7 image in a VM?

Do I need to go through the device imaging steps with an ADT VM, a specific qemu configuration, something else, not possible? How do I run the Ubuntu Phone Nexus7 image in a VM? Any of the above ...
2
votes
0answers
1k views

How to Install Ubuntu Server amd64 12.0.4.1 in Windows 2008 Hyper-V?

I would like to install Ubuntu Server 12.0.4.1 LTS in Windows Server 2008 Hyper-V. However when I run the Ubuntu installation from the CDROM ISO, I get stopped by the error "Your installation CD-ROM ...
2
votes
0answers
424 views

Windows 8 guest, ubuntu 12.10 host - sound will only play through front headphone jack

I've had a search but couldn't find a solution for my issue. I'm running Ubuntu 12.10 with VMWare Player 5.0.1 build-894247. Unbuntu is recognising my sound card as a "Creative Labs CA0106 ...
2
votes
0answers
473 views

How to make NetworkManager NOT manage libvirtd's virtbr0 and vnet0 interfaces?

The libvirt-bin daemon libvirtd creates virtual bridge(s) and interface(s) for the virtual machines it controls. NetworkManager kills these connections. I know that it is possible to uninstall or ...
1
vote
0answers
8 views

Clean up KVM / libvirt

I installed the "Virtual machine host" feature during installation of my 16.04 server. I'll run VMs exclusively on my local network so I don't need virbr0, dnsmasq and iptables rules, just to mention ...
1
vote
0answers
35 views

Linux VirtualBox Lab VLAN tagging

I am in the middle of a learning experience in my network education that I’d like some community insight on. I have set up a virtual lab on my home network but am trying to add physical hosts to the ...
1
vote
0answers
29 views

Unable to stub 1 of 2 nvidia cards

I am unable to have my video card claimed completely by stub: [ 9.897987] pci-stub: add 10DE:13C2 sub=FFFFFFFF:FFFFFFFF cls=00000000/00000000 [ 9.897998] pci-stub: add 10DE:0FBB sub=FFFFFFFF:...
1
vote
0answers
31 views
+50

QEMU SDL_Init failed: No available video device

Total Linux NOOB looking for advice: I'm trying to run a 64bit application on a 32bit PC using QEMU user mode. I have compiled qemu from source, all good, but when I want to start the application (...
1
vote
0answers
91 views

Unable to install VMware kernel modules in Workstation 11 on Ubuntu 16.04

I am unable to install VMWare Workstation 11 successfully on Ubuntu 16.04 due to the Kernel Module Updater failing on the Virtual Machine Monitor and Virtual Network Device. Here is the log file that ...
1
vote
0answers
66 views

how do I install qemu on my bq Aquaris M10?

I am trying to install scrivener (windows, or Linux) on my bq Aquaris m10 tablet. The problem is that scrivener is only written for amd/x86 hardware, and my tablet is arm. The good news is that this ...
1
vote
0answers
94 views

No console login prompt in Xenial VM on KVM host

I just installed a fresh VM using Xenial beta mini.iso installation like I do for any Ubuntu based VM on my KVM based virtualisation host, but this VM doesn't show console login prompt on (KVM) VNC ...
1
vote
0answers
67 views

No Display in Fullscreen VirtualBox Guests — AwesomeWM Host

I'm using AwesomeWM v3.5.6 on my Host, a Xubuntu 15.10. I have VirtualBox guest additions installed on all my guest VMs, a Windows 7, another Xubuntu 15.10 and a Kali 2.0. When I try to switch my ...
1
vote
0answers
59 views

“No devices available” in USB settings of guest OS

I am trying to connect my sound card and MIDI device directly to VirtualBox guest Windows 10 64-bit. I've done the following: Added current user to vboxusers group Installed VirtualBox 5.0.14 ...
1
vote
0answers
51 views

Virtualize Windows on Ubuntu server no GUI

I've been administering a remote Ubuntu 12.04 server for some time and loving it. Sadly some of the applications I would like to run hate WINE and pretty much require a Windows installation. I don't ...
1
vote
0answers
32 views

Why doesn't uvt-kvm --run-script-once work when run on a 14.04 host building a more recent guest?

I have an Ubuntu 14.04 virtual host, and I'm building guests on it with uvt-kvm. I have a small script I want them to run on first start. The command line looks something like this: uvt-kvm create --...
1
vote
0answers
175 views

“unable to enumerate USB device” when enabled IUMMO/VT-d in BIOS

I am trying to get started with IUMMO feature, but when i turn it on, i cannot load my system anymore; in recovery mode i see bunch of similar error messages, ending with: [ 169.00000] usb 8-3: ...
1
vote
0answers
27 views

Find GPU resource allocation on virtual server

I have been provided a virtual server, which runs Ubuntu 14.04. I'm accessing it using PuTTY. The server should have a NVIDIA GRID K2 GPU, but I'm having some issues using it in Python/C++ with the ...
1
vote
0answers
157 views

MAAS KVM nodes commission timesout

So, I have set up MAAS and several KVM and Qemu VMs. When I add them as nodes, they start up during commissioning but then the attempt times out. Here's the line from the MAAS log: [ERROR] test: ...
1
vote
0answers
179 views

Run Snappy Ubuntu Core on Hyper-V in Windows Server 2012

I'm running Ubuntu 14.04 Server in a Hyper-V VM on Windows Server 2012 and all is working well. I'd like to try Snappy Ubuntu Core in Hyper-V but I've not seen any instructions online explaining how ...
1
vote
0answers
207 views

nested vm failed to boot with “KVM: entry failed, hardware error 0x0”

Trying to create a nested vm with virt-manager. vm stuck at paused state. From instance log under /var/log/libvirt/qemu/, I see following errors. Anyway to get around this? KVM: entry failed, ...
1
vote
0answers
27 views

VirtualMode to remove MSDOS filesystem files in Ubuntu?

I have a MSDOS memory card where I would like delete files by my Ubuntu installation. I run on those files sudo rm /media/masi/g0399/DCIM/video.mp4 but I get a filesystem error that the filesystem is ...
1
vote
0answers
234 views

Bridge external IP to the qemu standalone Virtual Machine

I'm having a very specific issue. To let You know what I'm up to, I will describe the whole infrastructure of my system. I've got a Ubuntu host machine on which I run up to 4 virtual Ubuntu machines....
1
vote
0answers
151 views

Multi-headed Gaming VM Host on Ubuntu Server

I am trying to build a multi-headed gaming system based on an Ubuntu Server 15.04 host with either Windows or Ubuntu/Linux Mint guests. I have gotten the systems nearly working with Linux Mint/Ubuntu ...
1
vote
0answers
524 views

How can i Boot my VMware WIN 7 in a new machine

I am using Ubuntu 14.04 with VMware windows 7 installed. I moved my hard disk to another computer and i am not able to play vmware machine. I get this message: Virtualized Intel VT-x/EPT is not ...
1
vote
0answers
136 views

Manual for building a virtual machine with kvm

Using this manual I want to build a VM. However, the manual seems rather outdated: It talks about using Hardy on i386 architecture (I'm running Vivid on an x86_64). Also, ubuntu-vm-builder is no more ...
1
vote
0answers
136 views

graceful shutdown of libvirt virtual machines on host shutdown

I have a Windows 8 installation on a KVM virtual machine, runing on my Ubuntu 15.04 host. When I issue the shutdown option in virt-manager, or virsh shutdown windows, the virtual machine cleanly shuts ...
1
vote
0answers
88 views

How to hot add a new disk with virsh attach-disk?

I'm trying to add a new LVM disk to my guest machine (Ubuntu 14.04.1) by doing the following on the host: lvcreate -L 14G -n vm_vm005_data3 vg00 virsh attach-disk vm005 /dev/vg00/vm_vm005_data3 --...
1
vote
0answers
168 views

KVM : Connect USB PS3 Eye Webcam to Virtual Machine

General Question: What keeps a USB device from registering correctly in a KVM virtual machine? Specific: The PS3 Eye (ID 1415:2000 Nam Tai E&E Products Limited or OmniVision Technologies, Inc ...
1
vote
0answers
153 views

VM ware player Ubuntu post Installation problem- VT-x not in BIOS on lenovo T430

I am getting the following error: "This host supports Intel VT-x, but Intel VT-x is disabled" When I went into BIOS to change these, I did not find any option like "VT-x" Ubuntu version-14.04.01 VM- ...
1
vote
0answers
306 views

virt-sysprep problem

Virt-sysprep man page notes : You do not need to run virt-sysprep as root. In fact we'd generally recommend that you don't. The time you might want to run it as root is when you need root ...
1
vote
0answers
52 views

what is the effect of making my kvm's HD cache none vs default?

I am playing with KVM migration, and I got an error about unsafe migration due to hdd cache settings. I found the fix, which is to set the cache to none and it works after I made the change. But ...