Questions about upgrading packages, systems or hardware.

learn more… | top users | synonyms (5)

1
vote
1answer
21 views

Unable to update Ubuntu 10.10 [duplicate]

I am using Ubuntu 10.10 ,when I use apt-get install I am getting error as Some index files failed to download, they have been ignored, or old ones used instead.
2
votes
1answer
68 views

Problem cloning root and home before doing an upgrade from Trusty to Utopic

I'm trying to copy root and home to other partitions on my notebook internal drive and then boot from them (root2 and home2). Once it works, it can be an (almost) live backup or I could upgrade from ...
-1
votes
1answer
535 views

14.04 trusty: 'apt-get install' silently refuses upgrade package with unsatisfied dependencies

This is more or less replication of this question. I hope AskUbuntu is more suitable place for it. Short description: apt can't upgrade a package if some dependencies are missing (it's OK), but ...
0
votes
1answer
89 views

can not update 12.10 to 13.04 [duplicate]

Trying to get to 14 version by updating 12.40 to 13.04 but get failed fetch error. Have tried upgrade through Software updater and get all the way through to the update prompt "you should update to 13....
0
votes
2answers
75 views

Black screen after upgrading to Ubuntu 14.04

I upgraded from Ubuntu 12 to 14.04 from the updater, and the installation seemed to go fine. When my HP Pavilion boots up, it gets to the login screen and everything looks normal. It allows me to ...
-1
votes
1answer
23 views

No matter what i do, upgrade keeps being offered

I am very happily running 12.04.5 LTS Several months ago, it began popping up a dialog box EVERY COUPLE OF MINUTES that says "Welcome to Ubuntu 14.04 'Trusty tahr'" -- there are three choices Don't ...
4
votes
1answer
3k views

How can I upgrade gnome-terminal on Ubuntu 14.04 LTS?

I would like to upgrade gnome-terminal to the latest version. Is that possible on Ubuntu 14.04 LTS? I am using version 3.6.2 of gnome-terminal. I have tried: sudo apt-get install --only-upgrade ...
1
vote
1answer
974 views

The difference between the different APT upgrade commands

I have seen and used all of these commands to upgrade packages on my system, but why are there different commands for this? Do they all not do the same thing? And if not, then in which situations ...
0
votes
1answer
54 views

From terminal how can I upgrade a particular software only [duplicate]

Using Xubunutu 140.04 LTS I want to upgrade a particular software only without upgrading the rest of the system. How can this be done from terminal, To update entire system I understand that I need ...
1
vote
2answers
144 views

Ubuntu 14.04 seems to have failed to upgrade from 12.04

I recently attempted to update to Ubuntu 14.04 from Ubuntu 12.04. Everything seemed to work without error until it restarted. When the computer fired back up, I was greeted with the following message ...
-1
votes
1answer
70 views

How to upgrade python in ubuntu 14.04 LTS?

I'm using python Please take a look at this SCREENSHOT. But it is old version. So, I've downloaded a new version of source code for Python. But it's giving an error while compilation. Please help me ...
0
votes
1answer
57 views

Is upgrading to Utopic worth it? Will I encounter lots of bugs?

I have a newer, touchscreen laptop/tablet (a 2-in-1? but it doesn't come apart, it folds back and becomes a tablet), and I'd like the fullest support possible for my newer device. When trying to ...
1
vote
1answer
96 views

How do I check for release updates that are not beta but might not be LTS?

I have a cron job that checks for new releases. I want to make sure it emails me when a new release is out of beta and ready to install. I want to upgrade to both long term support (LTS) releases ...
1
vote
1answer
136 views

Error when sudo apt-get upgrade

I run Ubuntu 14.04 LTS. When I type sudo apt-get upgrade into the terminal I get this error message. The following packages have unmet dependencies. cups : Depends: libc-bin (>= 2.13) E: Unmet ...
1
vote
0answers
599 views

How to update kernel to 3.19 on 14.04 with i915 Intel graphics?

On 14.04.2 LTS (amd64), I need to update the Linux kernel to 3.19+ (because it adds support for some hardware I have). The computer uses EFI and has an integrated Intel Graphics controller. lspci ...
0
votes
1answer
1k views

Problem in updating [duplicate]

Whenever I try to update my system I get these error messages: W: Failed to fetch http://dl.hhvm.com/ubuntu/dists/trusty/InRelease Unable to find expected entry 'main/source/Sources' in Release file ...
0
votes
3answers
1k views

Can't Access Terminal, Menus or Sidebar

I posted a while ago with this problem: 14.10 Upgrade: No access to menus or sidebar, which I cannot find a workaround, especially as I can't access the Terminal via Ctrl Alt T, and none of the login/...
0
votes
1answer
53 views

Grub kernel upgrade (two different systems)

My system is partitioned this way: hdda 500 giga (/dev/sda) ssd 20 giga (/dev/sdb) /dev/sda /boot(300 mega) /home(remaining space) (/dev/sdb) / (14 giga main system with ubuntu 14.04 x64) / (7 ...
0
votes
1answer
207 views

Upgrade from 12 to 14 failed with missing python package, now what?

do-release-upgrade aborted deep in the process. The main log file ends with the following. How do I recover this system? (The apt.log file seems boring). 2015-03-28 08:30:32,930 INFO Using config ...
3
votes
1answer
28k views

How to upgrade Ubuntu 14.04 LTS to Ubuntu 15.04? [duplicate]

Is there a way I can upgrade my Ubuntu 14.04 to 15.04 online without using a bootable device?
1
vote
1answer
860 views

Apache from 2.4.7 to 2.4.10

I am running Ubunto 14.04 LTS that runs Apache 2.4.7. I know that Apache 2.4.12 is out but only want to upgrade to Apache 2.4.10. How can I do this without breaking WordPress 4? Thanks
7
votes
1answer
2k views

apt-get upgrade: why is lxc-docker being kept back? [duplicate]

Why is lxc-docker being held back? I also notice that my web app, running on Docker, is quite slow. Any suggestions? [lucas@production]/home/lucas$ sudo apt-get dist-upgrade Reading package lists... ...
3
votes
0answers
135 views

Why does xubuntu 14.04 request a reboot on every start?

Since installing xubuntu 14.4, I have often found that the update manager insists a reboot is required even if no upgrades were performed. This seems to be because /var/run/reboot-required and reboot-...
0
votes
1answer
727 views

upgrading from 14.04 to 14.10 issue

During the distro-upgrade 14.10 in the unpacking I saw an error in the terminal that said do this to fix: gdk-pixbuf-query-loaders > /usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders.cache ...
0
votes
1answer
1k views

Why does updating and upgrading Ubuntu results in reverting the numpy version to 1.8.2

I am using Ubuntu 14.04.2 LTS on a 64-bit machine. I noticed that whenever I update and upgrade Ubuntu using sudo apt-get update && sudo apt-get upgrade the numpy version in Python reverts ...
1
vote
1answer
12 views

why am i asked for a cdrom to perform upgrades?

I recently downloaded an iso image for ubuntu to install on a friend's laptop and now my installation is asking me to insert a cdrom in order to perform an upgrade. How can I get rid of this and get ...
19
votes
4answers
16k views

Google Chrome PPA upgrade invalid signature

When running: sudo apt-get update && sudo apt-get dist-upgrade I got this output: Ign http://security.ubuntu.com utopic-security InRelease Ign http://gb.archive.ubuntu.com utopic InRelease ...
1
vote
0answers
229 views

Observium Upgrade procedure on ubuntu 14.04 from Community edition to prefessional edition

I am planning to upgrade observium from community edition to professional edition. Can someone please help with the procedure. DISTRIB_ID=Ubuntu DISTRIB_RELEASE=14.04 DISTRIB_CODENAME=trusty ...
6
votes
2answers
7k views

How to upgrade to the latest Emacs?

I have Emacs 24.3.1 and I'd like to upgrade to the latest Emacs 24.4.x. All documentation that I have visited suggests building from a tarball or source. Is there a reason why there are no package ...
2
votes
1answer
214 views

how do I “rebuild” or “repair” APTD?

How do I "rebuild" or "repair" aptd? I don't mean up the various utilities to rebuild and reconfigure which has not solved my problem suggesting that something more fundamental is damaged. I am ...
1
vote
1answer
41 views

Getting a new harddrive, and want to use Ubuntu. Will it work on my emachine?

My PC hard-drive blew up and I am getting a Toshiba HD to replace that one. Is this going to be way over my head? I have read up on Ubuntu, and I really like what I have seen. I was going to use my ...
0
votes
1answer
457 views

Why does apt-get upgrade give ELF file warning?

Executing sudo apt-get update and sudo apt-get upgrade: sudo apt-get update sudo apt-get upgrade gives the following message, which I think is a warning: /sbin/ldconfig.real: /usr/lib/...
1
vote
3answers
150 views

why can't I install some packages after installing virtualbox

After I installed virtualbox, I cannot install some packages. So I removed virtualbox, then I still cannot install the packages. This is the package: And this is the error I received. After I ...
0
votes
0answers
20 views

Installation Upgrade [duplicate]

I was trying to upgrade my OS from 11.1 to 14 and after waiting for 2 hours I got this message and the progress bar is no longer moving. Mar 17 06:57:39 ubuntu NetworkManager[1697]: <warn> ...
1
vote
1answer
69 views

Risk of apt-get upgrade on Ubuntu 12.04 with manually installed Cuda 6.5

I'm using Ubuntu 12.04 along with a manually installed Cuda 6.5. I'm wondering if there is a risk doing apt-get upgrade? The question is: Does apt-get upgrade install some default Ubuntu Nvidia ...
1
vote
1answer
17 views

Bumpy Upgrade and Possible Missing pakages

So I just Upgraded to Ubuntu 14.10 and It had a few hiccups on the road of no return. Idk if im missing any packages or something failed to install because I got allot of failed attempted installs. ...
1
vote
2answers
2k views

Point Release upgrade from 14.04.1 to 14.04.2?

I wanted to upgrade to 14.04.2 point release from 14.04. What I did was: sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade -y Then I wanted to upgrade to 3....
2
votes
0answers
70 views

Distribution Upgrade CRASH/FREEZE

Here's my situation: just got a new computer with Ubuntu 12.04. It suggested an upgrade to 14.04. I ran the upgrade and it already crashed once, so I had to restore system to its original state. Now, ...
0
votes
1answer
146 views

required hardware upgrade for old system [duplicate]

I want to use Ubuntu 14.04.I do not wish to opt for lightweight versions so I need help in determining some reasonable hardware upgrades so I can use Ubuntu comfortably. Currently my system specs are ...
0
votes
1answer
27 views

If I upgrade Ubuntu from an EOL version to a supported version will my data will lost? [duplicate]

If I upgrade Ubuntu from an EOL version to a supported version will my data will lost?
1
vote
1answer
390 views

Graphical system broken after AMD->Nvidia upgrade. How to re-install all graphical components?

I've upgraded my AMD HD4770 with an Nvidia GTX 960. When I boot into Ubuntu, the screen is mostly black with some red artifacts at the top. I can switch with Ctrl+Alt+F1 to a terminal. I've tried ...
2
votes
0answers
430 views

Why does libapache2-mod-php5 get removed whenever I upgrade apache2?

I hope someone can help me figure out what is going on with my apache upgrades. For years, whenever I upgrade apache2, it tries to install apache2-mpm-itk even though I use the prefork module apache2-...
0
votes
1answer
610 views

Apache problems after upgrade from 12.10 to 13.10/14.04

I just finished upgrading my server to Ubuntu 14.04.2. Previously I had had it configured thanks to the "Perfect server" guide for 12.10. Unfortunately, after the upgrade I cannot access any of the ...
0
votes
2answers
98 views

how to auto-answer apt-get upgrade?

When I run apt-get --yes upgrade in a script it sometimes stops and prompts for input. Today in 14.04 LTS it is prompting for what to do for grub/menu.lst. I don't know what could be asked for in a ...
1
vote
0answers
40 views

default menu theme is black text on grey after long series of upgrades

This laptop that I've got has been upgraded over an extremely long period of time from 11.04, 11.10, 12.04, 12.10, 13.10, 14.04, 14.10. I think I've got almost all of it working again, at least ...
3
votes
1answer
3k views

How I can upgrade gnome to latest(Testing or Unstable release) on ubuntu?

Now I'm using gnome shell version 3.14.3 on ubuntu 14.10 utopic.How I can upgrade gnome-shell to 3.16 or 3.15 91(on ppa:ricotz/testing repository). Currently I added following ppa repository ppa:...
1
vote
0answers
183 views

problem with upgrade - “packages have been kept back”

one package libgbm1 is not upgraded I dont know why... sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done ...
0
votes
1answer
2k views

How do I upgrade my g++, C++11 features do not work

the following code generates error std::string xyz="whatever"; int x=1; xyz+=std::to_string(x); //this is supposed to turn xyz into whatever1 from whatever Why am I using this approach? Because ...
1
vote
1answer
299 views

Loosing user permissions after upgrading Kubuntu 14.04 to 14.10

Yesterday I've upgraded my Kubuntu 14.04 to 14.10 thinking it would be safe to do so right now. The upgrade proceeded as expected but somehow my user account apparently lost admin rights. If I try to ...
0
votes
1answer
665 views

apt-get: unmet dependencies, but dependencies can't install

I'm in a spot where Ubuntu 12.04 LTS wants to do a dist-upgrade, but I can't do anything because /boot is full. ~$ df -h /dev/sda1 228M 227M 0 100% /boot I want ...