Graphical front-end to apt, the package management system in Ubuntu.

learn more… | top users | synonyms

26
votes
1answer
15k views

Assign highest priority to my local repository

Summary How can I make apt-get prefer local repository packages instead of downloading again the same package version from official repositories? The local repository is signed and trusted. We've ...
7
votes
2answers
2k views

What does 'Lock Version' do?

Having installed an experimental version of dropbox and installed in manually, i dont want the deb in synaptic to download any updates (as theyll over write the changes ive done manually i assume). ...
14
votes
3answers
30k views

How do I add the mainline kernel PPA?

How can I add the mainline kernel ppa to the synaptic software sources? I have the url: http://kernel.ubuntu.com/~kernel-ppa/mainline/ but I am missing the ppa: line.
13
votes
4answers
577 views

How can I get a list of all packages in a repository section from command line?

In Synaptic, one can list packages by section. For example, in the image below all packages of the "Amateur Radio (universe)" section are listed. How can I get such a list (edit: with package ...
1
vote
2answers
2k views

How do I downgrade libglib2? (from glib 2.31 to 2.30?)

EDIT: NEW FORMULATION OF THE QUESTION I have the wrong version of libglib2 installed. I had some experimental repo that broke everything. From this source, https://bugs.launchpad.net/ubuntu/+source/...
16
votes
0answers
6k views

How to find and delete duplicated sources list entries? [duplicate]

Is there a command line to find and delete duplicated entries in the /etc/apt/sources.list file? or is this possible via synaptic perhaps?
5
votes
3answers
3k views

Backup Software Sources

In Ubuntu 10.04, when I goto System > Administration > Software Sources and goto the Authentication tab, I can view all of my keys allowing me to download from third party sources. How would I back ...
13
votes
2answers
8k views

Synaptic Package Manager keeps crashing

Synaptic keeps crashing. When I open it, it asks for the sudo password. I give the password, then the synaptic window flashes for less than a second and then goes away. What's wrong? After seeing ...
5
votes
2answers
8k views

Installing debian package through Synaptic

I want to install a .deb file. After going through various questions, I came across these three options: dpkg, GDebi and Ubuntu Software Center. However, I want to install the. Deb file via Synaptic ...
5
votes
3answers
2k views

Why was the Synaptic package manager removed from Ubuntu 11.10?

I recently tried the new Ubuntu release and when I wanted to change the cache setting of Ubuntu update, I noticed that the Synaptic Package Manager was no longer available. Why? It was one of most ...
3
votes
1answer
323 views

What can I do if Synaptic can't get the latest version of software?

I'm using Synaptic for package management on Ubuntu 12, and am currently trying to get the newest version of SWIG - 2.0.9. My currently installed package swig in Synaptic is version 2.0.7-3ubuntu1. I ...
2
votes
2answers
851 views

sudo apt-get update giving error about duplicate

Getting an error about duplicate sources, how can I get around this?
1
vote
1answer
238 views

Unable to repair packages in ubuntu

I'm unable to repair programs through either use of the terminal or synaptic package manager. I keep getting this message. dpkg: error processing archive /var/cache/apt/archives/kde-config-telepathy-...
27
votes
3answers
7k views

apt-get vs. aptitude .vs synaptic compatibility

As a former Debian user, I "kind of" remember that I should only use one of the package managers... Either apt-get, aptitude, or synaptic, but not the three in combination 'cause there may be ...
2
votes
2answers
2k views

Unable to remove 'residual config' packages in Synaptic Package Manager

I am using 11.04 with Synaptic Package Manager (Ver 0.70). When I select 'Status' and try to delete packages from the 'Not Installed (residual config)' option, although I can select these old ...
12
votes
1answer
850 views

Why don't applications opened as root use global menu?

Why do applications like synaptic (and other that need root privilege) have their menus in the window instead of top panel? Is it going to change or will it stay like that to indicate that user is on ...
8
votes
1answer
2k views

Couldn't find synaptics properties after reboot. No synaptics driver loaded?

Every time I reboot my laptop, my touchpad scrolling stops to work. I assume it's because my synaptics isn't loading as when I try to run synclient. I get the Couldn't find synaptics properties. ...
4
votes
3answers
19k views

how do I downgrade google chrome?

Presumably after an update, google chrome has very serious problems with page rendering. I want to downgrade it. (Switching to vmlinuz.old and initrd.img.old did not help). $ apt-cache policy google-...
7
votes
1answer
27k views

How to open the Synaptic Package Manager in Unity?

I just installed a fresh copy of Ubuntu 11.10. How to open the Synaptic Package Manager?
7
votes
1answer
4k views

How to delete History of installed packages

I need to delete the Synaptic/Software Center history(commit logs). How can I go about doing this?
5
votes
2answers
9k views

How to delete a non-working kernel after update?

I have. a simple question. After I updated my kernel, I couldn't boot (stuck on purple screen) unless I chose the old kernel. So how do I delete the new kernel with synaptic. And how do I do this ...
5
votes
2answers
5k views

How to hold a package back from being upgraded? [duplicate]

Possible Duplicate: How to forbid a specific package to be updated? I don't want my kernel or grub updated until I do it manually. Is this possible in Ubuntu (10.04, I suppose)?
5
votes
2answers
1k views

How to prevent Thunderbird from updating automatically?

today at startup my Tb (not precisely sure what version it was) asked if it should check compatibility of the lightning calendar addon. That is to say it displayed in a list windows the only item: ...
4
votes
1answer
2k views

How to remove latest kernel without removing linux itself

I have found my machine to be unstable with 3.2.0-58. Since starting to run 3.2.0-57 my machine has been much more stable, and I would like to remove 3.2.0.58 from my machine, partly so that I boot ...
2
votes
4answers
1k views

Broken Package error after updating

I updated my system using the Update Manager and now I am getting a Broken Package error. I went into Synaptic Package Manager and clicked on Fix Broken Packages but then I got this error. E: /...
1
vote
1answer
8k views

How do I install missing dependencies on my system?

I was fooling around trying to fix this problem, and I removed some important packages. When I realized that it was cleaning out more things that I had intended, I just rebooted, rather than try to ...
7
votes
4answers
3k views

What does “local or obsolete” mean in Synaptic

In the Synaptic Package Manager there is a category "Installed (local or obsolete)". For whatever reason I have a bunch of packages listed there. As you can see from the screenshot, the packages ...
4
votes
2answers
4k views

Is running Latest Firefox on older versions of Ubuntu possible?

Is running Latest Firefox (ver. 16) on Ubuntu 8.04 possible? If so, what do I need to do to accomplish this? (If I can keep that latest support Firefox 3.6.17 alongside the latest Firefox 16, that's ...
2
votes
2answers
5k views

dpkg returned an error code(1) for libc6:i386 and libtinfo5:i386 while trying to install anything

When I try to install anything through apt-get or synaptic I keep on getting this ... Fetched 23.6 MB in 1min 10s (336 kB/s) debconf: DbDriver "config": /var/...
16
votes
3answers
16k views

How can I install a package without installing its dependencies?

I'm trying to install Alacarte and the dependencies are huge, basically all of GNOME. I know that they are unnecessary. Is there an option in Synaptic or an apt-get flag for this?
12
votes
2answers
617 views

Possible problems in mixed use of apt-get, aptitude and synaptic

Even though aptitude and synaptic are both front-end to the APT (and I myself stick only with apt-get), peculiarities in each of the available dpkg/APT frontends seem to cause problems and confusions ...
8
votes
2answers
68k views

“Dependency is not satisfiable” error when trying to install an application

When I try to install glchess in Synaptic I get this error At a certain time I installed the Gnome desktop and a lot of games that came with it and then uninstalled the games. Now I want chess ...
6
votes
2answers
618 views

Write List of Packages installed via Manual Invocation of apt-get to File

I'm trying to install a new version of Ubuntu from scratch, but I would like a list of the packages which I manually installed (as opposed to installed as a dependency or that came with the system). ...
6
votes
2answers
15k views

Apt/Synaptic needs to reinstall package but can't find the archive for it

Running Synaptic I get the following error message: E: The package hl1440lpr needs to be reinstalled, but I can't find an archive for it. E: Internal error opening cache (1). Please report. Upon ...
5
votes
3answers
1k views

Advanced inertial scrolling configuration

Is it possible configure the synaptic inertial scrolling in a way so it is disrupted when any key is pressed on the keyboard? To explain this question: I often use shortcuts. Now when I am for ...
5
votes
2answers
306 views

How exactly does Synaptic keep track of “New in repository” packages?

Is this info part of APT cache or does it create a separate file to compare with new cache? Where is it stored then?
5
votes
4answers
1k views

Which packages recommended 'Missing Recommends'?

The Synaptic Package Manager has a custom filter "Missing Recommends". Is there a way to find out which packages installed on my system recommended the packages listed in this filter?
2
votes
2answers
1k views

dpkg: error processing linux-headers-3.2.0-35

Whenever I install, update or uninstall a program in the terminal, this comes up sudo apt-get autoremove Reading package lists... Done Building dependency tree Reading state information... ...
5
votes
1answer
2k views

After force-installing a 32-bit deb failed, how can I install the 64-bit version?

I tried to dpkg -i --force-architecture google-earth-stable_i386.deb and it failed. But now when I try to install the amd64.deb it fails saying dpkg: error processing google-earth-...
4
votes
2answers
17k views

How to fix broken repository information?

I have the small red cross icon in my indicator applet, and upon hovering it says that An error occurred while checking for updates. Because of this, I can't edit the selected repositories through ...
4
votes
2answers
1k views

Is there way to Accelerate Package Downloads in slow connections? [duplicate]

Possible Duplicate: Upgrading ubuntu with some thing which can make more than one connection I'm using Ubuntu 11.10 and I want to download all (for a specified installation) packages ...
3
votes
2answers
352 views

Firefox update fails with “not found” error

I got 3 update notifications for firefox: Yet when I click update, it fails with a "not found" error: Any idea why this is? How to fix this?
2
votes
1answer
330 views

Why are (uninstalled) packages listed in the “Local” repository (in Synaptic) after an upgrade?

I just upgraded a computer from 10.10 to 11.04 using the do-release-upgrade command. (This was the first time I've actually done an upgrade.) I had a few PPA's in my setup, which got removed from my ...
2
votes
1answer
315 views

Need to downgrade a package with many dependents

In order to get a working low-power video card setup I decided to use a custom xserver from Andrikos:ppa. It worked well, but when the official release caught up to the bug fixes I dried to drop the ...
2
votes
2answers
9k views

Missing libqt3-mt in 13.04

I have an application that requires the libqt3-mt package, in particular it's asking for libqt-mt.so.3. It worked OK under Ubuntu 12.04, but I've recently upgraded to 13.04 and the package is missing ...
1
vote
2answers
2k views

How can I theme Synaptic Manager?

I use Lubuntu 12.04 and a gtk2 theme, Elegant Arch. With such a theme, gtk2 applications like Thunar will be themed, while others like Nautilus, would be not (see this question ant the images there)....
4
votes
6answers
4k views

How to install postgresql-9.4-postgis-2.1 on Ubuntu 14.04(Trusty Tahr)?

I get the following error when trying to install postgres-9.4-postgis-2.1 on Ubuntu 14.04(Trusty Tahr): Depends: libgdal1 (>= 1.9.0) but it is not installable I also tried to install the package ...
4
votes
4answers
499 views

Why are some Open Office packages marked as “local or obsolete” in Synaptic

This is a follow up to this question: What does “local or obsolete” mean in Synaptic. I have not installed Open Office manually. I doubt that Open Office has been dropped from the repositories. So ...
3
votes
1answer
74 views

is Python available in any Ubuntu installation?

Quite simply: is python already provided in any of the latest installations Ubuntu or does it have to be installed explicitly by the user? Thanks.
2
votes
2answers
95 views

How do you use the Synaptic packege manager for downloading packages?

I new to Ubuntu, and have just installed Synaptic. I want to Know how to use it for downloading packages and and software.Please help.