1
vote
1answer
42 views

'apt-get upgrade' getting stuck

When trying to install updates after checking with sudo apt-get update, sudo-apt get upgrade is not installing them. username@username:~$ sudo apt-get upgrade Reading package lists... Done Building ...
-2
votes
1answer
33 views

Why I cannot download software on Ubuntu?

I have found out that suddenly i am unable to install ANYTHING on my ubuntu distro. Every time I try sudo apt-get install anything i actually get the same error message: ubuntu@ubuntu:~$ sudo ...
0
votes
0answers
8 views

when i input “sudo apt-get update” ,i get an w&&E. I've tried many methods but failed to solve it .Thanks for help me [duplicate]

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/mirrors.oschina.net_ubuntu_dists_saucy-updates_universe_binary-i386_Packages Hash Sum mismatch E: Some index files failed to download. They have ...
0
votes
1answer
65 views

errors while using 'sudo apt-get update'

W: Failed to fetch cdrom://Ubuntu 13.10 _Saucy Salamander_ - Release amd64 (20131016.1)/dists/saucy/restricted/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get ...
0
votes
0answers
35 views

Errors with apt-get update command [duplicate]

When I run a sudo apt-get update command I get these errors: FirstStrike@ubuntu13.04-desktop:~$ sudo apt-get update Hit http://dl.google.com stable Release.gpg Hit http://dl.google.com stable Release ...
0
votes
0answers
85 views

Error installing rails 3.2.14

I get the following error while installing Rails 3.2.14: With sudo apt-get install rails apt 0.8.16~exp12ubuntu10.16 for amd64 compiled on Nov 15 2013 15:33:57 Supported modules: *Ver: Standard .deb ...
0
votes
0answers
19 views

recover data from autoclean

I have used sudo apt-get autoclean command and sudo apt-get clean command but didn't knew that I'll loose all my data. Is there any way to recover that data?
0
votes
2answers
50 views

Error while installing update [duplicate]

I am very new to ubuntu. I have Installed today only. I tried to update software by typing comnmand in Terminal as pranay@Hom-lnx:~$ sudo apt-get update && sudo apt-get upgrade [sudo] ...
0
votes
0answers
59 views

Why I am not able to update my system with sudo apt-get update command? [duplicate]

I am trying to update using sudo apt-get update, but it do download some packages but after some times I get the following errors W: Failed to fetch ...
1
vote
1answer
2k views

apt-get not using http_proxy in ubuntu 13.10

I just updated from Ubuntu 12.04 to 13.10 In 12.04, I used to set up my http_proxy variable in .bashrc and then use apt-get as follows sudo -E apt-get update The -E option in sudo used to make the ...
0
votes
1answer
190 views

get list of all commands run in past with sudo apt-get install in terminal

As per command history in Ubuntu terminal we can see all previous command we run on system. I want to know how can we get all previous command which starts with some words/characters. Example : i ...
-1
votes
1answer
238 views

fatal error: log4cxx/logger.h: No such file or directory

I am getting this error whenever I am compiling my c++ code from command line. fatal error: log4cxx/logger.h: No such file or directory Is there any easy way to download the log4cxx package from the ...
0
votes
2answers
124 views

How does command-not-found determines if user is administrator

I am administrator of two ubuntu servers. On one of them, when I try to run a command (for instance irb1.9.1) from a package that is not installed, I get the following message: The program 'irb1.9.1' ...
4
votes
1answer
537 views

What does this code do if entered in a terminal?

sudo add-apt-repository ppa:langdalepl/gvfs-mtp sudo apt-get update Then, launch Software Updater (previously known as Update Manager) and install the available updates. After you update everything ...
0
votes
1answer
1k views

Trying to update but not enough space on boot (answer here) [duplicate]

The error message I get suggests "sudo apt-get clean" I try running it but nothing happens. Just get back to the prompt. Is there any other terminal commands I should try to clean temporary files ...
0
votes
2answers
453 views

What is the answer to “are you root” when installing packages?

What is the answer to "are you root" in Ubuntu 12.10. I was installing the restricted extras for the 12.10 when I got this message after typing my password. I typed yes and now all I see are y in the ...
0
votes
0answers
24 views

error while trying to run sudo apt-get update [duplicate]

I am using ubuntu 12.04 and am getting error message while try to run sudo apt-get update. This is what I am getting when i run the above mentioned command: failed to fetch ...
0
votes
0answers
568 views

cannot install gnuplot in ubuntu 12.04

whenever I type sudo apt-get install gnuplot I get: Err http://in.archive.ubuntu.com/ubuntu/ precise/universe gnuplot-nox i386 4.4.3-0ubuntu3 Connection failed [IP: 91.189.92.200 80] 0% [Waiting for ...
0
votes
0answers
7 views

sudo apt-get install curl command not installing curl [duplicate]

I'm trying to install curl using the command: sudo apt-get install curl It shows me error saying E: Encountered a section with no Package: header E: Problem with MergeList ...
1
vote
3answers
215 views

Not able to run sudo apt-get update in 12.10

I am trying to run sudo apt-get update but getting below mentioned error .. do you think there is any issue with Ubuntu's installation? E: Could not get lock /var/lib/dpkg/lock - open (11: Resource ...
0
votes
1answer
2k views

Some index files failed to download [duplicate]

When I ran sudo apt-get update then I found some error. The Error is like below: W: Failed to fetch cdrom://Ubuntu 13.04 _Raring Ringtail_ - Release amd64 ...
1
vote
0answers
454 views

Red Triangle with exclamation mark, next to wifi symbol, in ubuntu 13.04

I have a red triangle at top on screen, that says "The update information is outdated. This may be caused by network problems or by a repository that is no longer available. Please update manually ...
0
votes
1answer
129 views

sudo apt-get update leads to crash of terminal application

I try to run sudo apt-get update and the terminal freezes and a message pops up: Ubuntu experienced an internal error... I am trying to work with OpenFOAM and all the times is asking me to update ...
0
votes
1answer
127 views

Error Message while sudo apt-get -f install [duplicate]

Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
2
votes
1answer
2k views

Sudo apt-get update command does not work

I'm trying to install Java onto my Ubuntu 11.10. I've managed to get some repositories from where to download the installer, but whenever it gets to the point of updating the resources (a.k.a. sudo ...
1
vote
1answer
405 views

Can't access GUI mode with Virtual Box fresh 12.04 install

Trying to install 12.04 in virtual box. Install went great after restart I get a white error box talking about my graphics. Basically I get options to look at different log files or I can run without ...
0
votes
1answer
901 views

The package sudo needs to be reinstalled, but I can't find an archive for it

It seems I have landed in trouble.... on running update-manager or synaptic I get this message "E: The package sudo needs to be reinstalled, but I can't find an archive for it." I searched for ...
0
votes
0answers
60 views

Unable to install a program on ubuntu via command line(same for desktop)

Despite the good internet connections I have used in trying to install packages with the famous sudo apt-get install package-name , it is not possible. Whenever I download any file form the network, ...
0
votes
0answers
293 views

getting error Resource temporarily unavailable [duplicate]

E: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable) no matter what i try to install i get this error, also i get unity & unity 2d not installed so if ...
1
vote
0answers
2k views

How can I run Sublime as a normal user? [closed]

I've installed Sublime Text using this method and the installation seems to have went through just fine. However, I can't seem to run sublime as a normal user. I can only get it to run when I run it ...
4
votes
1answer
2k views

apt-get could not open lock file

I am trying to get an nfs client running on a Sheeva-plug running debian 2.6.22. The host is Ubuntu 12.04 and claims (from showmount -e) to be exporting the desired directory. There is no showmount ...
2
votes
1answer
135 views

My system is broken I guess — issues with libqt4-test

So here's the problem, every time I try to install a package, I receive an error that says: Reading package lists... Done Building dependency tree Reading state information... Done You might ...
0
votes
2answers
275 views

Problem with the “sudo apt-get update” command

I'm a beginner when it comes to the Linux environment. I recently tried to install some extensions in Linux. I've entered some commands like: sudo apt-get install gnome-tweak-tool and then when I ...
0
votes
1answer
853 views

Problem bash completion apt-get 12.10

I've got an annoying problem with completion and sudo apt-get. To give an example: $ sudo apt-get in[Tab][Tab] in intel_bios_reader includeres ...
3
votes
1answer
1k views

How to install Git on Ubuntu? [duplicate]

When I run this command: apt-get install git-core It shows: E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable to lock the administration directory ...
1
vote
0answers
53 views

How to upgrade 12.10 beta 2 version to 12.10 final release [duplicate]

Possible Duplicate: How to verify I have updated from Ubuntu 11 beta to stable? I want to upgrade 12.10 beta 2 version to final release of ubuntu 12.10 eagerly waiting. Pls do help me.
1
vote
1answer
195 views

Wrong autocompletion with sudo apt-get

Does anybody know why if I type: apt-get upg<TAB> I get: apt-get upgrade but if I type: sudo apt-get upg<TAB> I get: sudo apt-get upgrade-from-grub-legacy
2
votes
2answers
3k views

“Unable to connect” error with apt-get: possible proxy?

I've been having an issue with 'sudo apt-get update' for several days now. I've tried every proposed solution I could find but to no avail. Here is the output to 'apt-get update'. Ign ...
5
votes
5answers
8k views

How do I fix a “E: The method driver /usr/lib/apt/methods/http could not be found.” error?

I tried updating my packages from the terminal and this is what I got: $ sudo apt-get update E: The method driver /usr/lib/apt/methods/http could not be found. E: The method driver ...
1
vote
2answers
459 views

Installing ZFS changed my sudoers file

Following the wiki's advice, I installed ubuntu-zfs. However, once everything installed correctly, and I tried installing another application via apt-get, I get a weird issue with my sudoers file: ...
1
vote
3answers
273 views

Can I automate updating/upgrading with sudo in this way?

Please consider this code: alias fast='echo "password" | sudo -S apt-get update && sudo -S apt-get upgrade' I have not yet had a problem using it but is it possible that if the first step, ...
1
vote
1answer
2k views

Installing gcc in Ubuntu 11.10

I want to install gcc on my computer. To do this, I ran the following command: sudo apt-get install build-essential As this runs, it connects (or tries to connect) to the server ...
0
votes
2answers
108 views

Help with installing sudo apts

Any time I use Alt+F2 to open command line and I type a command such as: sudo apt-get install clamav clamtk I click on it and it doesn't do anything. Am I not supposed to click on the icon that ...
2
votes
2answers
758 views

enable auto-completion of apt-get for non-privileged user?

I've enabled apt-get in SUDO without password , and bash autocompletion for it need to be enabled as well , but how ? If i try to source that file: %> . /etc/bash_completion.d/apt No command ...
12
votes
1answer
13k views

What exactly does sudo apt-get -f install do?

I have seen it before. I am just wondering what exactly does it do?
4
votes
2answers
2k views

Problem installing ruby and gems

I just installed ruby using apt-get with the following command: sudo apt-get install ruby1.9.1-full But when I try to do sudo gem install ... it says that I have not installed gems and that I shoud ...