1
vote
2answers
81 views

Fixing nginx 1.4.6 dependency on old openssl version (libssl0.9.8)?

I'm trying to enable TLSv1.1 & TLSv1.2 on my Ubuntu 12.04 EC2 instance w/ nginx 1.4.6, but this version of nginx is dependent upon libssl0.9.8, even though the newest version of OpenSSL is ...
0
votes
1answer
127 views

what is the nginx equivalent command apache has for a2enmod?

I'm following this guide: How to Setup OwnCloud Server 5 with SSL Connection Problem though is that the guide is for apache but I am using nginx for my server. As such I am trying to "reverse ...
0
votes
2answers
629 views

hiphop, nginx, spdy

I'm about a month young at linux and brand new to ubuntu. I can do this to install hiphop https://github.com/facebook/hiphop-php/wiki/Building-and-installing-HHVM-on-Ubuntu-12.04 (I installed ...
2
votes
1answer
1k views

Nginx with SSL package

I'm trying to install nginx using the package manager. Usually I'd do this: sudo apt-get install nginx but I need nginx to have SSL support. I could compile nginx from source with SSL support, but ...
3
votes
2answers
2k views

Can I use nginx and GnuTLS together?

I read that nginx works with OpenSSL. But since GnuTLS is the only software that provides TLS 1.2 support, it would be useful to combine that. So, how can I compile nginx with GnuTLS on Ubuntu? =)