For questions, issues related to shared libraries, .so files and its manipulation in Ubuntu

learn more… | top users | synonyms

13
votes
5answers
30k views

Error While Loading Shared Libraries (libGLU.so.1)

I am trying to run Chamsys MagicQ on Ubuntu 12.10 with 64bit AMD processor. This is what it tells me when I try to run the program. ./magicq: error while loading shared libraries: libGLU.so.1: ...
0
votes
0answers
8 views

OpenCV using Code::Blocks, shared library errors

I've installed openCV and followed these steps to configure my Code::Blocks. I am getting these errors: By the way: I've tried ldconfig and creating a opencv.conf file through this.
0
votes
1answer
22 views

apt-get not work and putty not connect

When I want to login to ssh by putty show me this errors: Connection refused and when I connect to Ubuntu via VNC when I login I see this errors: apt-config: error while loading shared libraries: ...
2
votes
2answers
9k views

/usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.19' not found

I'm building a program in a VM then deploying to another machine. This has been working for some time. Today I've started receiving this error message when I attempt to execute my program: ...
0
votes
0answers
14 views

Mupen64plus not dlopen() ing mupen64plus-video-glide64mk2.so

I am running Lubuntu 15.10 on my machine currently and happen to notice something strange happening with a Mupen64Plus graphics plugin. Upon running the program, I get a strange error message ...
3
votes
1answer
30k views

How to install library files

I installed skype translting software CLOWN FISH in linux(ubuntu 14.04 LTS). But it was not working properly. In the clown fish website they have specified required library files for the proper ...
1
vote
0answers
17 views

Export functions of a library? [closed]

So, I want to make a clone of a library(libc for the matter, but I would like to apply this elsewhere), and I'd like to know method signatures for LD_PRELOADing, or if I make a complete wrapper for ...
3
votes
1answer
983 views

libMagicWand.so.5 cannot open shared object file?

After update to version Ubuntu 15.04 I have problems when I try to run emacs. emacs: error while loading shared libraries: libMagicWand.so.5: cannot open shared object file: No such file or ...
3
votes
4answers
2k views

How to install Xaw package with header files?

I'm having this error on Ubuntu 14.04: checking for X... libraries , headers /usr/include/X11/ configure: error: Cannot find required Xaw header file Box.h; PDCurses cannot be configured How can I ...
53
votes
15answers
142k views

How do I resolve a “Cannot open shared object file libudev.so.0” error?

Trying to run Game Dev Tycoon on Ubuntu 64. It asks for the above object. I ran sudo apt-get install libudev1:i386 and it came back already installed. I have /lib/i386-linux-gnu/libudev.so.1 but no ...
1
vote
3answers
3k views

Unable to start sublime text

I had been using Sublime Text 2 with no issues. I installed IDLE and now I'm unable to start Sublime Text. I tried uninstalling IDLE, but Sublime Text is still not starting. Here's the error: Unable ...
0
votes
0answers
19 views

How to remove libglew1.10 without killing ubuntu desktop

I am on Ubuntu 14.04. If I do sudo apt-get remove libglew1.10 ubuntu-desktop and unity will be removed, I accidentally do it once and I had to go to recovery mode to reinstall everything back. I ...
10
votes
4answers
23k views

error while loading shared libraries libSDL-1.2.so.0

I am trying to install ioquake on my ubuntu server. When I try to run it, I get this message: # ./ioquake3 ./ioquake3.x86_64: error while loading shared libraries: libSDL-1.2.so.0: cannot open ...
0
votes
1answer
114 views

Installing 32bit app on 64bit Ubuntu 15.10

I tried to install 32bit linux app (Cadsoft Eagle) on 64bit Ubuntu 15.10 via terminal. This was the result: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No ...
10
votes
4answers
50k views

libssl.so.10: cannot open shared object file: No such file or directory

Im trying to use twoBitToFa, which is a small program released by the University of California Santa Cruz, that uncompresses large genome files and I get this error: error while loading shared ...
1
vote
1answer
66 views

Portable Batch System

I am working in a server (I am not the admin) where I must run jobs in .pbs format so I can disconnect my computer while a job is running. The problem is that I cannot run in .pbs format the same ...
1
vote
0answers
71 views

squeak: could not find any display driver

I am building the vm for squeak on Ubuntu 14.04 32-bit. It is failing to call entry points to libraries, whether these libraries are statically linked or loaded or not loaded. I have been doing some ...
0
votes
1answer
72 views

Cannot run cmake from QtCreator [duplicate]

QtCreator shows me this error message and asks me to browse for and select a cmake executable: /usr/bin/cmake: error while loading shared libraries: libgssapi_krb5.so.2: cannot open shared object ...
4
votes
3answers
4k views

liblapack.so file

I want to run a matlab code in ubuntu 12.04 in which error is coming that liblapack.so shared library file is missing. How to get this file installed and from where can I get this file.Please help me ...
0
votes
0answers
287 views

“gl31.h not found, please install gl31.h” but libgles2-mesa-dev includes it

I recently changed my OS to Ubuntu to use some open source based on GCC compiler. However, after installing NVIDIA Cuda 7 and compiling Cuda 7 sample, I got this warning message: WARNING - ...
1
vote
1answer
26 views

when I use matlab command , matlab does not open rather it shows this error

When I use the matlab command, matlab does not open but it shows this error: What is the problem and how can I fix it?
0
votes
1answer
168 views

Error while loading shared library libz.so.1 while cross compiling for arm-linux

I'm trying to cross compile an opencv app on Ubuntu 14.04 to run on an ARM core. I can compile the open cv app fine on Ubuntu with g++ test.c -o test -I /usr/include/opencv -I /usr/include/opencv2 -L ...
1
vote
1answer
472 views

libpng16.so.16 not found - how to get it?

I have recently attempted to install mupen64plus on my Lubuntu machine. After doing this command: sudo apt-get install mupen64plus the install proceeds without error and everything sets up ok. But ...
0
votes
1answer
37 views

Why/How is it possible to copy 32 bit librarys form Ubuntu to an ARM machine?

This is not too ubuntu specific but kind of. I wanted to setup a dedicated game server for Don't Starve together which is only avaiable in 32 bit. I installed it on ubuntu and it worked perfectly ...
0
votes
1answer
80 views

shared lib libmp.so.3 not found

I am trying to run the software Synopsys-Sentaurus on x64 machine with Ubuntu 15. I get the error "unable to open shared lib libmp.so.3..." the libg gmp seems to be installed. Any help is welcome, ...
0
votes
0answers
38 views

cannot start freefilesycn after update to version 7.6

I updated my FreeFileSync-installation recently to version 7.6. After doing this I'm not able to start FFS anymore with this error ./FreeFileSync: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version ...
13
votes
3answers
36k views

GLIBCXX_3.4.20 not found, how to fix this error?

Whey I try to run the program Layout Editor (available on this site) on Ubuntu 14.04.1 64-bit LTS I get the following output in the terminal: $ layout layout: ...
1
vote
2answers
2k views

Witcher 2 missing library libgtk-x11-2.0.so.0

The events that led to this situation are as follows: I tried to run The Wither 2 on Linux from GoG.com and installed the dependencies (http://www.gog.com/game/the_witcher_2) using aptitude. I ...
3
votes
1answer
320 views

R package is not loading in 15.10

I have upgraded to Ubuntu 15.10 (64 bit). Now, I tried to run R package from the command line, it gives the error message as /usr/local/lib/R/bin/exec/R: error while loading shared libraries: ...
1
vote
1answer
87 views

Calibre cannot load ImageMagick since upgrade to Vivid Vervet

I just upgraded to Ubuntu 15.04 and now Calibre won't work. File "/usr/lib/calibre/calibre/utils/magick/__init__.py", line 15, in <module> raise RuntimeError('Failed to load ImageMagick: ...
1
vote
1answer
45 views

SSH - after login: wrong elf class

I'm running Ubuntu 14.04. When I login on a remote machine using SSH. The login works, but I can't execute any commands. I always receive this error mesesage: ssh: error while loading shared ...
4
votes
4answers
36k views

How do I install libtiff.so.3?

I installed Maya 2011 on Ubuntu 10.04 many times and it was always working, Recently i upgraded my Ubuntu from 10.04 to 11.04, and when i tried to install Maya 2011 on it i wasn’t able to get it ...
0
votes
3answers
2k views

libpython2.6.so.1.0 doesn't exist

I am trying to run an application called powerpc-eabi-gdb, however, when I start it, I get the following error: error while loading shared libraries: libpython2.6.so.1.0: cannot open shared object ...
1
vote
2answers
4k views

peazip: error while loading shared libraries: libX11.so.6

I'm trying to get peazip running but I'm facing some trouble. When I run peazip I get the error: peazip: error while loading shared libraries: libX11.so.6: cannot open shared object file: No such ...
3
votes
1answer
104 views

AC3D - No such file or directory

I just downloaded AC3D and extracted the zip in a folder in my home folder. I opened a terminal, CD'd to the folder and typed ./ac3d. But I get the following error message every time: bash: ./ac3d: ...
2
votes
2answers
3k views

Packet Tracer 6.0.1 - problem with running (error while loading shared libraries: libQtScriptTools.so.4: …)

I have installed smoothly PTR 6.0.1 according to this site (How do I run Cisco Packet Tracer 6.0.1?), but when I want to run it this error appears: PacketTracer6: error while loading shared ...
51
votes
8answers
104k views

Problems with Eclipse and Android SDK

I installed Eclipse, openjdk6 and downloaded and extracted the sdk manager file. Now, When I created an Android project I got the following error: 2012-06-06 18:44:40 - contactManager] ...
10
votes
3answers
592 views

Is there any open-source way to make a static from a dynamic executable with no source code availability?

Let me explain the problem with an example. I use some old program in my day to day work, like for example xfig and pdfedit. Now, these programs are quite old and not updated too often; my fear is ...
1
vote
0answers
271 views

Installing a software changed the path to shared libraries

I have a limited knowledge of how linux works but I will try to explain my problem as clearly as possible. I recently tried to install wallch on Ubuntu 15.04 but I wasn't able to start it. When ...
0
votes
0answers
16 views

How to force library search path for an application (Not entire system)?

How could I override the library search path for an application? For example: I hope MyApplicantion to search libraries only from /usr/lib/mylib
0
votes
1answer
307 views

How to Fix error related to libicudata.so

I'm getting following error when invoking a binary file from command line: error while loading shared libraries: libicudata.so.55: cannot open shared object file: No such file or directory I tried ...
0
votes
0answers
58 views

faketime ld.so ERROR

I am receiving the following error when running faketime: ERROR: ld.so: object '/usr/$LIB/faketime/libfaketime.so.1' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored. I ...
5
votes
1answer
231 views

Bash script doesn't run from nautilus, but does run from terminal

Before I add more detail to my question, I have to say something very important: Yes my script has "Allow executing file as program" turned on The question itself: For programming reasons (shared ...
0
votes
1answer
58 views

pthread_kill(0,0) crashes

This is my first question here (as you can probably tell from the poor formatting of GDB's output below :^}, and this may not be the right forum ??... Using Ubuntu 14.04, calling pthread_kill(0,0) ...
0
votes
0answers
35 views

Where is libgtkhtml-2.so.0

I'm trying to run the program xtrkcad (for model railroading) and my attempt to run it runs into a missing library file libgtkhtml-2.so.0. Where can I find it?
2
votes
0answers
168 views

Error installing Steam on 14.04.03 (missing 32-bit libraries)

I have the Steam Launcher installed (installed via Software Center), when double-clicking the launcher the following is executed in the command window: Steam needs to install these additional ...
1
vote
1answer
2k views

Can't run Second life firestorm viewer (32bit) in ubuntu 64 bit

I'm trying to install a Second Life client called Phoenix Viewer. On the first attempt, I got a message about X errors. I searched the net all I could see to fix 32 bit apps and run them under 64 ...
2
votes
1answer
258 views

add path directories for boost installation

I have installed boost_1.58_0 on my loptop's home directory. After some processes I faced to this message: The following directory should be added to compiler include paths: ...
2
votes
1answer
189 views

installing the newest LittleCMS library in 14.04

I use the rawtherapee package and the latest release requires the latest version LCMS2.7 . I found the code here. Shall I use it (if yes how?) or is there any other way?
1
vote
1answer
89 views

Unable to import gmpy

I am a beginner with ubuntu and python. As I try to import gmpy, I get the following error: import gmpy Traceback (most recent call last): File "<stdin>", line 1, in <module> ...