For questions, issues related to shared libraries, .so files and its manipulation in Ubuntu

learn more… | top users | synonyms

3
votes
1answer
2k views

What package provides -llua for g++?

I've installed all lua5.1 development packages from Synaptic and the g++ linker can not find -llua. I've read on some other question that it is possible that -llua has some other name and that I ...
3
votes
2answers
218 views

please help me understand libraries/includes

I'm trying to understand how libraries work. for example I downloaded a tarball and extracted it. Now I do "./configure", it searches in pre-defined directories from what I understand for certain ...
3
votes
4answers
28k views

How do I install libtiff.so.3?

I installed Maya 2011 on Ubuntu 10.04 many times and it was always working, Recently i upgraded my Ubuntu from 10.04 to 11.04, and when i tried to install Maya 2011 on it i wasn’t able to get it ...
2
votes
1answer
789 views

err: file '/lib/libgcc_s.so.1' not found

I'm running 32bit ubuntu in a virtual machine inside vmplayer. That file simply doesn't exist, what do I do?
2
votes
2answers
4k views

Compiling library from source code, how to overwrite current package?

So here's the short story. I wanted to compile the latest Transmission client from source but in order to do that I needed the libevent-2 library which is not available from Ubuntu 10.04's ...
2
votes
1answer
3k views

Why do I need lib64 on my 32 bit machine?

I am trying to install Oracle on my 32-bit machine that runs Ubuntu 10.4. I am following install Oracle on Ubuntu tutorial. At the very first step there is a requirement to manually install library ...
3
votes
1answer
8k views

error while loading shared libraries, file too short

From one of my customers I got an application. When I try to run it I got following error error while loading shared libraries: ./libvtkWidgets.so.5.4: file too short In my project structure I see ...
1
vote
0answers
2k views

How to resolve “error loading libxml2.so.2” when installing Cisco AnyConnect VPN? [duplicate]

I'm trying to install Cisco AnyConnect VPN Client on Maverick 64-bit. I'm getting the following errors: Installing Cisco AnyConnect VPN Client ... Removing previous installation... ...
1
vote
0answers
577 views

Cx_freeze - How can I Install the shared libraries to /usr/lib [closed]

I am using cx_freeze to compile my python script and when I compile the program, all the files are placed in one specified folder. The executable wont run if the shared libs are not within the same ...
1
vote
1answer
76 views

Issue with compiling OpenSludge

I've tried compiling an adventure game sdk called OpenSludge (http://sourceforge.net/projects/opensludge/). I can compile everything okay include libalure through git (openal library). But whenever I ...
4
votes
1answer
329 views

Help compiling (need old libs)

I need to get a scientific software running but it requires older libs and I don't want to screw my current system. I thought about using an old ubuntu version in a VM. But which would I need? The ...
4
votes
3answers
2k views

libunrar.so not found

I'm having trouble installing libunrar.so. It's required for Calibre to convert CBR files. Anyone an idea on where to get it (package or source)?
1
vote
2answers
992 views

How to get .so file to show up in package?

As many of you know by now, I'm building a package :) I am so close to getting it finished so I can upload it to my PPA, but there is still one slight problem: the shared library (.so file) doesn't ...