1
vote
2answers
36 views

What lines should be commented out in my sources.list file?

I have just updated from Ubuntu 12.04 to 14.04 last weekend. I haven't downloaded any extra programs as of yet. I checked my sources.list file and it has the following lines in it: deb ...
-1
votes
1answer
19 views

How to accept only essential security updates?

sometimes i am getting problem in software updates. So i would like to get only essential security updates and also need to make it as default. Please let me know is there any way to sort out that?
1
vote
0answers
12 views

How are security updates classified into low/med/high?

When an update becomes available for a particular piece of software, if I run aptitude changelog <name> I will see urgency as either low, medium or high. How is it decided which ...
0
votes
0answers
15 views

Are Ubuntu upgrades signed or encrypted?

When you download updates from the standard Software Updater (which I'm assuming is just a graphical front-end for apt), are these updates signed or encrypted between the server and the user, or are ...
0
votes
1answer
21 views

Why is each security update file size so large?

The 'Software Updater' just asked me to download a security update which has a filesize of 62MB. And these updates are quite frequent. My questions are: Why are they this big, if, by the frequency ...
0
votes
1answer
90 views

“Your Java version is out of date.” on Ubuntu 2014.04

With fully updated Ubuntu 2014.04, Firefox tells me: Your Java version is out of date. How to update Java? Typing java -version in a terminal tells me: java version "1.7.0_51" Java(TM) SE ...
0
votes
2answers
306 views

When will Flash Player 11.2.202.356 security update will be available

Adobe Systems released emergency security updates for Flash Player in order to fix a vulnerability that has been exploited in attacks against users since earlier this month. Software center provides ...
4
votes
1answer
403 views

Is having Lubuntu 12.04 a security risk?

I have a computer with Lubuntu 12.04 installed. Since unlike Ubuntu 12.04 Lubuntu is not LTS, I will not get Lubuntu updates. However, I am still getting updates (I guess these are the general Ubuntu ...
0
votes
0answers
17 views

Are Key files for repositories fetched over HTTPS?

I'm connecting to the internet through a public internet connection. I want to know if some one can do a MITM attack and give wrong Keyfiles when I update and upgrade. The difference here would be ...
0
votes
1answer
155 views

is adobe flash player plugin installer marked as “important security update”?

Why is adobe flash player plugin installer marked as "important security update"? Is security really compromised if one does not install that?
0
votes
1answer
81 views

Why Ubuntu doesn't upgrade to the latest version of GnuPG?

Two days ago GnuPG announced the release of a new stable version. The new version is 1.4.16 but the repository of Ubuntu Saucy have 1.4.14. I don't understand this because the new release cover a ...
1
vote
0answers
32 views

Does the “security” repository provides anything not found in the “updates” repository?

For the limited number of package I looked at (e.g. apache), I found that the package version in the updates repository is always newer than or equal to the version available in the security ...
1
vote
1answer
101 views

Are all “Important security updates”, updates to already installed packages?

I'm running 12.04, and I've never downloaded any drivers for the installation of any peripheral devices. Yet, I noticed a fair few "Important security updates" involving drivers/utilities for HP ...
1
vote
0answers
47 views

sudo apt-get update stuck at 100% [Waiting for headers]? [duplicate]

Here is the sample Hit http://security.ubuntu.com raring-security/main Translation-en Hit http://security.ubuntu.com raring-security/multiverse Translation-en Hit ...
1
vote
3answers
64 views

What are CVE security updates and who issues them?

Just a couple quick questions. Hope a couple wise owls might be able to answer ; ) I used to apply updates through the terminal without any care, since I don't use any ppa's or use any untrusted ...
7
votes
2answers
282 views

Security updates for the universe repository for LTS releases?

What happens if there is a security problem in a package in the universe repository four years after the 12.04 LTS release; will the package be updated from upstream, patched, or left alone? It's my ...
5
votes
1answer
6k views

How to enable auto security update in Ubuntu 12.04 Server [duplicate]

When I installed the Ubuntu 12.04 Server in my VM, I chose to manually update security. My question is how can I enable it again? I know there are other packages that do auto update, but I'm just ...
3
votes
1answer
319 views

How is Software updater installing updates without my password? [duplicate]

I've noticed Software updater in 12.10 installs updates without asking for my password the way it used to. My question is, how is it doing this and what is to prevent a malicious script/program ...
0
votes
2answers
4k views

apt-get update error using automatic proxy configuration

I am using Ubuntu 10.4.04 LTS with in VMware5. I used automatic proxy configuration and I'm able to use internet from firefox. When I wanted to update apt-get update, I am getting following errors. ...
4
votes
1answer
291 views

How to make my server email me when there are security updates?

There's obviously a way to check to see when an update is a security update. I often get greeted by a motd that says "there are N security updates." What I'd like to do is have my server email me a ...
0
votes
1answer
68 views

Get Security Updates Delta, and install them

I am writing a script that is supposed to run every day to check if there are any new security updates for Ubuntu. If there are, it will make a list of those updates, it will download them, and then ...
6
votes
2answers
224 views

How can I be sure that the updated packages are not compromised?

When trying to install tmux I get an error that Untrusted packages could compromise your system's security, similar to the situation in this thread. I ran aptitude update and the package installed ...
4
votes
1answer
119 views

How do I ensure that security updates are installed on Juju machines?

It seems that security updates and other package updates are not automatically installed in Juju nodes. I assume that they are installed at installation of new Juju machines, or that the installation ...
4
votes
3answers
254 views

Will this sudo rule allow a user to update the system and nothing more?

I want to design a sudo rule that will allow the user ricardo to update the system using aptitude, but prevent him from using sudo to run any other command (he's a problem user). Are there any ...
1
vote
1answer
76 views

Isn't open-source a two-edge sword? [duplicate]

Possible Duplicate: Wouldn’t writing an open source program make it available for anyone to freely hack and exploit, thus making it less secure? I know that ubuntu is an open source OS, ...
2
votes
1answer
263 views

Will Adobe Reader 9.5.3 be offered in partner repository?

Will there be an Ubuntu package in the Canonical Partner repository for the security update Adobe Reader 9.5.3? ...
8
votes
2answers
330 views

How do I get security updates for restricted/partner packages?

I want to perform just security updates on Ubuntu 12.04 LTS, keeping the rest of the system unchanged. I need to do this from the command line, no the GUI update manager. I have implemented the ...
2
votes
4answers
1k views

Is this fix for Avast Antivirus crashing safe to use?

Well I have installed avast anti virus on Ubuntu 12.04. But after updating, it crashes! So I have made some tweaks like below: Press Ctrl+Alt+T to open the Terminal. When it opens, run the command ...
0
votes
0answers
38 views

Why does my Ubuntu 12.04 install not pull this security update? [duplicate]

Possible Duplicate: Update Manager Not working Fail to Download Repository Information I have installed Ubuntu 12.04 about a week ago and it is not letting me receive security updates. It ...
0
votes
1answer
58 views

Why does a custom PPA offers to update gnome keyring?

I installed this PPA only to add some control panel widget. But it suggests some updates I don't expect from it. Is this safe to install?
2
votes
2answers
272 views

Ubuntu/Kubuntu LTS: longer support for server packages

I read that Ubuntu 10.04 LTS Desktop is supported till April 2013, but Server is supported till April 2015. If I install Ubuntu LTS Desktop, will the server packages of the system still be updated ...
7
votes
2answers
1k views

What is a security update?

Why are some updates called Important security updates? How are they different from other updates? Is my system insecure, If I don't install them? How can there be very frequent security updates? ...
6
votes
3answers
579 views

Updating a mysql production server without having problems

I have a mysql server, ubuntu server 10.04. It works great and we're really happy about it. Time for updates has come and I am sincerely scared: can I do a sudo apt-get dist-upgrade with light heart? ...
7
votes
2answers
283 views

Are there alternatives after the official support time stops?

I'm currently running Ubuntu 8.10 on a system. It works very good but I did a lot of tuning (it's a server) to get it working. I'm aware that I need to upgrade to a new LTS version of Ubuntu if I have ...
12
votes
4answers
441 views

Where are release notes from security updates that were installed in the background?

My Update Manager is set up to download and release security updates silently in the background. Therefore release notes are no longer displayed. I wonder if there is a way to read the release notes ...
4
votes
2answers
188 views

What's the best way to automatically apply server updates?

What's the best way to automatically apply security updates? Or any updates for that matter?
90
votes
6answers
58k views

How can I install just security updates from the command line?

sudo apt-get upgrade installs all updates, not just security updates. I know that I can use Update Manager to select only important security updates, but is there a way to do this from the command ...