A dynamic, open source programming language with a focus on simplicity and productivity. (quote: ruby-lang.org)

learn more… | top users | synonyms

3
votes
1answer
162 views

How to autorun a ruby script in Ubuntu?

How hard can it possibly be to run a ruby script on startup?! Fairly tough apparently: I'm using rvm and running ruby 2.3.0. which ruby returns /home/ubuntu/.rvm/rubies/ruby-2.3.0/bin/ruby The ...
2
votes
1answer
271 views

How to make a Openbox dockapp with GTK?

I'm using Openbox and I want to make a dock-app (NOTE: not a dock like plank/docky but a dock-app like stalonetray or lal) in GTK+. How do I get the simple app I have written to sit in the dock area? ...
1
vote
1answer
421 views

I want to install vim with ruby support on Ubuntu 15.04 vivid vervet

I have installed Ubuntu 15.04 and am trying to set up my Ruby on Rails environment to program. I use vim as the IDE and it comes pre-installed without ruby support: vim --version | grep -i ruby ...
1
vote
1answer
111 views

Gnome Tab not recognizing Rails anymore using ubuntu 14.04

I am having a strange issue , my main terminal is recognizing the RVM , Ruby and runs Rails command as well , and I had two tabs opened yesterday which were recognizing all of the commands . Today ...
1
vote
1answer
655 views

How to install postgressql-server

For ruby development on Heroku I need to use postgresql, but when I do bundle install I see this message: You need to install postgresql-server-dev-X.Y for building a server-side extension or libpq-...
1
vote
1answer
199 views

Gsl ruby gem on Ubuntu Saucy (13.10)

I'm trying to install the gsl gem on Ubuntu Saucy I installed the relevant gsl packages with sudo apt-get install gsl-bin libgsl0-dev But then installing the gem fails In file included from /usr/...
1
vote
1answer
857 views

Successfully installed SASS, but the terminal insists it isn't

I wanted to install sass version 3.2.0 alpha. I first ran sudo apt-get install libhaml-ruby1.8, which is what the console recommended It successfully installed, but it installed an older version ...
0
votes
1answer
20 views

Ubuntu-touch ruby / rails development: installing with rvm

I have a Bq10 tablet running Ubuntu-touch OTA-11. I want to be able to work with Ruby and rails apps. Usually I use rvm for this. Is it possible to install rvm [or something similiar] using ubuntu-...
3
votes
0answers
2k views

Problem with installing rvm

I try to install rvm on Ubuntu 14.04. $ \curl -L https://get.rvm.io | bash -s stable --ruby % Total % Received % Xferd Average Speed Time Time Time Current ...
3
votes
0answers
2k views

Install compass 1 pre fails

I can not install compass version 1. $ ruby -v ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-linux] And when I do: $ sudo gem install compass --pre I get following error: Building native ...
3
votes
0answers
2k views

Failed to install a ruby gem, eventmachine

I attempts to run a script that prompt Could not find gem 'eventmachine (= 0.12.10) ruby' in the gems available on this machine. Run bundle install to install missing gems. Then I runs ...
2
votes
0answers
46 views

Any way to catch the notifications so another program can read them?

I know you can see notifications in the terminal using dbus-monitor "interface='org.freedesktop.Notifications'" | grep --line-buffered "string", but is there any easy way to catch the notifications ...
2
votes
0answers
64 views

Termial not accepting options

I'm using Ubuntu 14.10, and for some reason the terminal command will not accept options. (I believe these are called option, please correct me if I am wrong). For example, when installing a new ...
2
votes
0answers
153 views

Ruby's ri not working - 'Marshall data too short'

I'm running Lubuntu 13.10, I installed Ruby (1.9.3p194), Gems(1.8.23), ri(4.1.1), rdoc and some gems (Rails, RSpec, haml...) from the apt-get repository. When I try to run ri, it gives me the ...
1
vote
0answers
71 views

Unable to install Github-Pages with gem?

I've been trying to install github-pages using gem. I have Ruby v. 2.1.2: ✦ ruby -v ruby 2.1.2p95 (2014-05-08 revision 45877) [x86_64-linux] I installed Ruby using RVM and I've set 2.1.2 as my ...
1
vote
0answers
32 views

Upstart Ruby version issue

I am trying to get Upstart to fire up Sidekiq (https://github.com/mperham/sidekiq/wiki/Deploying-to-Ubuntu). I can manually start it but the same command fails in the Upstart script. I have piped ...
1
vote
0answers
88 views

Making ruby script into .exe

Is there a way to make a windows executable from a ruby script on Ubuntu ? I've tried to achive that with ocra gem but I constantly getting this error : /home/use/.rvm/gems/ruby-2.1.6/gems/ocra-1.3....
1
vote
0answers
59 views

Postgres server start fails - WANTED: netstat -ant|grep 5432 output explanation

INFO: I'm working on a Ruby on Rails app. Hosting on Heroku with postgres. Tried running "heroku run rake db:migrate" as usual, but getting error "cannot connect,... check if something else is already ...
1
vote
0answers
1k views

Problems Installing Metasploit Framework on Ubuntu

I have encountered 3 problems while following this guide to installing Metasploit Framework on Ubuntu and Debian: 1) After installing proper version of ruby, there is a command given for installing ...
1
vote
0answers
20 views

12.04 — ruby1.8 missing dependencies

I just built a new 12.04 ubuntu box and tried to install puppet package. This failed because it could not load ruby1.8. After some fiddling around I tracked the issue down to the fact that the ...
1
vote
0answers
57 views

rack server won't start

I am a beginner to ruby and rack ; trying to start a rack server and the rackup config.ru command does nothing. right now my rackup file is #!/usr/bin/env ruby require "rack" Rack::Server.start ...
1
vote
0answers
193 views

Confusion for mime files: magic, magic.mgc, magic.mime

I'm using Ubuntu. I'm trying to use ruby gem 'shared-mime-info' for an application I'm writing. I understand that magic.mgc is a compiled version of magic file which has magic number definitions for ...
1
vote
0answers
343 views

Error installing rvm on Ubuntu 12.04

I'm taking a web applications development course on Coursera that requires me to install Ruby and Rails. I'm following the instructions at https://class.coursera.org/webapplications-002/forum/thread?...
1
vote
0answers
171 views

Dotdeb alternatives for Ruby or Python?

I really like Dotdeb, but it doesn't include packages for Ruby and Python. While I could build my own repository, I wouldn't want to reinvent the wheel (and then be forced to drive). Are there any ...
0
votes
0answers
9 views

Understanding Ruby Setup with bundler “bundle install” as non root

I received a ruby source code + dependencies and db. The code is about 3 years old and running on an 12.04 Ubuntu. Now I am trying to make a fresh setup on 14.04. I installed a lamp stack and wanted ...
0
votes
0answers
66 views

installing for Chromebook converted to Linux?

I just got Linux on my Chromebook. for now, Chromebook is my only option to use Linux as my desktop is out of commission. I started using The Odin Project, and I need a bunch of things on my ...
0
votes
0answers
232 views

Can't install json 1.8.1

I'm trying to install json gem using ruby 2.2.3 (I've tried with other oversions), and I always get the same error: Fetching: json-1.8.1.gem (100%) Building native extensions. This could take a ...
0
votes
0answers
25 views

Any harm of doing 'Run command as login shell'

I've installed RVM and everytime I execute rvm use <version>, terminal complains me that RVM is not a function, selecting rubies with 'rvm use ...' will not work. You need to change ...
0
votes
0answers
175 views

msfconsole not running Ignoring bcrypt-3.1.11

I have problems when running metasploit on Ubuntu LTS 14:04. I've created a database msfconsole and run postgresql but still does not work. root@evan:/home/evan# msfconsole Ignoring bcrypt-3.1.11 ...
0
votes
0answers
20 views

RailsEnv misspelled or defined by a module not included in the server configuration

I am following this link http://blog.redpanthers.co/2015/10/how-to-deploy-a-rails-app-with-passenger-and-apache-in-ubuntu-14-04/ in order to install ruby on rails with rvm and passenger. I was fine ...
0
votes
0answers
85 views

Cannot load such file bcrypt_ext

While using metasploit i'm getting this issue /.rvm/gems/ruby-2.1.8@metasploit-framework/gems/bcrypt-3.1.11/lib/bcrypt.rb:16:in `require': incompatible library version - /home/.rvm/gems/ruby-2.1.8@...
0
votes
0answers
80 views

cannot load such file — rspec/expectations (LoadError)

I got this when I run rspec spec its a sample project, and its very simple too but I couldnt found an answer for this case, I think it's an error in installation. Here is my tree and my files. Thanks ...
0
votes
0answers
22 views

Cannot Install Ruby1.9.1

I've added some ppa for Kali Linux tools in Ubuntu by the help of this answer. But now I cannot install ruby1.9.1 to my machine. Output is as below: Reading package lists... Done Building dependency ...
0
votes
0answers
28 views

Unmet ruby dependency, but ruby installed

In an Ubuntu 14.04 server, I needed a recent version of ruby-passenger. The version I need is not available in the repositories yet (4.0.53-1). I obtained a deb and trying installing it with dpkg. ...
0
votes
0answers
12 views

Cannot find my software in “Open With” list

On Ubuntu, I would like to open a xxx.shoes file using Ruby Shoes, but it is not displayed in the "Open with" list. I added the following file: /usr/share/applications/shoes.desktop more /usr/share/...
0
votes
0answers
15 views

VPS with multiple hosts postfix configuration

a VPS running Ubuntu 14.04 has postfix installed for outgoing e-mail. File /etc/postfix/main.cf has the myhostname value set to one specific MX record. This VPS is intended to host multiple Rails ...
0
votes
0answers
213 views

Ruby/RVM with @global gem - bundle run fails with `require': cannot load such file — bundler (LoadError)

I study linux for 1 month. While I tried to make all steps from Migrating from MySQL to Postgres on Heroku I've got an error I could not handle. When I try to install the mysqltopostgres gem from ...
0
votes
0answers
108 views

two postgres have been installed, remove both

I have previously installed postgres 9.1 by How To Use PostgreSQL with Your Ruby on Rails Application on Ubuntu 14.04 It was installed correctly and my app was working fine, but today its not working ...
0
votes
0answers
103 views

Install chruby and ruby-install so that they update

I want to install chruby and ruby-install to manage my ruby installs. However, it seems that they cannot be obtained via apt-get nor from a .deb file. Is there a way to install these so that they ...
0
votes
0answers
78 views

Vagrantfile print statements

I have this in my vagrant file, how can I get it to print only when someone does 'vagrant up', as it is now it prints out for every vagrant command. Print actual system string for preview p "...
0
votes
0answers
21 views

Tk with Ruby v2.0 on Ubuntu with RVM

Is there anyway I can get Tk to work on Ubuntu 14.04 when using rvm? I've tried every method I've found online to no avail.
0
votes
0answers
209 views

Trouble installing Ruby

I run - sudo gem install pg -- --with-pg-config=/opt/metasploit/postgresql/bin/pg_config Which results Building native extensions with: '--with-pg-config=/opt/metasploit/postgresql/bin/pg_config'...
0
votes
0answers
66 views

Simplest Way to do a Local Home Rails Server on Ubuntu 14.04 without Subscription Services

I've been browsing many tutorials with regards to deploying a rails app unto a server; however , many of these articles require something like "Digital Ocean" VM's to run. I just want a very simple ...
0
votes
0answers
21 views

looking for a nagios or ruby expert to help me get away from bad bash practices

Granted the problem: I want to; mount, copy files, and unmount; automagically when drive is connected, I see the following 2 options (i'm sure there are more concise ways I'm not aware of).. maybe ...
0
votes
0answers
49 views

ERROR with gem for a ruby tool?

I am trying to install a tool script called bio-polyploid-tools and I am getting this error after command sudo gem install bio-polyploid-tools sammanmahmoud@samman[bioruby-polyploid-tools-master] ...
0
votes
0answers
120 views

I can't run Ruby script in Aptana Studio 3

I can't run my script in Aptana Studio 3. It is simple Ruby Srcipt like : BEGIN{ puts "And my adventure with Ruby already started." } puts "Hello World!" END{ puts "Its is the end of this GemUno ...
0
votes
0answers
171 views

Redmine not running on apache2 as rails app , just show 'Index Of' header and library content.

I trying to run redmine3.04 on apache2. My OS is ubuntu 12.04 - opensource. the app run correctly locally : /usr/share/redmine$ bundle exec rails server webrick -e production output: => Booting ...
0
votes
0answers
118 views

Start Rails Application on Boot Ubuntu

I am trying to make my application Ruby on Rails (OpenProject) starting with the system boot, but to test the script as root, returns me the error: /usr/bin/env:ruby: No such file or directory. My ...
0
votes
0answers
117 views

Problems installing Ruby 1.9.1 on Ubuntu 12.04

I am installing Ruby 1.9.1 on Ubuntu 12.04 and it seems to install an old version of gem; I don't understand why or how to fix this. This is what I do: $ sudo apt-get install ruby1.9.1 $ ruby --...
-2
votes
0answers
30 views

plzz help kernel_require.rb:55:in `require'

I am receiving the following error when I run the ./wpxf.rb file I do not know, whether is this the imbalance of the script or the interpreter Ruby.