A dynamic, open source programming language with a focus on simplicity and productivity. (quote: ruby-lang.org)

learn more… | top users | synonyms

1
vote
1answer
23 views

Cant install Ruby on Ubuntu 16.04 LTS

Can't install Ruby via sudo apt-get install ruby-full The following packages have unmet dependencies : Ruby, ruby-dev, libtcltk-ruby, ri E: Unable to correct problems, you have held broken ...
28
votes
2answers
14k views

How to install jekyll?

According to the jekyll site, this is how you make a new website with jekyll: ~ $ gem install jekyll ~ $ jekyll new myblog ~ $ cd myblog ~/myblog $ jekyll serve gem install jekyll didn't work, nor ...
0
votes
1answer
60 views

Jekyll not working on 16.04

My Google search showed that this question was asked here and then deleted by the asker, so I'm not sure if I'm asking something stupidly obvious. I'm trying to start a jekyll project after upgrading ...
0
votes
1answer
14 views

Installing Ruby On Rails shows errors on line 168

I am trying to install ruby on rails on my me elementary OS 0.3.2 Freya. and now i am seeing the following errors on my terminal. even if when i restart the terminal the errors shows on the first ...
-1
votes
0answers
17 views

How to install ruby on rails on elementary os? [closed]

I am new on elementary os. I want to install ruby on rails on my elementary os. can anyone please tell me how can i install ruby on rails on elementary os. Thank You
0
votes
0answers
11 views

Integrating RVM with LXTerminal, but no “x-terminal-emulator” in lubuntu-rc.xml file

I'm trying to use this instruction to automatically load RVM and the profiles, but there's no "x-terminal-emulator" in my ~/.config/openbox/lubuntu-rc.xml file. Should I use this command for it to ...
1
vote
1answer
13 views

How to install QtRuby + Qt4 on Ubuntu 14?

I wish to program in ruby in QtCreator. If I'm right, I need to install QtRuby + Qt4, but with no success on Ubuntu 14. How to do? Thanks!
0
votes
3answers
60 views

How to downgrade Ruby on Ubuntu?

I'm running Ubuntu 16.04. My ruby version is: ruby 2.3.0p0 (2015-12-25) [x86_64-linux-gnu] How can I downgrade ruby to version 2.1 to be in line with the rest of my development team (some of our ...
0
votes
1answer
67 views

Just installed Ubuntu/Ruby, cant create rails project

so I've just started using Ubuntu a few days ago, started trying to get an IDE working for Ruby on Rails developement, downloaded/installed everything from scratch. I found out the first version of ...
0
votes
0answers
62 views

installing for Chromebook converted to Linux?

I just got Linux on my Chromebook. for now, Chromebook is my only option to use Linux as my desktop is out of commission. I started using The Odin Project, and I need a bunch of things on my ...
34
votes
3answers
54k views

How to find and install latest Ruby version using RVM?

I finally got RVM working and now I would like RVM to install the latest stable ruby version. In the tutorial I am using they installed ruby 1.9.3 with command : rvm install 1.9.3 Now I want to ...
0
votes
0answers
107 views

Can't install json 1.8.1

I'm trying to install json gem using ruby 2.2.3 (I've tried with other oversions), and I always get the same error: Fetching: json-1.8.1.gem (100%) Building native extensions. This could take a ...
0
votes
0answers
21 views

Any harm of doing 'Run command as login shell'

I've installed RVM and everytime I execute rvm use <version>, terminal complains me that RVM is not a function, selecting rubies with 'rvm use ...' will not work. You need to change ...
0
votes
0answers
93 views

msfconsole not running Ignoring bcrypt-3.1.11

I have problems when running metasploit on Ubuntu LTS 14:04. I've created a database msfconsole and run postgresql but still does not work. root@evan:/home/evan# msfconsole Ignoring bcrypt-3.1.11 ...
10
votes
4answers
24k views

How do I install ruby-rvm?

I want to install a rails environment on Ubuntu 11.04. I tried: $ sudo apt-get install ruby-rvm But got the error: Unable to locate package ruby-rvm My other PC has Ubuntu 11.10, and this ...
0
votes
0answers
19 views

RailsEnv misspelled or defined by a module not included in the server configuration

I am following this link http://blog.redpanthers.co/2015/10/how-to-deploy-a-rails-app-with-passenger-and-apache-in-ubuntu-14-04/ in order to install ruby on rails with rvm and passenger. I was fine ...
0
votes
0answers
49 views

Cannot load such file bcrypt_ext

While using metasploit i'm getting this issue /.rvm/gems/ruby-2.1.8@metasploit-framework/gems/bcrypt-3.1.11/lib/bcrypt.rb:16:in `require': incompatible library version - ...
0
votes
1answer
110 views

Trouble removing ruby 2.3.0p0 from Ubuntu

I need to install ruby via rvm. I already have it installed via packet manager though, and now I want to remove that version. So far so good, removing stuff with apt-get remove isn't hard. BUT after I ...
0
votes
3answers
52 views

New to Ubuntu + Ruby Development + selenium

I am an automation engineer, I've been using java bindings with selenium web-driver on a windows machine for development of automated tests, however, I am switching to Ruby for developing automated ...
0
votes
0answers
48 views

cannot load such file — rspec/expectations (LoadError)

I got this when I run rspec spec its a sample project, and its very simple too but I couldnt found an answer for this case, I think it's an error in installation. Here is my tree and my files. Thanks ...
0
votes
1answer
55 views

AH00112: Warning: DocumentRoot [/home/rails/testapp/public] does not exist

I followed this link https://www.digitalocean.com/community/tutorials/how-to-deploy-a-rails-app-with-passenger-and-apache-on-ubuntu-14-04 to install ruby on rails with passenger on ubuntu 14.04 and I ...
3
votes
2answers
7k views

OpenSSL installed, but Ruby unable to require it

I'm trying to setup github-pages on my Ubuntu laptop, and following the guide provided by Github I have to install the bundler package; giving the command ~$ gem install bundler returns me this ...
0
votes
1answer
83 views

Redmine installation on 14.04

I have installed Ubuntu 14.04 server and want to install fresh Redmine. I faced several problems while installing, and still no LUCK. I found some documentations regarding installation but they are ...
0
votes
0answers
20 views

Cannot Install Ruby1.9.1

I've added some ppa for Kali Linux tools in Ubuntu by the help of this answer. But now I cannot install ruby1.9.1 to my machine. Output is as below: Reading package lists... Done Building dependency ...
4
votes
4answers
10k views

foreman: command not found

I am following this tutorial of Heroku. I installed foreman with sudo gem install foreman but when I try to use this in the terminal with command foreman this returns foreman: command not ...
11
votes
4answers
14k views

Install Ruby 2.0 with OpenSSL and ReadLine support

I have a fresh Ubuntu 12.04 VM, and I would like to install Ruby 2.0.0-p0. I am able to get Ruby installed easily enough, but I am unable to get gems to work. $ gem install bundler ERROR: Loading ...
0
votes
0answers
85 views

Install chruby and ruby-install so that they update

I want to install chruby and ruby-install to manage my ruby installs. However, it seems that they cannot be obtained via apt-get nor from a .deb file. Is there a way to install these so that they ...
0
votes
1answer
180 views

can't install any new packages

I have been trying to install ruby on rails and I run into failures in all directions. I finally went into the package manager and right away it detected an issue and asked me if I wanted to resolve ...
2
votes
2answers
17k views

Can't install a Ruby package: Failed to build gem native extension

I installed ruby 2.1.0 and package pdfbeads on 32bit 12.04 last year following the blog https://railssavvy.wordpress.com/2012/06/02/install_ruby_and_rails/, and it worked. Now it seems that I have ...
0
votes
0answers
25 views

Unmet ruby dependency, but ruby installed

In an Ubuntu 14.04 server, I needed a recent version of ruby-passenger. The version I need is not available in the repositories yet (4.0.53-1). I obtained a deb and trying installing it with dpkg. ...
0
votes
0answers
11 views

Cannot find my software in “Open With” list

On Ubuntu, I would like to open a xxx.shoes file using Ruby Shoes, but it is not displayed in the "Open with" list. I added the following file: /usr/share/applications/shoes.desktop more ...
-1
votes
2answers
55 views

Trying to install Rails on Ruby and getting bash error during installation

I get this error when I run \curl -L https://get.rvm.io | bash -s stable: Command 'bash' is available in '/bin/bash' The command could not be located because '/bin' is not included in the PATH ...
1
vote
1answer
29 views

VirtualBox: Share whole Ubuntu drive on Windows (Host)

I currently have Ubuntu in VirtualBox. Currently I do web development in the Ubuntu since its easier to run Ruby on Rails in Linux then its on windows. But I had the idea to share the whole ubuntu ...
0
votes
0answers
14 views

VPS with multiple hosts postfix configuration

a VPS running Ubuntu 14.04 has postfix installed for outgoing e-mail. File /etc/postfix/main.cf has the myhostname value set to one specific MX record. This VPS is intended to host multiple Rails ...
20
votes
5answers
24k views

Install ruby 2.0 without ruby-switch?

I'm finding the task of installing ruby 2.0 on the latest Ubuntu 14.04 rather frustrating. I'm aware that I could forgo the packages and install from source - but I'd far rather install a package - ...
1
vote
1answer
2k views

Installing Ruby On Rails stack on Ubuntu? [duplicate]

I'm looking to install ruby on rails on Ubuntu similarly to how its described in the RailsIntaller.org for MAC/Windows. Instructions and guides that I've seen to do this on Ubuntu seem to be all over ...
0
votes
1answer
297 views

How do I use the latest Sass and Compass?

I've had problems with multiple ruby versions installed, couldn't install animation gem properly. The latest Compass has it included so it might solve it for me. I don't need ruby for anything else so ...
3
votes
1answer
144 views

How to autorun a ruby script in Ubuntu?

How hard can it possibly be to run a ruby script on startup?! Fairly tough apparently: I'm using rvm and running ruby 2.3.0. which ruby returns /home/ubuntu/.rvm/rubies/ruby-2.3.0/bin/ruby The ...
2
votes
1answer
149 views

Why did lolcat stop working after installing rvm?

After recently doing something that involved installing rvm, this error occurs when I try using lolcat. /home/max/.rvm/rubies/ruby- ...
0
votes
3answers
45 views

Java Process takes more memory and Machine stop working

I am new to Linux, I am using Ubuntu 14.04LTS, But suddenly my machine stop working.I run $ free -m and get results total used free shared buffers cached Mem: 7897 ...
1
vote
0answers
51 views

Unable to install Github-Pages with gem?

I've been trying to install github-pages using gem. I have Ruby v. 2.1.2: ✦ ruby -v ruby 2.1.2p95 (2014-05-08 revision 45877) [x86_64-linux] I installed Ruby using RVM and I've set 2.1.2 as my ...
0
votes
0answers
28 views

Upstart Ruby version issue

I am trying to get Upstart to fire up Sidekiq (https://github.com/mperham/sidekiq/wiki/Deploying-to-Ubuntu). I can manually start it but the same command fails in the Upstart script. I have piped ...
1
vote
1answer
32 views

Keyboard shortcut for ruby script

I have some problem here when I'm trying to make a keyboard shortcut for my ruby script. So the first step I've do for it was to make a alias and add that command for alias on file .bashrc alias ...
0
votes
1answer
26 views

How do I symlink this file?

I'm really confused. I'm trying to install rvm ( Ruby's version manager ) but keep getting an error message. Something about how /etc/pki/tls/certs/ca-bundle.crt not found. I believe the security ...
0
votes
0answers
192 views

Ruby/RVM with @global gem - bundle run fails with `require': cannot load such file — bundler (LoadError)

I study linux for 1 month. While I tried to make all steps from Migrating from MySQL to Postgres on Heroku I've got an error I could not handle. When I try to install the mysqltopostgres gem from ...
0
votes
0answers
99 views

two postgres have been installed, remove both

I have previously installed postgres 9.1 by How To Use PostgreSQL with Your Ruby on Rails Application on Ubuntu 14.04 It was installed correctly and my app was working fine, but today its not working ...
1
vote
1answer
409 views

I want to install vim with ruby support on Ubuntu 15.04 vivid vervet

I have installed Ubuntu 15.04 and am trying to set up my Ruby on Rails environment to program. I use vim as the IDE and it comes pre-installed without ruby support: vim --version | grep -i ruby ...
6
votes
3answers
10k views

how to set default to ruby 2.1.2

I have ruby 1.9.3 and 2.1.2, by opening the terminal by default it uses ruby 1.9.3 but i wanted to use ruby 2.1.2, can you please help me about., how to set default to ruby 2.1.2..?? Thank you!
0
votes
0answers
40 views

'rake aborted!' Stuck on gitimmersion tutorial

I am going through the Git Immersion tutorial on Lab 21 here: http://gitimmersion.com/lab_21.html After I had installed Rake and created the 'Rakefile' with the contents: !/usr/bin/ruby -wKU task ...
-1
votes
1answer
17 views

can i copy ruby distribution from utopic to vivid?

I am shifting to vivid from utopic. I have a working ruby environment installed with rvm of size around 1.7 GB. Is there a way i can use this(or some part of it) in my newly installed vivid? For ...