A dynamic, open source programming language with a focus on simplicity and productivity. (quote: ruby-lang.org)

learn more… | top users | synonyms

1
vote
1answer
1k views

How to get a bundler enabled rails app running as a service with upstart?

I can get some random shell script to run as a service...that's not the problem. I think it's related to environment variables given some of the google-ing I did. Either a list of required rails ...
1
vote
5answers
2k views

How to install Ruby on Rails and MySql?

How to install Ruby on Rails and MySql on my Ubuntu 10.04 OS?
1
vote
1answer
144 views

What version of Ruby am I really running?

Im running Ubuntu 12.04 lts and have installed Ruby via RVM. Problem is when I just type ruby -v into the terminal it says that my Ruby Version is 1.8.7 and using the shotgun gem for Sinatra it ...
1
vote
2answers
140 views

Ruby: Problem with Different Versions

I posted this question before but I had 11.04 which is not supprted. So now I updated to 11.10, but still the problem is not solved. I want to use ruby 1.9.1 . The problem I am facing is shown below. ...
1
vote
4answers
5k views

bundle command gives permission denied - /var/lib/gems How to overcome?

From trying to do bundle I get: $ gem install bundler Fetching: bundler-1.2.0.gem (100%) ERROR: While executing gem ... (Errno::EACCES) Permission denied - /var/lib/gems
1
vote
3answers
205 views

How do I get the ruby prompt with Ruby 1.8 package

I have installed ruby1.8 and ruby1.8-dev packages but it doesnt respond to the ruby command at the command line. ruby The program 'ruby' is currently not installed. You can install it by typing: ...
1
vote
1answer
380 views

Installed Ruby 1.9.2 but new gems won't create scripts into /usr/bin

I had previously ruby 1.8 on my Ubuntu 10.10, which I removed through Synaptics. Then I have installed ruby 1.9.1 also via Synaptics (which is then saying that itself is version 1.9.2). Then I ...
1
vote
1answer
272 views

How do I configure Ruby on Rails to Always use mySQL as the default database?

How do i configure Ruby on Rails to always use mySQL as the default database? I am a newbie and i just installed Ruby on Rails and mySQL and by default ROR uses sqlite3, but when I configure the db ...
1
vote
2answers
1k views

Readline not compiled by default - Causing `require': no such file to load — readline

When trying to install ruby 1.9.2 on Ubuntu 10.04 (64-bit), I get the following error after performing the following steps: Install Dependencies ./configure to create make file Make Make Install ...
1
vote
2answers
33 views

A Software Center review claims Ruby has a virus. Is it accurate?

I'm working on a Javascript webapp and trying to figure out how to add documentation. It seems like the only option is to install something that lives on a server. I thought maybe I'd try JSDuck. It ...
1
vote
1answer
3k views

How to install rubygems in Ubuntu 12.04 with Ruby 1.9.3

So I used these commands: sudo apt-get install ruby 1.9.3 cd /etc/alternatives sudo ln -sf /usr/bin/ruby1.9.3 ruby from ...
1
vote
1answer
817 views

Why do I need to run “/bin/bash --login”

I have just setup a new Ubuntu 13.10 server with ruby 2.1.1 installed through rvm. The problem is that whenever I switch to the user "rails" (the user I installed ruby and rails with) I have to run ...
1
vote
1answer
2k views

How to uninstall rubymine from UBUNTU

I was trying to upgrade from RubyMine 5.4.3.2.1 to 6 for that I was trying to uninstall RubyMine 5.4.3.2.1. I removed RubyMine directory from where I installed RubyMine. Now everytime I need to run ...
1
vote
2answers
723 views

Unable to Install Guard

I've seen Guard and it's usefulness in web development and would like to install it. Naturally, I expected to be able to use sudo gem install guard to do so (yes, it is a Ruby Gem). However the ...
1
vote
3answers
2k views

How do you login into /bin/bash automatically?

Im on 12.04 LTS and am doing to Ruby on Rails development. When I start up my terminal and type in ruby -v it will list my Ruby as 1.8.7. When I type in /bin/bash --login then ruby -v will list it as ...
1
vote
1answer
6k views

Ruby IDE in Ubuntu [duplicate]

Could you people help me by saying a good Ruby compatible IDE in Ubuntu and its installation and settings with Ruby environment? I really need that one. I don't want Rails version,only Ruby 1.9.3. I ...
1
vote
1answer
1k views

Redmine - backlogs - No such file to load — nokogiri

I'm trying to install backlogs 0.9.9 plugin for redmine 2.1.2 under ubuntu 12.10. Following the Backlogs installation guide remine_install_path$ RAILS_ENV=production bundle exec rake db:migrate ...
1
vote
2answers
778 views

Contacting Pulse Audio over dbus?

I am trying to write a basic volume application. Since I'm writing this in Ruby I don't want to extend the C library or use ffi, instead I trying to write this with ruby-dbus I got the Address ...
1
vote
1answer
35 views

Is there an online documentation repository for ruby like it is for Matlab? [closed]

Is there an online documentation repository for ruby like it is for Matlab? A site that documents the functions and objects, their uses, parameters, etc? Matlab online Documentation
1
vote
1answer
66 views

Why does everyone insist that Ruby be installed via rvm and not by compiling?

I just installed Ruby on my 12.04 machine by compiling from the tarball file I got from the official Ruby site. I want to know why doing that was a bad idea if I don't plan on using multiple versions ...
1
vote
1answer
242 views

How can I easily install ruby on rails? [duplicate]

Possible Duplicate: How do I set up Ruby on Rails? How can I easily install RVM, ruby 1.9.3, rubygems, passenger and rails all in one go ?
1
vote
2answers
696 views

How to auto indent the characters of rb, erb, .html.erb files?

In mac using Text - Mate we can easily auto - indent the characters in the file for Ruby on Rails code in various rb,erb or html.erb files. I am searching for a plugin for GEdit for the same purpose ...
1
vote
1answer
129 views

How to decide which version of Ruby to install, ruby1.8 or ruby1.9.1?

I am thinking about learning the basics of Ruby, so I want to install the ruby interpreter, irb, etc., on my Ubuntu 11.10 box. I quickly found that there are two main branches of ruby -- the 1.8 ...
1
vote
1answer
651 views

Not able to start juggernaut server as a background processs/service

I am using ruby on rails application to implement chat. I am not able to setup juggernaut server in production mode. I followed this guide to setup redis. and its working perfectly fine. Then I ...
1
vote
1answer
326 views

Ruby compilation error in Ubuntu 10

I've got a vps which runs solusVM. I'm now trying to install ruby 1.9.2 in it. I'm following this guide: After I run this command: apt-get update apt-get -y install build-essential zlib1g ...
1
vote
1answer
731 views

bundle install permissions denied

Hello I am working on a new ubuntu machine and when I run tasks like: bundle install or rvm get head I get errors like: Downloading https://get.rvm.io bash: line 709: /usr/local/rvm/RELEASE: ...
1
vote
2answers
66 views

Daemonize process with autostart

I have simple script written in Ruby. I'd like to run as a background task (daemon process or service). What is more want to have control over it so that I can start and stop it. It will be perfect ...
1
vote
1answer
508 views

Ubuntu 12.04, ruby installation

I'm new to Ubuntu and Ruby and I have a problem, which seems to be strange. I needed to install Ubuntu because of problems with Ruby on Windows. I've installed Ruby, v. 1.9.3 (the same as I had on ...
1
vote
1answer
72 views

How do I launch my script from a launcher?

I have my custom script in Ruby with read permission, which starts with: #!/usr/bin/env ruby I can run that script from the terminal by typing that path. I added a file with .desktop extention to ...
1
vote
1answer
121 views

Where is my ruby installed when i install through RVM?

right now i am running ruby 1.9 , which i installed using RVM . I needed that to run my redmine 2.4.2 , since i had trouble using 1.8. Now i need to configure my passenger mod to point to ruby 1.9 ...
1
vote
1answer
919 views

GitLab Omnibus Ubuntu 12.04

I am trying to build GitLab from the Omnibus project in my Ubuntu 12.04 64-bit following this link After issuing sudo apt-get install ruby ruby-bundler I downloaded the source from here and after ...
1
vote
1answer
5k views

install libmysqlclient-dev 5.6

I can't use the mysql ruby gem because I get this error: Incorrect MySQL client library version! This gem was compiled for 5.6.15 but the client library is 5.5.34. (RuntimeError) apt-get is ...
1
vote
1answer
3k views

VPS apache config - Invalid command 'PassengerDefaultRuby' after adding latest passenger gem

used to have this list of rubies in my vps: ruby-1.9.2-p320 [ i686 ] =* ruby-1.9.3-p194 [ i686 ] ruby-1.9.3-p374 [ i686 ] ruby-1.9.3-p392 [ i686 ] today I installed a new app on this vps ...
1
vote
1answer
508 views

Upstart - Bluepill not starting without sudo

I have an upstart service to start bluepill (Ruby gem to monitor processes). The upstart config is below. description "Start up the bluepill service" start on runlevel [2] stop on runlevel [016] ...
1
vote
1answer
385 views

Issue With Upstart And RVM Gem?

Im trying to get a RVM gem to run via upstart... I can't seem to get it to work: siriserver.conf #siriserver start on filesystem or runlevel [2345] stop on runlevel [!2345] respawn exec ...
1
vote
2answers
880 views

Launching a Ruby Script from the bash does not work, even with the shebang

I am using Ubuntu 12.04 64 bits. I've recently installed the ruby1.9.1 package and the wx-ruby gem using : sudo gem install wxruby-ruby19 in order to install the ruby1.9 compatible version. So I ...
1
vote
1answer
636 views

error when installing rmagic gem on Ubuntu 12.04 for Ruby on Rails

I am trying to get my Ruby on Rails application working and installing RMagic gem. But I get an error that says "Can't install RMagick 2.13.1. Can't find the ImageMagick library or one of the ...
1
vote
1answer
438 views

How big is the mono runtime?

How big is the mono runtime, and how does it compare in size to other popular runtimes like python, ruby and java?
1
vote
1answer
1k views

tk installation doesn't work for ruby1.9.1

Ok, this is what I did before I landed onto a terminal with a bunch of error messages... First, I installed ruby1.9.1 using apt-get. (All of those ruby1.9.1 packages including ruby1.9.1-examples ...
1
vote
2answers
4k views

Install ruby 1.9.2-p180 via RVM on Ubuntu 12.04

I just upgraded to the newest Ubuntu release and this broke my ruby on rails setup. I would like to install ruby 1.9.2-p180 now via RVM: rvm install ruby-1.9.2-p180 This is cancelled due to some ...
1
vote
1answer
2k views

Default Ruby version set with RVM not recognized by system

I'm trying to get the system to use the Ruby version I've set with RVM. The following commands produce this output: $ rvm use 1.9.2 --default Using /usr/share/ruby-rvm/gems/ruby-1.9.2-p180 $ rvm ...
1
vote
3answers
357 views

How do I install Ruby 1.9.2 on Ubuntu without crashing?

I've been trying to set up Ruby on Rails for Ubuntu 11.10 following these instructions, but I can't get it to work. I'll follow the install guide all the way up to "rvm install ruby-1.9.2", and at ...
1
vote
1answer
310 views

Ruby Gems error with AtomicTV

I've been trying to run AtomicTV on my 10.04 install, but I've had some Ruby issues that I'm having trouble parsing and haven't been able to find help with via Google. I installed the Ruby gems ...
1
vote
1answer
18 views

I have trouble making a ruby file

I try to make a file but it said 'The file is not valid.' require "./lib/NAME.rb" require "test/unit" class TestNAME < Test::Unit::TestCase def test_sample ...
1
vote
0answers
69 views

Confusion for mime files: magic, magic.mgc, magic.mime

I'm using Ubuntu. I'm trying to use ruby gem 'shared-mime-info' for an application I'm writing. I understand that magic.mgc is a compiled version of magic file which has magic number definitions for ...
1
vote
1answer
157 views

Bundle install fatal error

I am migrating my project over to a new machine and I am having trouble running bundle install on the machine I am trying to use. When I run: bundle install I get this error: Unfortunately, a ...
1
vote
1answer
243 views

Package 'ruby1.8-dev' has no installation candidate [duplicate]

How can I solve this error? sudo apt-get update sudo apt-get install ruby1.8-dev sudo apt-get install mysql-server sudo apt-get install libgemplugin-ruby Currently I am getting this error: sudo ...
1
vote
1answer
63 views

FATAL: role “roelof” does not exist

I did install postgresql according to the manual. But as soon as I do rails server I see the above error. Roelof Edit 1: the sudo -u postgres createuser roelof did the trick but now when I do rake ...
1
vote
1answer
29 views

How to install postgressql-server

For ruby development on Heroku I need to use postgresql, but when I do bundle install I see this message: You need to install postgresql-server-dev-X.Y for building a server-side extension or ...
1
vote
1answer
1k views

How to install ruby mine Ubuntu [duplicate]

I have already install RVM. Now I have download RubyMine-6.3.2.tar.gz From here http://www.jetbrains.com/ruby/download/ , But still I am confuse How can I install it on my system. I am using Ubuntu ...